aboutsummaryrefslogtreecommitdiff
path: root/devel/portmk/Mk
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-09-19 08:57:43 +0000
committerClement Laforet <clement@FreeBSD.org>2005-09-19 08:57:43 +0000
commit4a8a47415e32c2bab2b9a25edc2c67bd76837975 (patch)
tree489fb592efedfed355665231901a8293ebcbf095 /devel/portmk/Mk
parentefc03b4ae3f50ff887f2df081f62e630e3952847 (diff)
downloadports-4a8a47415e32c2bab2b9a25edc2c67bd76837975.tar.gz
ports-4a8a47415e32c2bab2b9a25edc2c67bd76837975.zip
Notes
Diffstat (limited to 'devel/portmk/Mk')
-rw-r--r--devel/portmk/Mk/bsd.apache.mk14
-rw-r--r--devel/portmk/Mk/bsd.port.mk4
2 files changed, 12 insertions, 6 deletions
diff --git a/devel/portmk/Mk/bsd.apache.mk b/devel/portmk/Mk/bsd.apache.mk
index bee676ac49c7..a67eea2608a3 100644
--- a/devel/portmk/Mk/bsd.apache.mk
+++ b/devel/portmk/Mk/bsd.apache.mk
@@ -16,6 +16,9 @@
# common*: common13, common20 and common21
# apr: deal with apr stuff ;-)
#
+.if defined(APACHE_COMPAT)
+USE_APACHE=yes
+.endif
# Print warnings
_ERROR_MSG= : Error from bsd.apache.mk.
@@ -29,15 +32,16 @@ AP_PORT_IS_MODULE= YES
#### for backward compatibility
.elif ${USE_APACHE:L} == yes
-APXS= ${LOCALBASE}/sbin/apxs
. if defined(WITH_APACHE2)
-APACHE_PORT?= www/apache20
+APACHE_PORT?= www/apache2
. else
APACHE_PORT?= www/apache13
. endif
APXS?= ${LOCALBASE}/sbin/apxs
+.if !defined(APACHE_COMPAT)
BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+.endif
#### End of backward compatibility
.else
@@ -257,7 +261,7 @@ IGNORE= ${_ERROR_MSG} apache${AP_CUR_VERSION} is installed (or APACHE_PORT is d
APACHE_VERSION= ${AP_CUR_VERSION}
.else
AP_CUR_VERSION= none
-. if !defined(${APACHE_PORT})
+. if !defined(APACHE_PORT)
#Fallback to smallest version...
APACHE_VERSION= ${AP_VERSION:C/\+//}
. endif
@@ -277,7 +281,9 @@ IGNORE?= PREFIX must be egal to APXS_PREFIX.
AP_BUILDEXT= la
PLIST_SUB+= APACHEMODDIR="libexec/apache2" \
APACHEINCLUDEDIR="include/apache2"
-APACHE_PORT= www/apache${APACHE_VERSION}
+# XXX We postpone www/apache2 => www/apache20 migration
+#APACHE_PORT= www/apache${APACHE_VERSION}
+APACHE_PORT= www/apache2
.elif ${APACHE_VERSION} == "21"
AP_BUILDEXT= la
PLIST_SUB+= APACHEMODDIR="libexec/apache${APACHE_VERSION}" \
diff --git a/devel/portmk/Mk/bsd.port.mk b/devel/portmk/Mk/bsd.port.mk
index b9e47e8db1d4..fbfb80a7dfec 100644
--- a/devel/portmk/Mk/bsd.port.mk
+++ b/devel/portmk/Mk/bsd.port.mk
@@ -1343,7 +1343,7 @@ PERL= ${LOCALBASE}/bin/perl
.include "${DEVELMKDIR}/bsd.tcl.mk"
.endif
-.if defined(USE_APACHE)
+.if defined(USE_APACHE) || defined(APACHE_COMPAT)
.include "${DEVELMKDIR}/bsd.apache.mk"
.endif
@@ -1763,7 +1763,7 @@ RUN_DEPENDS+= ${PERL5}:${PORTSDIR}/lang/${PERL_PORT}
.include "${DEVELMKDIR}/bsd.tcl.mk"
.endif
-.if defined(USE_APACHE)
+.if defined(USE_APACHE) || defined(APACHE_COMPAT)
.include "${DEVELMKDIR}/bsd.apache.mk"
.endif