aboutsummaryrefslogtreecommitdiff
path: root/devel/premake
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-28 11:45:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-28 11:45:56 +0000
commit0a32dd175fb298cdb02d1e98c0d2647a6ff12d61 (patch)
tree74a3c3a96fe3c02a15f6125cf8c9394fe12a660b /devel/premake
parent71c26bead8b9dc727ec662be958840a20f7b9475 (diff)
downloadports-0a32dd175fb298cdb02d1e98c0d2647a6ff12d61.tar.gz
ports-0a32dd175fb298cdb02d1e98c0d2647a6ff12d61.zip
Notes
Diffstat (limited to 'devel/premake')
-rw-r--r--devel/premake/Makefile28
-rw-r--r--devel/premake/distinfo2
-rw-r--r--devel/premake/files/patch-Premake.make58
-rw-r--r--devel/premake/files/patch-Src::posix.c44
-rw-r--r--devel/premake/pkg-descr5
5 files changed, 137 insertions, 0 deletions
diff --git a/devel/premake/Makefile b/devel/premake/Makefile
new file mode 100644
index 000000000000..fe4d8cc3558d
--- /dev/null
+++ b/devel/premake/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: premake
+# Date created: 2004-03-25
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= premake
+PORTVERSION= 1.6.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= premake
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Writes build scripts
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/Premake-${PORTVERSION}
+USE_GMAKE= yes
+PLIST_FILES= bin/premake
+USE_REINPLACE= yes
+MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
+
+do-install:
+ @${INSTALL} ${WRKSRC}/premake ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/premake/distinfo b/devel/premake/distinfo
new file mode 100644
index 000000000000..61c2ccb17762
--- /dev/null
+++ b/devel/premake/distinfo
@@ -0,0 +1,2 @@
+MD5 (premake-src-1.6.1.zip) = 3833bcf3ecd49b8bf90a4a431e825a82
+SIZE (premake-src-1.6.1.zip) = 140011
diff --git a/devel/premake/files/patch-Premake.make b/devel/premake/files/patch-Premake.make
new file mode 100644
index 000000000000..4bc4185a181b
--- /dev/null
+++ b/devel/premake/files/patch-Premake.make
@@ -0,0 +1,58 @@
+--- Premake.make.orig Tue Feb 24 21:49:57 2004
++++ Premake.make Thu Mar 25 21:03:11 2004
+@@ -8,13 +8,13 @@
+ TARGET =
+
+ ifeq ($(CONFIG),Debug)
+- CFLAGS += --no-rtti --no-exceptions
+- LDFLAGS += -ldl
++ CFLAGS += --no-exceptions
++ LDFLAGS +=
+ TARGET = premake
+ endif
+ ifeq ($(CONFIG),Release)
+- CFLAGS += --no-rtti --no-exceptions -Os
+- LDFLAGS += -ldl
++ CFLAGS += --no-exceptions -Os
++ LDFLAGS +=
+ TARGET = premake
+ endif
+ CXXFLAGS=$(CFLAGS)
+@@ -23,37 +23,21 @@
+ -@if [ ! -d obj ]; then mkdir obj; fi
+ @echo $(notdir $<)
+ @$(CXX) $(CXXFLAGS) -MD -o $@ -c $<
+- @cp obj/$*.d obj/$*.P; \
+- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
+- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
+- rm -f obj/$*.d
+
+ obj/%.o : %.cpp
+ -@if [ ! -d obj ]; then mkdir obj; fi
+ @echo $(notdir $<)
+ @$(CXX) $(CXXFLAGS) -MD -o $@ -c $<
+- @cp obj/$*.d obj/$*.P; \
+- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
+- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
+- rm -f obj/$*.d
+
+ obj/%.o : %.cxx
+ -@if [ ! -d obj ]; then mkdir obj; fi
+ @echo $(notdir $<)
+ @$(CXX) $(CXXFLAGS) -MD -o $@ -c $<
+- @cp obj/$*.d obj/$*.P; \
+- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
+- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
+- rm -f obj/$*.d
+
+ obj/%.o : %.c
+ -@if [ ! -d obj ]; then mkdir obj; fi
+ @echo $(notdir $<)
+ @$(CC) $(CFLAGS) -MD -o $@ -c $<
+- @cp obj/$*.d obj/$*.P; \
+- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
+- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
+- rm -f obj/$*.d
+
+ OBJECTS = \
+ obj/premake.o \
diff --git a/devel/premake/files/patch-Src::posix.c b/devel/premake/files/patch-Src::posix.c
new file mode 100644
index 000000000000..8cdcc7e1586a
--- /dev/null
+++ b/devel/premake/files/patch-Src::posix.c
@@ -0,0 +1,44 @@
+--- Src/posix.c.orig Tue Feb 24 21:49:57 2004
++++ Src/posix.c Thu Mar 25 21:10:21 2004
+@@ -20,6 +20,9 @@
+
+ #if defined(__linux__)
+ const char* osIdent = "linux";
++#endif
++#if defined(__FreeBSD__)
++const char* osIdent = "linux";
+ #else
+ #error Unknown OS type.
+ #endif
+@@ -87,31 +90,7 @@
+ return 1;
+ }
+
+- FILE* file = fopen("/etc/ld.so.conf", "rt");
+- if (file == NULL) return 0;
+-
+- while (!feof(file))
+- {
+- // Read a line and trim off any trailing whitespace
+- char linebuffer[2048];
+- char* ptr;
+-
+- fgets(buffer, 2048, file);
+- ptr = &buffer[strlen(buffer) - 1];
+- while (isspace(*ptr))
+- *(ptr--) = '\0';
+-
+- if (findLib(lib, buffer))
+- {
+- fclose(file);
+- return 1;
+- }
+- }
+-
+- fclose(file);
+- return 0;
+ }
+-
+ //-----------------------------------------------------------------------------
+
+ int plat_generateUUID(char* uuid)
diff --git a/devel/premake/pkg-descr b/devel/premake/pkg-descr
new file mode 100644
index 000000000000..411b082bd6d5
--- /dev/null
+++ b/devel/premake/pkg-descr
@@ -0,0 +1,5 @@
+Describe your software project with a full-featured scripting language and let
+Premake write the build scripts for you. With one file your project can
+support both IDE-addicted Windows coders and Linux command-line junkies!
+
+WWW: http://premake.sourceforge.net