aboutsummaryrefslogtreecommitdiff
path: root/devel/premake
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-30 00:50:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-30 00:50:27 +0000
commit9545b8271c851830a3e9f2eae27bcc0c689d6b81 (patch)
treeeb1254978de53b1e5b722aef4b815d6750c540ec /devel/premake
parentfd14ac3b8b63042e8485eeaab11f96c4ae9f71c8 (diff)
downloadports-9545b8271c851830a3e9f2eae27bcc0c689d6b81.tar.gz
ports-9545b8271c851830a3e9f2eae27bcc0c689d6b81.zip
Notes
Diffstat (limited to 'devel/premake')
-rw-r--r--devel/premake/Makefile3
-rw-r--r--devel/premake/distinfo4
-rw-r--r--devel/premake/files/patch-Premake.make22
-rw-r--r--devel/premake/files/patch-Src-posix.c19
-rw-r--r--devel/premake/files/patch-Src::posix.c44
5 files changed, 24 insertions, 68 deletions
diff --git a/devel/premake/Makefile b/devel/premake/Makefile
index fe4d8cc3558d..699b1dc5f388 100644
--- a/devel/premake/Makefile
+++ b/devel/premake/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= premake
-PORTVERSION= 1.6.1
+PORTVERSION= 1.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= premake
@@ -19,7 +19,6 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/Premake-${PORTVERSION}
USE_GMAKE= yes
PLIST_FILES= bin/premake
-USE_REINPLACE= yes
MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
do-install:
diff --git a/devel/premake/distinfo b/devel/premake/distinfo
index 61c2ccb17762..3b562e1496d1 100644
--- a/devel/premake/distinfo
+++ b/devel/premake/distinfo
@@ -1,2 +1,2 @@
-MD5 (premake-src-1.6.1.zip) = 3833bcf3ecd49b8bf90a4a431e825a82
-SIZE (premake-src-1.6.1.zip) = 140011
+MD5 (premake-src-1.7.zip) = e018d8a3a42145530060b0043b530a3e
+SIZE (premake-src-1.7.zip) = 178976
diff --git a/devel/premake/files/patch-Premake.make b/devel/premake/files/patch-Premake.make
index 4bc4185a181b..ab381194eb18 100644
--- a/devel/premake/files/patch-Premake.make
+++ b/devel/premake/files/patch-Premake.make
@@ -1,23 +1,5 @@
---- Premake.make.orig Tue Feb 24 21:49:57 2004
-+++ Premake.make Thu Mar 25 21:03:11 2004
-@@ -8,13 +8,13 @@
- TARGET =
-
- ifeq ($(CONFIG),Debug)
-- CFLAGS += --no-rtti --no-exceptions
-- LDFLAGS += -ldl
-+ CFLAGS += --no-exceptions
-+ LDFLAGS +=
- TARGET = premake
- endif
- ifeq ($(CONFIG),Release)
-- CFLAGS += --no-rtti --no-exceptions -Os
-- LDFLAGS += -ldl
-+ CFLAGS += --no-exceptions -Os
-+ LDFLAGS +=
- TARGET = premake
- endif
- CXXFLAGS=$(CFLAGS)
+--- Premake.make.orig Mon Mar 29 18:33:15 2004
++++ Premake.make Mon Mar 29 18:33:35 2004
@@ -23,37 +23,21 @@
-@if [ ! -d obj ]; then mkdir obj; fi
@echo $(notdir $<)
diff --git a/devel/premake/files/patch-Src-posix.c b/devel/premake/files/patch-Src-posix.c
new file mode 100644
index 000000000000..f34c4c1993a6
--- /dev/null
+++ b/devel/premake/files/patch-Src-posix.c
@@ -0,0 +1,19 @@
+--- Src/posix.c.orig Sat Mar 27 05:00:55 2004
++++ Src/posix.c Tue Mar 30 02:47:55 2004
+@@ -89,13 +89,15 @@
+
+ int plat_findLib(const char* lib, char* buffer, int size)
+ {
++ FILE* file;
++
+ if (findLib(lib, "/usr/lib"))
+ {
+ strcpy(buffer, "/usr/lib");
+ return 1;
+ }
+
+- FILE* file = fopen("/etc/ld.so.conf", "rt");
++ file = fopen("/etc/ld.so.conf", "rt");
+ if (file == NULL) return 0;
+
+ while (!feof(file))
diff --git a/devel/premake/files/patch-Src::posix.c b/devel/premake/files/patch-Src::posix.c
deleted file mode 100644
index 8cdcc7e1586a..000000000000
--- a/devel/premake/files/patch-Src::posix.c
+++ /dev/null
@@ -1,44 +0,0 @@
---- Src/posix.c.orig Tue Feb 24 21:49:57 2004
-+++ Src/posix.c Thu Mar 25 21:10:21 2004
-@@ -20,6 +20,9 @@
-
- #if defined(__linux__)
- const char* osIdent = "linux";
-+#endif
-+#if defined(__FreeBSD__)
-+const char* osIdent = "linux";
- #else
- #error Unknown OS type.
- #endif
-@@ -87,31 +90,7 @@
- return 1;
- }
-
-- FILE* file = fopen("/etc/ld.so.conf", "rt");
-- if (file == NULL) return 0;
--
-- while (!feof(file))
-- {
-- // Read a line and trim off any trailing whitespace
-- char linebuffer[2048];
-- char* ptr;
--
-- fgets(buffer, 2048, file);
-- ptr = &buffer[strlen(buffer) - 1];
-- while (isspace(*ptr))
-- *(ptr--) = '\0';
--
-- if (findLib(lib, buffer))
-- {
-- fclose(file);
-- return 1;
-- }
-- }
--
-- fclose(file);
-- return 0;
- }
--
- //-----------------------------------------------------------------------------
-
- int plat_generateUUID(char* uuid)