aboutsummaryrefslogtreecommitdiff
path: root/devel/prepstools/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-23 13:21:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-23 13:21:45 +0000
commitd574d476ad4816b8114a3430d1fd55d2649b822f (patch)
tree4926c3b698562006e34a92c91c85c4608f74cefd /devel/prepstools/Makefile
parent475a4cdd3b149716cdcb35bb3f51c98345f0c315 (diff)
downloadports-d574d476ad4816b8114a3430d1fd55d2649b822f.tar.gz
ports-d574d476ad4816b8114a3430d1fd55d2649b822f.zip
Notes
Diffstat (limited to 'devel/prepstools/Makefile')
-rw-r--r--devel/prepstools/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/prepstools/Makefile b/devel/prepstools/Makefile
new file mode 100644
index 000000000000..c0313be1a21f
--- /dev/null
+++ b/devel/prepstools/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: libpreps
+# Date created: Fri Mar 19 14:27:30 EET 2004
+# Whom: shadow@psoft.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpreps
+PORTVERSION= 1.6.6
+CATEGORIES= devel
+MASTER_SITES= http://webpages.charter.net/stuffle/linux/preps/
+DIST_SUBDIR= prep
+
+MAINTAINER= shadow@psoft.net
+COMMENT= Problem reporting system
+
+LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql7
+
+CONFLICTS= libpreps-1.9.*
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GNOME= glib12
+USE_LIBTOOL= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+=--with-pgsqldir=${LOCALBASE} --with-plpgsqldir=${LOCALBASE}
+
+INSTALLS_SHLIB= yes
+
+.if defined(WITHOUT_SERVER)
+CONFIGURE_ARGS+=--disable-server
+PKGNAMESUFFIX= -client
+PLIST_SUB+= SERVER="@comment "
+.else
+MAN1= create_prepsdb.1 update_prepsdb.1
+PLIST_SUB+= SERVER=""
+.endif
+
+.include <bsd.port.mk>