aboutsummaryrefslogtreecommitdiff
path: root/devel/prettygo
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-13 06:28:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-13 06:28:35 +0000
commited2b5ef916bee0ce42bc3d88a22704dfb5cd9278 (patch)
treed3f15a0ae5b9f9811f2d5a11203a182683863c88 /devel/prettygo
parentfa31c5aeb3c6a7e4eb7475ddcdcbe053d83da9f7 (diff)
downloadports-ed2b5ef916bee0ce42bc3d88a22704dfb5cd9278.tar.gz
ports-ed2b5ef916bee0ce42bc3d88a22704dfb5cd9278.zip
Notes
Diffstat (limited to 'devel/prettygo')
-rw-r--r--devel/prettygo/Makefile24
-rw-r--r--devel/prettygo/distinfo2
-rw-r--r--devel/prettygo/pkg-descr7
-rw-r--r--devel/prettygo/pkg-plist3
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/prettygo/Makefile b/devel/prettygo/Makefile
new file mode 100644
index 000000000000..673f887f32ac
--- /dev/null
+++ b/devel/prettygo/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pretty.go
+# Date created: 4 Nov, 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prettygo
+PORTVERSION= 20110611
+CATEGORIES= devel
+MASTER_SITES= http://files.roorback.net/
+DISTNAME= pretty.go-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= Pretty-printing package for go values
+
+FETCH_ARGS= -Fpr
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+USE_GO= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/prettygo/distinfo b/devel/prettygo/distinfo
new file mode 100644
index 000000000000..bab8009f7dbe
--- /dev/null
+++ b/devel/prettygo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pretty.go-20110611.tar.gz) = 87dddbc69cd93e718db565b8ad63e8a0dafc141d85d1d8fe3c0f05c11ef2c13d
+SIZE (pretty.go-20110611.tar.gz) = 4119
diff --git a/devel/prettygo/pkg-descr b/devel/prettygo/pkg-descr
new file mode 100644
index 000000000000..faa1bc2ba035
--- /dev/null
+++ b/devel/prettygo/pkg-descr
@@ -0,0 +1,7 @@
+Package pretty provides pretty-printing for go values. This is useful during
+debugging, to avoid wrapping long output lines in the terminal.
+
+This package also provides a convenience wrapper for each function in
+package fmt that takes a format string.
+
+www: https://github.com/kr/pretty.go
diff --git a/devel/prettygo/pkg-plist b/devel/prettygo/pkg-plist
new file mode 100644
index 000000000000..bc0b4efbdeea
--- /dev/null
+++ b/devel/prettygo/pkg-plist
@@ -0,0 +1,3 @@
+%%GO_LIBDIR%%/github.com/kr/pretty.go.a
+@dirrmtry %%GO_LIBDIR%%/github.com/kr
+@dirrmtry %%GO_LIBDIR%%/github.com