aboutsummaryrefslogtreecommitdiff
path: root/devel/projectcenter.app/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-07-11 11:23:23 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-07-11 11:23:23 +0000
commit61646e97b19991d80926efa2b59f4a8ff5871800 (patch)
tree065034c5ed85b5ff4d6b67606c770c8dc83d340f /devel/projectcenter.app/Makefile
parent1f40f2b106f7f175f454a326c9ec4db1713b10a0 (diff)
downloadports-61646e97b19991d80926efa2b59f4a8ff5871800.tar.gz
ports-61646e97b19991d80926efa2b59f4a8ff5871800.zip
Notes
Diffstat (limited to 'devel/projectcenter.app/Makefile')
-rw-r--r--devel/projectcenter.app/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/projectcenter.app/Makefile b/devel/projectcenter.app/Makefile
index 39861dd37b21..3d28631d9f1a 100644
--- a/devel/projectcenter.app/Makefile
+++ b/devel/projectcenter.app/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= projectcenter.app
-PORTVERSION= 0.2.0
+PORTVERSION= 0.2.4
CATEGORIES= devel
MASTER_SITES= http://www.projectcenter.ch/
DISTNAME= ProjectCenter-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/GNUstep/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep
-RUN_DEPENDS= ${LOCALBASE}/GNUstep/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep
+BUILD_DEPENDS= ${XGPSBUNDLEDIR}/libgnustep-xgps:${PORTSDIR}/x11-toolkits/gnustep-xgps
+RUN_DEPENDS= ${XGPSBUNDLEDIR}/libgnustep-xgps:${PORTSDIR}/x11-toolkits/gnustep-xgps
PREFIX= ${LOCALBASE}/GNUstep
WRKSRC= ${WRKDIR}/ProjectCenter
@@ -22,10 +22,12 @@ USE_NEWGCC= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
MAKE_ENV= ADDITIONAL_INCLUDE_DIRS="-I${WRKSRC}" \
- ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/freebsdelf/gnu-gnu-gnu-xgps"
+ ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu"
ALL_TARGET=
NO_MTREE= yes
+XGPSBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-xgps.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
+
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "i386"
@@ -34,13 +36,13 @@ GNU_ARCH= ix86
GNU_ARCH= ${MACHINE_ARCH}
.endif
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH}
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
# XXX This is ugly beyond measure. Don't tell anyone I did this.
post-extract:
${LN} -sf ${WRKSRC}/PCLib/*.h ${WRKSRC}/ProjectCenter
-# Quick workaround until I found out how to set the real path in the code
+# Quick workaround until I find out how to set the real path in the code
post-patch:
.for file in PCLib/PCBundleLoader.m ProjectCenter/PCAppController.m
${PERL} -pi -e "s:@\"/usr/GNUstep:@\"${PREFIX}:g" ${WRKSRC}/${file}