aboutsummaryrefslogtreecommitdiff
path: root/devel/pth-devel
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-08-18 08:54:29 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-08-18 08:54:29 +0000
commitb025fedb2aa00714c52737b2a61b60196adabc0e (patch)
tree12a6b7b8f03da3882155d6149e0eed4f43044e05 /devel/pth-devel
parent3cba145a61e02eb320e3f321a6cb2de8f01855c0 (diff)
downloadports-b025fedb2aa00714c52737b2a61b60196adabc0e.tar.gz
ports-b025fedb2aa00714c52737b2a61b60196adabc0e.zip
Notes
Diffstat (limited to 'devel/pth-devel')
-rw-r--r--devel/pth-devel/Makefile34
-rw-r--r--devel/pth-devel/distinfo1
-rw-r--r--devel/pth-devel/pkg-comment1
-rw-r--r--devel/pth-devel/pkg-descr22
-rw-r--r--devel/pth-devel/pkg-plist14
5 files changed, 72 insertions, 0 deletions
diff --git a/devel/pth-devel/Makefile b/devel/pth-devel/Makefile
new file mode 100644
index 000000000000..56cadfd2ffa2
--- /dev/null
+++ b/devel/pth-devel/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pth
+# Version required: 1.1b5
+# Date Created: 17 Aug 1999
+# Whom: Ralf S. Engelschall
+#
+# $Id: Makefile,v 1.1 1999/08/17 09:58:33 rse Exp $
+#
+
+DISTNAME= pth-1.1b5
+CATEGORIES= devel
+MASTER_SITES= ftp://alpha.gnu.org/gnu/pth/ \
+ ftp://ftp.engelschall.com/sw/pth/
+
+MAINTAINER= rse@engelschall.com
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --enable-pthread \
+ --enable-syscall-soft \
+ --enable-batch
+
+MAN1= pth-config.1 pthread-config.1
+MAN3= pth.3 pthread.3
+
+post-build:
+ @${ECHO_MSG} "===> Use 'make test' to run a quick test suite."
+
+test:
+ @cd ${WRKSRC} && ${MAKE} test
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/pth-devel/distinfo b/devel/pth-devel/distinfo
new file mode 100644
index 000000000000..6312f3f27c3a
--- /dev/null
+++ b/devel/pth-devel/distinfo
@@ -0,0 +1 @@
+MD5 (pth-1.1b5.tar.gz) = 4231c73dd53720688d518f93a5be4fec
diff --git a/devel/pth-devel/pkg-comment b/devel/pth-devel/pkg-comment
new file mode 100644
index 000000000000..bdb826a4f559
--- /dev/null
+++ b/devel/pth-devel/pkg-comment
@@ -0,0 +1 @@
+GNU Portable Threads (DEVELOPMENT VERSION)
diff --git a/devel/pth-devel/pkg-descr b/devel/pth-devel/pkg-descr
new file mode 100644
index 000000000000..d56feb8e72e4
--- /dev/null
+++ b/devel/pth-devel/pkg-descr
@@ -0,0 +1,22 @@
+GNU Pth - GNU Portable Threads
+Copyright (c) 1999 Ralf S. Engelschall <rse@engelschall.com>
+
+Pth is a very portable POSIX/ANSI-C based library for Unix platforms
+which provides non-preemptive priority-based scheduling for multiple
+threads of execution ("multithreading") inside server applications. All
+threads run in the same address space of the server application, but
+each thread has it's own individual program-counter, run-time stack,
+signal mask and errno variable.
+
+The thread scheduling itself is done in a cooperative way, i.e. the
+threads are managed by a priority- and event-based non-preemptive
+scheduler. The intention is that this way one can achieve better
+portability and run-time performance than with preemptive scheduling.
+The event facility allows threads to wait until various types of events
+occur, including pending I/O on filedescriptors, asynchronous signals,
+elapsed timers, pending I/O on message ports, thread and process
+termination, and even customized callback functions.
+
+The documentation and latest release can be found on
+ o http://www.gnu.org/software/pth/
+ o ftp://ftp.gnu.org/gnu/pth/
diff --git a/devel/pth-devel/pkg-plist b/devel/pth-devel/pkg-plist
new file mode 100644
index 000000000000..3355fe72710d
--- /dev/null
+++ b/devel/pth-devel/pkg-plist
@@ -0,0 +1,14 @@
+bin/pth-config
+bin/pthread-config
+include/pth.h
+include/pthread.h
+lib/libpth.a
+lib/libpth.la
+lib/libpth.so
+lib/libpth.so.11
+lib/libpthread.a
+lib/libpthread.la
+lib/libpthread.so
+lib/libpthread.so.11
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B