aboutsummaryrefslogtreecommitdiff
path: root/devel/ptmalloc2/Makefile
diff options
context:
space:
mode:
authorGreg Lehey <grog@FreeBSD.org>2004-12-14 02:18:24 +0000
committerGreg Lehey <grog@FreeBSD.org>2004-12-14 02:18:24 +0000
commit52619f7b5b077bad734bc7c36870ced9f60e6616 (patch)
tree8c0c9c65c79cfe068c4d53986bb89f9dbeb2c4f3 /devel/ptmalloc2/Makefile
parent7746ee71a0d0ff9f0a259c75b4aa21bf2f1e5587 (diff)
New port: ptmalloc is an older version of the GNU libc malloc. It has
a BSD compatible license and outperforms FreeBSD's malloc by an order of magnitude with some pathological files (notably pthreads and realloc abuse).
Notes
Notes: svn path=/head/; revision=123979
Diffstat (limited to 'devel/ptmalloc2/Makefile')
-rw-r--r--devel/ptmalloc2/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/ptmalloc2/Makefile b/devel/ptmalloc2/Makefile
new file mode 100644
index 000000000000..95c946f960a1
--- /dev/null
+++ b/devel/ptmalloc2/Makefile
@@ -0,0 +1,29 @@
+# Ports Collection Makefile for: ptmalloc
+# Date created: 10 December 2004
+# Who: Greg 'groggy' Lehey <grog@FreeBSD.org>
+# Whom: is grammatically incorrect in this context.
+#
+# $FreeBSD$
+
+PORTNAME= ptmalloc
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.malloc.de/malloc/
+DISTNAME= ptmalloc
+
+MAINTAINER= grog@FreeBSD.org
+COMMENT= Alternative malloc, performs better with threaded applications
+
+do-install: all
+ ${INSTALL_PROGRAM} ${WRKSRC}/ptmalloc.so ${PREFIX}/lib/libptmalloc.so.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/ptmalloc.so ${PREFIX}/lib/libptmalloc.so
+ ${INSTALL_PROGRAM} ${WRKSRC}/libptmalloc.a ${PREFIX}/lib/libptmalloc.a
+
+post-install:
+ @${ECHO_CMD}
+ @${ECHO_CMD} Not much documentation is available.
+ @${ECHO_CMD} Read work/ptmalloc/README for what there is.
+ @${ECHO_CMD} See also pkg_descr
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>