aboutsummaryrefslogtreecommitdiff
path: root/devel/pure-ffi/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:44:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:44:38 +0000
commitc8b2d8c562b02bd6498ea364bdf342b53e7b6507 (patch)
tree5a06e2e3aa99048fda456cb5340c29d9ccf3f941 /devel/pure-ffi/Makefile
parent930beb29406be617ee74b32dbf4221f6eed70702 (diff)
downloadports-c8b2d8c562b02bd6498ea364bdf342b53e7b6507.tar.gz
ports-c8b2d8c562b02bd6498ea364bdf342b53e7b6507.zip
Notes
Diffstat (limited to 'devel/pure-ffi/Makefile')
-rw-r--r--devel/pure-ffi/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/pure-ffi/Makefile b/devel/pure-ffi/Makefile
new file mode 100644
index 000000000000..a89be8a27d9b
--- /dev/null
+++ b/devel/pure-ffi/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pure-ffi
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-ffi
+PORTVERSION= 0.12
+CATEGORIES= devel
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure langauge interface to libffi
+
+LIB_DEPENDS+= pure.7:${PORTSDIR}/lang/pure \
+ ffi:${PORTSDIR}/devel/libffi
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GCC= 4.2+
+USE_GMAKE= yes
+
+PLIST_FILES= lib/pure/ffi.pure \
+ lib/pure/ffi.so
+MAKE_ARGS+= prefix=${PREFIX} \
+ CPPFLAGS+=-I${LOCALBASE}/include \
+ LDFLAGS+=-L${LOCALBASE}/lib \
+ CFLAGS="${CFLAGS}"
+
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>