aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-05-24 04:55:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-05-24 04:55:25 +0000
commit5aeb7b367f3d8c168d463e1374d04ee6b55a6e6e (patch)
tree872cfce441ae7468e4aa7a8d0cd0756f10f4996f /devel/pwlib/Makefile
parent9da7f595d7bf1228780336a5f2f435c9ce4c5244 (diff)
Notes
Diffstat (limited to 'devel/pwlib/Makefile')
-rw-r--r--devel/pwlib/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index c06e5ea18d30..7ddff9b905dc 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -40,6 +40,11 @@ MAKE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include"
STDCCFLAGS+="-I${LOCALBASE}" \
CFLAGS="${CFLAGS} -O1"
+.if ${OSVERSION} >= 700042
+CONFIGURE_ENV+= ATOMICITY_H="<ext/atomicity.h>"
+.else
+CONFIGURE_ENV+= ATOMICITY_H="<bits/atomicity.h>"
+.endif
# if explicitely asked for, depend upon it
.if defined(WITH_SDL)
USE_SDL+= sdl