aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib152
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2003-12-03 00:22:34 +0000
committerRoger Hardiman <roger@FreeBSD.org>2003-12-03 00:22:34 +0000
commit0c20d95e0762b3997ce37f65e2bb5fbcddf4f52a (patch)
tree59ad305017015886a36c1c2bcde25b094d6084d8 /devel/pwlib152
parent15d50ff35c5fc6139209ec6d11d8d8e2b1519a45 (diff)
downloadports-0c20d95e0762b3997ce37f65e2bb5fbcddf4f52a.tar.gz
ports-0c20d95e0762b3997ce37f65e2bb5fbcddf4f52a.zip
Notes
Diffstat (limited to 'devel/pwlib152')
-rw-r--r--devel/pwlib152/files/patch-makefile14
-rw-r--r--devel/pwlib152/files/patch-videoio36
2 files changed, 50 insertions, 0 deletions
diff --git a/devel/pwlib152/files/patch-makefile b/devel/pwlib152/files/patch-makefile
new file mode 100644
index 000000000000..8ca3ca5e99f7
--- /dev/null
+++ b/devel/pwlib152/files/patch-makefile
@@ -0,0 +1,14 @@
+*** src/ptlib/unix/Makefile.orig Tue Dec 2 11:15:55 2003
+--- src/ptlib/unix/Makefile Tue Dec 2 11:16:39 2003
+*************** VIDEO_CAPTURE_SOURCE = video4linux.cxx
+*** 422,428 ****
+--- 422,430 ----
+ endif
+
+ ifeq ($(OSTYPE),FreeBSD)
++ ifneq (,$(wildcard $(SYSINCDIR)/machine/ioctl_meteor.h))
+ VIDEO_CAPTURE_SOURCE = video4bsd.cxx
++ endif
+ endif
+
+ ifeq ($(OSTYPE),OpenBSD)
diff --git a/devel/pwlib152/files/patch-videoio b/devel/pwlib152/files/patch-videoio
new file mode 100644
index 000000000000..74d8a5c43c02
--- /dev/null
+++ b/devel/pwlib152/files/patch-videoio
@@ -0,0 +1,36 @@
+*** include/ptlib/unix/ptlib/videoio.h.orig Mon Jan 6 18:41:08 2003
+--- include/ptlib/unix/ptlib/videoio.h Tue Dec 2 09:42:10 2003
+***************
+*** 106,112 ****
+ #include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
+ #endif
+
+! #if defined(P_FREEBSD)
+ #include <machine/ioctl_meteor.h>
+ #endif
+
+--- 106,112 ----
+ #include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
+ #endif
+
+! #if defined(P_FREEBSD) && !defined(NO_VIDEO_CAPTURE)
+ #include <machine/ioctl_meteor.h>
+ #endif
+
+***************
+*** 186,192 ****
+ struct video_mmap frameBuffer[2];
+ #endif
+
+! #if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
+ struct video_capability
+ {
+ int channels; /* Num channels */
+--- 186,192 ----
+ struct video_mmap frameBuffer[2];
+ #endif
+
+! #if (defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)) && !defined(NO_VIDEO_CAPTURE)
+ struct video_capability
+ {
+ int channels; /* Num channels */