aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-07 13:02:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-07 13:02:10 +0000
commit9b586f478b95a4123e31c0235d61ce794665bc38 (patch)
tree8ceb2ccf17a085e2642972fd6560d1c8624615a2 /devel/pwlib
parentf1146bdc9a48e0b2c65a8dba24a359a14ce4ba3f (diff)
downloadports-9b586f478b95a4123e31c0235d61ce794665bc38.tar.gz
ports-9b586f478b95a4123e31c0235d61ce794665bc38.zip
Notes
Diffstat (limited to 'devel/pwlib')
-rw-r--r--devel/pwlib/Makefile42
-rw-r--r--devel/pwlib/files/patch-configureac43
-rw-r--r--devel/pwlib/files/patch-plugins-Makefile.in18
-rw-r--r--devel/pwlib/files/patch-plugins-configure347
-rw-r--r--devel/pwlib/files/patch-plugins-sound_esd-Makefile11
-rw-r--r--devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h22
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_avc-Makefile11
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx43
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h95
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in11
-rw-r--r--devel/pwlib/files/patch-src-ptlib-unix-udll.cxx13
-rw-r--r--devel/pwlib/pkg-plist5
12 files changed, 642 insertions, 19 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 6f4892897e91..cc5c8257aa04 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pwlib
PORTVERSION= 1.10.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.voxgratia.org/releases/
@@ -23,6 +24,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
USE_BISON= yes
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259
+WANT_GNOME= yes
WANT_SDL= yes
USE_OPENSSL= yes
NO_FILTER_SHLIBS= yes
@@ -75,11 +77,49 @@ CONFIGURE_ENV+= OPENLDAPLIBDIR="${LOCALBASE}/lib"
MAKE_ENV+= OPENLDAPLIBDIR="${LOCALBASE}/lib"
.endif
+#enable esound support
+.if defined(WITH_ESOUND) && ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
+CONFIGURE_ARGS+= --enable-esd
+PLIST_SUB+= ESD=""
+.else
+CONFIGURE_ARGS+= --disable-esd
+PLIST_SUB+= ESD="@comment "
+.endif
+
+# ONLY FOR THE BRAVE!
+# If someone owns a firewire(4) video device and wants to use it for
+# video-conferencing purposes, please download the files:
+# libraw1394.shar.gz, libavc1394.shar.gz and libdc1394.shar.gz from
+# ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/ports/
+# Extract the files in ${PORTSDIR}/devel and uncomment the following lines.
+#
+##enable libavc1394
+#.if defined(WITH_AVC1394)
+#LIB_DEPENDS+= avc1394.2:${PORTSDIR}/devel/libavc1394 \
+# dv.4:${PORTSDIR}/multimedia/libdv
+#CONFIGURE_ARGS+= --enable-avc
+#PLIST_SUB+= AVC1394=""
+#.else
+CONFIGURE_ARGS+= --disable-avc
+PLIST_SUB+= AVC1394="@comment "
+#.endif
+#
+##enable libdc1394
+#.if defined(WITH_DC1394)
+#LIB_DEPENDS+= dc1394_control.13:${PORTSDIR}/devel/libdc1394
+#CONFIGURE_ARGS+= --enable-dc
+#PLIST_SUB+= DC1394=""
+#.else
+CONFIGURE_ARGS+= --disable-dc
+PLIST_SUB+= DC1394="@comment "
+#.endif
+
.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
.endif
-.if (${ARCH} == "i386") || (${ARCH} == "ia64")
+.if (${ARCH} == "i386") || (${ARCH} == "ia64") || (${ARCH} == "amd64")
PLIST_SUB+= BSDVIDEO=""
.else
PLIST_SUB+= BSDVIDEO="@comment "
diff --git a/devel/pwlib/files/patch-configureac b/devel/pwlib/files/patch-configureac
index d923f281db17..e8da151aa2d6 100644
--- a/devel/pwlib/files/patch-configureac
+++ b/devel/pwlib/files/patch-configureac
@@ -1,5 +1,5 @@
---- configure.ac.orig Wed Feb 1 14:52:36 2006
-+++ configure.ac Wed Feb 1 15:04:55 2006
+--- configure.ac.orig Wed Feb 22 12:53:28 2006
++++ configure.ac Sun May 7 14:19:18 2006
@@ -136,7 +136,7 @@
x86 | i686 | i586 | i486 | i386 ) MACHTYPE=x86
;;
@@ -9,7 +9,7 @@
P_64BIT=1 ;
LIB64=1 ;
;;
-@@ -276,7 +276,7 @@
+@@ -278,7 +278,7 @@
AC_MSG_CHECKING(if linker accepts -Wreorder)
AC_LANG_CONFTEST([[int main(int ac,char **av) { return 0; }]])
@@ -18,7 +18,7 @@
if test $? = 0 ; then
AC_MSG_RESULT(yes)
STDCXXFLAGS="$STDCXXFLAGS -Wreorder"
-@@ -289,7 +289,7 @@
+@@ -291,7 +291,7 @@
# $CXX $CFLAGS -Woverloaded-virtual conftest.cc > /dev/null 2>&1
# if test $? = 0 ; then
# AC_MSG_RESULT(yes)
@@ -27,7 +27,7 @@
# else
# AC_MSG_RESULT(no)
# fi
-@@ -318,7 +318,7 @@
+@@ -320,7 +320,7 @@
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
@@ -36,7 +36,7 @@
fi
GCSECTIONS=0
-@@ -339,7 +339,7 @@
+@@ -341,7 +341,7 @@
$CXX $CFLAGS -ffunction-sections -c conftest.cc > /dev/null 2>&1
if test $? = 0 ; then
AC_MSG_RESULT(yes)
@@ -45,7 +45,7 @@
GCSECTIONS=1
else
AC_MSG_RESULT(no)
-@@ -355,7 +355,7 @@
+@@ -357,7 +357,7 @@
dnl $CXX $CFLAGS -fdata-sections -c conftest.cc > /dev/null 2>&1
dnl if test $? = 0 ; then
dnl AC_MSG_RESULT(yes)
@@ -54,7 +54,7 @@
dnl GCSECTIONS=1
dnl else
dnl AC_MSG_RESULT(no)
-@@ -368,7 +368,7 @@
+@@ -370,7 +370,7 @@
dnl $CXX $CFLAGS -fvtable-gc -c conftest.cc > /dev/null 2>&1
dnl if test $? = 0 ; then
dnl AC_MSG_RESULT(yes)
@@ -63,7 +63,7 @@
dnl GCSECTIONS=1
dnl else
dnl AC_MSG_RESULT(no)
-@@ -687,18 +687,18 @@
+@@ -689,18 +689,18 @@
dnl MSWIN_DISPLAY semaphore,Semaphore Support
dnl MSWIN_DEFINE semaphore,P_HAS_SEMAPHORES
@@ -88,7 +88,7 @@
fi
fi
-@@ -1251,7 +1251,7 @@
+@@ -1253,7 +1253,7 @@
else
AC_CHECK_HEADERS(expat.h, HAS_EXPAT=1)
if test "${HAS_EXPAT:-unset}" != "unset" ; then
@@ -97,7 +97,7 @@
else
AC_CHECK_FILE(/usr/local/include/expat.h, HAS_EXPAT=1)
if test "${HAS_EXPAT:-unset}" != "unset" ; then
-@@ -1426,7 +1426,8 @@
+@@ -1428,7 +1428,8 @@
if test $HAS_IPV6 = no ; then
AC_MSG_RESULT(no)
else
@@ -107,19 +107,28 @@
#include <netdb.h>],
[getnameinfo(NULL, 0, NULL, 0, NULL, 0, 0);], HAS_IPV6=yes, HAS_IPV6=no)
if test $HAS_IPV6 = no ; then
-@@ -1499,9 +1500,9 @@
- AC_CHECK_LIB(SDL, SDL_CreateYUVOverlay, HAS_SDL=1, HAS_SDL=, -L${X11LIBDIR} -lpthread -lX11 -lXext -laa)
+@@ -1485,7 +1486,7 @@
+ HAS_SDL=
+ if test "$enable_sdl" = "no" ; then
+ AC_MSG_NOTICE(SDL disabled)
+- AC_DEFINE(P_SDL, 0)
++# AC_DEFINE(P_SDL, 0)
+ else
+ dnl SDL checks
+ if test "${SDLLIB:-unset}" = "unset" ; then
+@@ -1501,9 +1502,9 @@
+ AC_CHECK_LIB(SDL, SDL_CreateYUVOverlay, HAS_SDL=1, HAS_SDL=, -L${X11LIBDIR} -lpthread -lX11 -lXext)
fi
- dnl freeBSD SDL check
+ dnl FreeBSD SDL check
if test "${HAS_SDL:-unset}" = "unset" ; then
- AC_CHECK_FILE(/usr/local/include/SDL11/SDL.h, HAS_SDL=1)
-+ AC_CHECK_FILE(SDL11/SDL.h, HAS_SDL=1)
++ AC_CHECK_HEADER(SDL11/SDL.h, HAS_SDL=1)
if test "${HAS_SDL:-unset}" != "unset" ; then
SDLLIB=SDL-1.1
fi
-@@ -1525,7 +1526,7 @@
+@@ -1527,7 +1528,7 @@
dnl ########################################################################
dnl check for video capture support.
dnl videodev.h on linux
@@ -128,7 +137,7 @@
dnl i386/ioctl_meteor on OpenBSD
dnl dev/ic/bt8xx on NetBSD
-@@ -1551,9 +1552,10 @@
+@@ -1553,9 +1554,10 @@
HAS_VIDEO_CAPTURE=1
else
AC_CHECK_HEADER(linux/videodev.h, HAS_VIDEO_CAPTURE=1)
@@ -142,7 +151,7 @@
if test "${HAS_VIDEO_CAPTURE}z" = "z" ; then
AC_MSG_NOTICE(No Video Capture support)
AC_DEFINE([NO_VIDEO_CAPTURE], [], [No video capture])
-@@ -2044,6 +2046,9 @@
+@@ -2046,6 +2048,9 @@
AC_MSG_NOTICE(C++ exceptions enabled)
STDCCFLAGS="$STDCCFLAGS -fno-exceptions"
fi
diff --git a/devel/pwlib/files/patch-plugins-Makefile.in b/devel/pwlib/files/patch-plugins-Makefile.in
new file mode 100644
index 000000000000..d7d1524aeb4a
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-Makefile.in
@@ -0,0 +1,18 @@
+--- plugins/Makefile.in.orig Thu Apr 6 10:15:56 2006
++++ plugins/Makefile.in Thu Apr 6 10:18:41 2006
+@@ -22,6 +22,15 @@
+ endif
+ endif
+
++HAS_ESD = @HAS_ESD@
++
++ifeq (1,$(HAS_ESD))
++SUBDIRS += sound_esd
++ifeq (,$(DEFAULT_SOUND))
++DEFAULT_SOUND = sound_esd
++endif
++endif
++
+ HAS_SUNAUDIO = @HAS_SUNAUDIO@
+
+ ifeq (1,$(HAS_SUNAUDIO))
diff --git a/devel/pwlib/files/patch-plugins-configure b/devel/pwlib/files/patch-plugins-configure
new file mode 100644
index 000000000000..6f30e76f900a
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-configure
@@ -0,0 +1,347 @@
+--- plugins/configure.orig Thu Apr 6 10:16:09 2006
++++ plugins/configure Thu Apr 6 09:56:04 2006
+@@ -309,7 +309,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_OSS HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_OSS HAS_ESD HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -852,6 +852,7 @@
+ --disable-audio disable audio support
+ --enable-alsa enable ALSA audio support
+ --enable-oss enable OSS audio support
++ --enable-esd enable ESD audio support
+ --enable-sunaudio enable Sun audio support
+ --disable-video disable video device support in PWLIB
+ --enable-v4l enable V4L video support
+@@ -3444,6 +3459,172 @@
+ fi
+
+
++# Check whether --enable-esd or --disable-esd was given.
++if test "${enable_esd+set}" = set; then
++ enableval="$enable_esd"
++
++else
++ enable_oss=yes
++fi;
++
++if test "${enable_esd}z" = "yesz" ; then
++ if test "${ac_cv_header_esd_h+set}" = set; then
++ echo "$as_me:$LINENO: checking for esd.h" >&5
++echo $ECHO_N "checking for esd.h... $ECHO_C" >&6
++if test "${ac_cv_header_esd_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++fi
++echo "$as_me:$LINENO: result: $ac_cv_header_esd_h" >&5
++echo "${ECHO_T}$ac_cv_header_esd_h" >&6
++else
++ # Is the header compilable?
++echo "$as_me:$LINENO: checking esd.h usability" >&5
++echo $ECHO_N "checking esd.h usability... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++#include <esd.h>
++_ACEOF
++rm -f conftest.$ac_objext
++if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest.$ac_objext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_header_compiler=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_header_compiler=no
++fi
++rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
++echo "${ECHO_T}$ac_header_compiler" >&6
++
++# Is the header present?
++echo "$as_me:$LINENO: checking esd.h presence" >&5
++echo $ECHO_N "checking esd.h presence... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <esd.h>
++_ACEOF
++if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
++ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } >/dev/null; then
++ if test -s conftest.err; then
++ ac_cpp_err=$ac_c_preproc_warn_flag
++ ac_cpp_err=$ac_cpp_err$ac_c_werror_flag
++ else
++ ac_cpp_err=
++ fi
++else
++ ac_cpp_err=yes
++fi
++if test -z "$ac_cpp_err"; then
++ ac_header_preproc=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_preproc=no
++fi
++rm -f conftest.err conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
++echo "${ECHO_T}$ac_header_preproc" >&6
++
++# So? What about this header?
++case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
++ yes:no: )
++ { echo "$as_me:$LINENO: WARNING: esd.h: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: esd.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: esd.h: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: esd.h: proceeding with the compiler's result" >&2;}
++ ac_header_preproc=yes
++ ;;
++ no:yes:* )
++ { echo "$as_me:$LINENO: WARNING: esd.h: present but cannot be compiled" >&5
++echo "$as_me: WARNING: esd.h: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: esd.h: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: esd.h: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: esd.h: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: esd.h: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: esd.h: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: esd.h: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: esd.h: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: esd.h: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: esd.h: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: esd.h: in the future, the compiler will take precedence" >&2;}
++ (
++ cat <<\_ASBOX
++## ------------------------------------------ ##
++## Report this to the AC_PACKAGE_NAME lists. ##
++## ------------------------------------------ ##
++_ASBOX
++ ) |
++ sed "s/^/$as_me: WARNING: /" >&2
++ ;;
++esac
++echo "$as_me:$LINENO: checking for esd.h" >&5
++echo $ECHO_N "checking for esd.h... $ECHO_C" >&6
++if test "${ac_cv_header_esd_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_cv_header_esd_h=$ac_header_preproc
++fi
++echo "$as_me:$LINENO: result: $ac_cv_header_esd_h" >&5
++echo "${ECHO_T}$ac_cv_header_esd_h" >&6
++
++fi
++if test $ac_cv_header_esd_h = yes; then
++ ESDHDR=1
++fi
++
++
++ echo "$as_me:$LINENO: checking for ESD sound support" >&5
++echo $ECHO_N "checking for ESD sound support... $ECHO_C" >&6
++ if test "${ESDHDR}z" != "z"; then
++ HAS_ESD=1
++
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ fi
++fi
++
++
++
+ # Check whether --enable-sunaudio or --disable-sunaudio was given.
+ if test "${enable_sunaudio+set}" = set; then
+ enableval="$enable_sunaudio"
+@@ -4239,6 +4239,146 @@
+ BSDVIDEOHDR=1
+ fi
+
++ if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
++ echo "$as_me:$LINENO: checking for dev/bktr/ioctl_meteor.h" >&5
++echo $ECHO_N "checking for dev/bktr/ioctl_meteor.h... $ECHO_C" >&6
++if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++fi
++echo "$as_me:$LINENO: result: $ac_cv_header_dev_bktr_ioctl_meteor_h" >&5
++echo "${ECHO_T}$ac_cv_header_dev_bktr_ioctl_meteor_h" >&6
++else
++ # Is the header compilable?
++echo "$as_me:$LINENO: checking dev/bktr/ioctl_meteor.h usability" >&5
++echo $ECHO_N "checking dev/bktr/ioctl_meteor.h usability... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++#include <dev/bktr/ioctl_meteor.h>
++_ACEOF
++rm -f conftest.$ac_objext
++if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest.$ac_objext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_header_compiler=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_header_compiler=no
++fi
++rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
++echo "${ECHO_T}$ac_header_compiler" >&6
++
++# Is the header present?
++echo "$as_me:$LINENO: checking dev/bktr/ioctl_meteor.h presence" >&5
++echo $ECHO_N "checking dev/bktr/ioctl_meteor.h presence... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <dev/bktr/ioctl_meteor.h>
++_ACEOF
++if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
++ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } >/dev/null; then
++ if test -s conftest.err; then
++ ac_cpp_err=$ac_c_preproc_warn_flag
++ ac_cpp_err=$ac_cpp_err$ac_c_werror_flag
++ else
++ ac_cpp_err=
++ fi
++else
++ ac_cpp_err=yes
++fi
++if test -z "$ac_cpp_err"; then
++ ac_header_preproc=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_preproc=no
++fi
++rm -f conftest.err conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
++echo "${ECHO_T}$ac_header_preproc" >&6
++
++# So? What about this header?
++case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
++ yes:no: )
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the compiler's result" >&2;}
++ ac_header_preproc=yes
++ ;;
++ no:yes:* )
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: present but cannot be compiled" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: in the future, the compiler will take precedence" >&2;}
++ (
++ cat <<\_ASBOX
++## ------------------------------------------ ##
++## Report this to the AC_PACKAGE_NAME lists. ##
++## ------------------------------------------ ##
++_ASBOX
++ ) |
++ sed "s/^/$as_me: WARNING: /" >&2
++ ;;
++esac
++echo "$as_me:$LINENO: checking for dev/bktr/ioctl_meteor.h" >&5
++echo $ECHO_N "checking for dev/bktr/ioctl_meteor.h... $ECHO_C" >&6
++if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_cv_header_dev_bktr_ioctl_meteor_h=$ac_header_preproc
++fi
++echo "$as_me:$LINENO: result: $ac_cv_header_dev_bktr_ioctl_meteor_h" >&5
++echo "${ECHO_T}$ac_cv_header_dev_bktr_ioctl_meteor_h" >&6
++
++fi
++if test $ac_cv_header_dev_bktr_ioctl_meteor_h = yes; then
++ BSDVIDEOHDR=1
++fi
+
+ if test "${ac_cv_header_dev_ic_bt8xx_h+set}" = set; then
+ echo "$as_me:$LINENO: checking for dev/ic/bt8xx.h" >&5
+@@ -5872,6 +6065,7 @@
+ s,@EGREP@,$EGREP,;t t
+ s,@HAS_ALSA@,$HAS_ALSA,;t t
+ s,@HAS_OSS@,$HAS_OSS,;t t
++s,@HAS_ESD@,$HAS_ESD,;t t
+ s,@HAS_SUNAUDIO@,$HAS_SUNAUDIO,;t t
+ s,@HAS_V4L@,$HAS_V4L,;t t
+ s,@HAS_V4L2@,$HAS_V4L2,;t t
diff --git a/devel/pwlib/files/patch-plugins-sound_esd-Makefile b/devel/pwlib/files/patch-plugins-sound_esd-Makefile
new file mode 100644
index 000000000000..41a36b0da932
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-sound_esd-Makefile
@@ -0,0 +1,11 @@
+--- plugins/sound_esd/Makefile.orig Thu Apr 6 16:47:13 2006
++++ plugins/sound_esd/Makefile Thu Apr 6 16:50:52 2006
+@@ -4,7 +4,7 @@
+
+ PLUGIN_NAME = esd
+ PLUGIN_FAMILY = device/sound
+-PLUGIN_LIBS =
++PLUGIN_LIBS = $(LDFLAGS) -lesd
+ PLUGIN_SOURCES = sound_esd.cxx
+
+ include ../../make/plugins.mak
diff --git a/devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h b/devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h
new file mode 100644
index 000000000000..bc36e0202936
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h
@@ -0,0 +1,22 @@
+--- plugins/sound_esd/sound_esd.h.orig Thu Apr 6 16:47:28 2006
++++ plugins/sound_esd/sound_esd.h Thu Apr 6 16:48:06 2006
+@@ -43,15 +43,15 @@
+ unsigned _bitsPerSample);
+ BOOL Setup();
+ BOOL Close();
+- BOOL IsOpen() const;
++// BOOL IsOpen() const;
+ BOOL Write(const void * buf, PINDEX len);
+ BOOL Read(void * buf, PINDEX len);
+ BOOL SetFormat(unsigned numChannels,
+ unsigned sampleRate,
+ unsigned bitsPerSample);
+- unsigned GetChannels() const;
+- unsigned GetSampleRate() const;
+- unsigned GetSampleSize() const;
++// unsigned GetChannels() const;
++// unsigned GetSampleRate() const;
++// unsigned GetSampleSize() const;
+ BOOL SetBuffers(PINDEX size, PINDEX count);
+ BOOL GetBuffers(PINDEX & size, PINDEX & count);
+ BOOL PlaySound(const PSound & sound, BOOL wait);
diff --git a/devel/pwlib/files/patch-plugins-vidinput_avc-Makefile b/devel/pwlib/files/patch-plugins-vidinput_avc-Makefile
new file mode 100644
index 000000000000..9dfbbb6e34bb
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-vidinput_avc-Makefile
@@ -0,0 +1,11 @@
+--- plugins/vidinput_avc/Makefile.orig Fri Nov 14 07:16:13 2003
++++ plugins/vidinput_avc/Makefile Thu Apr 6 17:00:31 2006
+@@ -4,7 +4,7 @@
+
+ PLUGIN_NAME = avc
+ PLUGIN_FAMILY = device/videoinput
+-PLUGIN_LIBS = -lraw1394 -ldv -lrom1394
++PLUGIN_LIBS = $(LDFLAGS) -lraw1394 -ldv -lrom1394
+ PLUGIN_SOURCES = vidinput_avc.cxx
+
+ include ../../make/plugins.mak
diff --git a/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx b/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx
new file mode 100644
index 000000000000..7207595c071b
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx
@@ -0,0 +1,43 @@
+--- plugins/vidinput_bsd/vidinput_bsd.cxx.orig Tue Aug 9 11:08:09 2005
++++ plugins/vidinput_bsd/vidinput_bsd.cxx Wed Apr 5 21:35:08 2006
+@@ -122,12 +122,11 @@
+ #pragma implementation "vidinput_bsd.h"
+
+ #include "vidinput_bsd.h"
+-#include <sys/mman.h>
+
+ PCREATE_VIDINPUT_PLUGIN(BSDCAPTURE);
+
+ ///////////////////////////////////////////////////////////////////////////////
+-// PVideoInputDevice_BSDCAPTURE
++// PVideoInputBSDCAPTURE
+
+ PVideoInputDevice_BSDCAPTURE::PVideoInputDevice_BSDCAPTURE()
+ {
+@@ -142,6 +141,7 @@
+
+ BOOL PVideoInputDevice_BSDCAPTURE::Open(const PString & devName, BOOL startImmediate)
+ {
++ if (IsOpen())
+ Close();
+
+ deviceName = devName;
+@@ -235,10 +235,14 @@
+ {
+ PStringList list;
+
+- list.AppendString("/dev/bktr0");
+- list.AppendString("/dev/bktr1");
+- list.AppendString("/dev/meteor0");
+- list.AppendString("/dev/meteor1");
++ if (PFile::Exists("/dev/bktr0"))
++ list.AppendString("/dev/bktr0");
++ if (PFile::Exists("/dev/bktr1"))
++ list.AppendString("/dev/bktr1");
++ if (PFile::Exists("/dev/meteor0"))
++ list.AppendString("/dev/meteor0");
++ if (PFile::Exists("/dev/meteor1"))
++ list.AppendString("/dev/meteor1");
+
+ return list;
+ }
diff --git a/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h b/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h
new file mode 100644
index 000000000000..968b4d0e4142
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h
@@ -0,0 +1,95 @@
+--- plugins/vidinput_bsd/vidinput_bsd.h.orig Tue Aug 9 11:08:09 2005
++++ plugins/vidinput_bsd/vidinput_bsd.h Thu Apr 6 09:37:11 2006
+@@ -1,13 +1,24 @@
++#ifndef _PVIDEOIOBSDCAPTURE
+
+-//#include <sys/mman.h>
+-//#include <sys/time.h>
++#define _PVIDEOIOBSDCAPTURE
++
++#ifdef __GNUC__
++#pragma interface
++#endif
++
++#include <sys/mman.h>
+
+ #include <ptlib.h>
+ #include <ptlib/videoio.h>
+ #include <ptlib/vconvert.h>
+
+ #if defined(P_FREEBSD)
++#include <sys/param.h>
++# if __FreeBSD_version >= 502100
++#include <dev/bktr/ioctl_meteor.h>
++# else
+ #include <machine/ioctl_meteor.h>
++# endif
+ #endif
+
+ #if defined(P_OPENBSD) || defined(P_NETBSD)
+@@ -20,19 +30,24 @@
+ #endif
+ #endif
+
+-class PVideoInputDevice_BSDCAPTURE: public PVideoInputDevice
++#if !P_USE_INLINES
++#include <ptlib/contain.inl>
++#endif
++
++
++class PVideoInputDevice_BSDCAPTURE : public PVideoInputDevice
+ {
+
++ PCLASSINFO(PVideoInputDevice_BSDCAPTURE, PVideoInputDevice);
++
+ public:
+ PVideoInputDevice_BSDCAPTURE();
+ ~PVideoInputDevice_BSDCAPTURE();
+
+- static PStringList GetInputDeviceNames();
+-
+- PStringList GetDeviceNames() const
+- { return GetInputDeviceNames(); }
+-
+- BOOL Open(const PString &deviceName, BOOL startImmediate);
++ BOOL Open(
++ const PString &deviceName,
++ BOOL startImmediate = TRUE
++ );
+
+ BOOL IsOpen();
+
+@@ -43,11 +58,24 @@
+
+ BOOL IsCapturing();
+
++ static PStringList GetInputDeviceNames();
++
++ PStringList GetDeviceNames() const
++ { return GetInputDeviceNames(); }
++
+ PINDEX GetMaxFrameBytes();
+
+- BOOL GetFrame(PBYTEArray & frame);
+- BOOL GetFrameData(BYTE*, PINDEX*);
+- BOOL GetFrameDataNoDelay(BYTE*, PINDEX*);
++// BOOL GetFrame(
++// PBYTEArray & frame
++// );
++ BOOL GetFrameData(
++ BYTE * buffer,
++ PINDEX * bytesReturned = NULL
++ );
++ BOOL GetFrameDataNoDelay(
++ BYTE * buffer,
++ PINDEX * bytesReturned = NULL
++ );
+
+ BOOL GetFrameSizeLimits(unsigned int&, unsigned int&,
+ unsigned int&, unsigned int&);
+@@ -99,3 +127,5 @@
+ int mmap_size;
+
+ };
++
++#endif
diff --git a/devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in b/devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in
new file mode 100644
index 000000000000..f367f2855c6b
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in
@@ -0,0 +1,11 @@
+--- plugins/vidinput_dc/Makefile.in.orig Thu Apr 6 17:01:27 2006
++++ plugins/vidinput_dc/Makefile.in Thu Apr 6 17:01:38 2006
+@@ -4,7 +4,7 @@
+
+ PLUGIN_NAME = dc
+ PLUGIN_FAMILY = device/videoinput
+-PLUGIN_LIBS = -lraw1394 -ldv -ldc1394_control
++PLUGIN_LIBS = $(LDFLAGS) -lraw1394 -ldv -ldc1394_control
+ PLUGIN_SOURCES = video4dc1394.cxx
+
+ CFLAGS = @DC_CFLAGS@
diff --git a/devel/pwlib/files/patch-src-ptlib-unix-udll.cxx b/devel/pwlib/files/patch-src-ptlib-unix-udll.cxx
new file mode 100644
index 000000000000..8cfadebbfe9f
--- /dev/null
+++ b/devel/pwlib/files/patch-src-ptlib-unix-udll.cxx
@@ -0,0 +1,13 @@
+--- src/ptlib/unix/udll.cxx.orig Wed Nov 30 13:47:42 2005
++++ src/ptlib/unix/udll.cxx Wed Apr 5 22:36:51 2006
+@@ -382,6 +382,10 @@
+ dllHandle = dlopen((char *)(const char *)name, RTLD_NOW);
+ #else
++ const char *dummyerr = dlerror();
+ dllHandle = dlopen((const char *)name, RTLD_NOW);
++ const char *err = dlerror();
++ if (err != NULL)
++ cerr << err << '\n';
+ #endif
+
+ return IsLoaded();
diff --git a/devel/pwlib/pkg-plist b/devel/pwlib/pkg-plist
index c8e81fcebd44..1867077b9cd1 100644
--- a/devel/pwlib/pkg-plist
+++ b/devel/pwlib/pkg-plist
@@ -158,11 +158,14 @@ lib/libpt_r.so.1
lib/libpt_r.so.1.10
lib/libpt_r.so.1.10.0
lib/pwlib/devices/sound/oss_pwplugin.so
+%%ESD%%lib/pwlib/devices/sound/esd_pwplugin.so
+%%AVC1394%%lib/pwlib/devices/videoinput/avc_pwplugin.so
%%BSDVIDEO%%lib/pwlib/devices/videoinput/bsdvideo_pwplugin.so
+%%DC1394%%lib/pwlib/devices/videoinput/dc_pwplugin.so
@dirrm lib/pwlib/devices/sound
@dirrm lib/pwlib/devices/videoinput
@dirrm lib/pwlib/devices
-@dirrm lib/pwlib
+@dirrmtry lib/pwlib
%%DATADIR%%/make/common.mak
%%DATADIR%%/make/defaultgui.mak
%%DATADIR%%/make/gui.mak