aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-07-25 09:38:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-07-25 09:38:45 +0000
commitacacd0d015ba10d7b1d2e0ed11ab7ee1f079fd4b (patch)
tree651da5037b0f20c4a0f70a639fa0c0f659c951f1 /devel/pwlib
parent428214143dfd45bd47a803ec9420f46886c780b5 (diff)
- Remove duplicates from MAKE_ENV after inclusion of CC and CXX in default MAKE_ENV
Notes
Notes: svn path=/head/; revision=217472
Diffstat (limited to 'devel/pwlib')
-rw-r--r--devel/pwlib/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index aebb23a900da..e97d54798fea 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -32,14 +32,14 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+CFLAGS= -O1
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- CFLAGS="${CFLAGS} -O1"
+ CFLAGS="${CFLAGS}"
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- STDCCFLAGS+="-I${LOCALBASE}" \
- CFLAGS="${CFLAGS} -O1"
+ STDCCFLAGS+="-I${LOCALBASE}"
.if ${OSVERSION} >= 700042
CONFIGURE_ENV+= ATOMICITY_H="<ext/atomicity.h>"