aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-04-13 12:43:55 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-04-13 12:43:55 +0000
commit6ece12cda93c1f0ac5a9a981d6e1bef0452491cf (patch)
tree2e6e64b7d98608952ec3d5728be5562ae6d8e857 /devel/pwlib
parent2c5ce7d989a90e235bbacaf3cce8f1395c847c9a (diff)
downloadports-6ece12cda93c1f0ac5a9a981d6e1bef0452491cf.tar.gz
ports-6ece12cda93c1f0ac5a9a981d6e1bef0452491cf.zip
Notes
Diffstat (limited to 'devel/pwlib')
-rw-r--r--devel/pwlib/Makefile2
-rw-r--r--devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx22
2 files changed, 20 insertions, 4 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 0da8cd224be3..2601a1782b0f 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwlib
PORTVERSION= 1.12.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx b/devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx
index 6f18e5cc9f87..7572b4cf5afd 100644
--- a/devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx
+++ b/devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx
@@ -1,6 +1,22 @@
---- plugins/sound_oss/sound_oss.cxx.orig 2007-10-19 02:22:33.000000000 -0400
-+++ plugins/sound_oss/sound_oss.cxx 2007-12-30 20:46:38.000000000 -0500
-@@ -643,6 +643,7 @@
+--- plugins/sound_oss/sound_oss.orig 2008-04-08 13:54:44.000000000 -0400
++++ plugins/sound_oss/sound_oss.cxx 2008-04-08 13:57:40.000000000 -0400
+@@ -399,6 +399,15 @@
+ PINDEX cardnum = numbers.AsInteger(); //dspN.M is truncated to dspN.
+ // If we have not yet inserted something for this cardnum, insert it
+ if (dsp.GetAt(cardnum+1) == NULL) {
++#if defined P_FREEBSD
++ // in FreeBSD the file name should be used via the devfs(5) and
++ // is just "/dev/dsp0" and devfs(5) takes care of virtual channels,
++ // like /dev/dsp0.0 /dev/dsp0.1 ...
++ // everything else would conflict with other KDE apps using the
++ // audio
++ devname = devdir + "dsp0";
++ PTRACE(1, "OSS\tCollectSoundDevices FreeBSD devname set to devfs(5) name:" << devname );
++ #endif
+ dsp.SetAt(cardnum+1, devname);
+ }
+ }
+@@ -643,6 +652,7 @@
arg = val = (entry.numChannels == 2) ? 1 : 0;
if (ConvertOSError(::ioctl(os_handle, SNDCTL_DSP_STEREO, &arg)) || (arg != val)) {