aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-01 07:24:51 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-01 07:24:51 +0000
commitbf1ee3290e60cf814992d9e666f310d200bb95c8 (patch)
tree54bd2c6f26a66265c81ec04eda315a445b3826e9 /devel/pwlib
parente068a5c001f9188e89738a107e266de8fe269295 (diff)
downloadports-bf1ee3290e60cf814992d9e666f310d200bb95c8.tar.gz
ports-bf1ee3290e60cf814992d9e666f310d200bb95c8.zip
Notes
Diffstat (limited to 'devel/pwlib')
-rw-r--r--devel/pwlib/Makefile16
-rw-r--r--devel/pwlib/distinfo6
-rw-r--r--devel/pwlib/files/patch-configureac149
-rw-r--r--devel/pwlib/files/patch-include-ptclib-dtmf-h10
-rw-r--r--devel/pwlib/files/patch-plugins-configure35
-rw-r--r--devel/pwlib/files/patch-plugins-sound_esd-Makefile11
-rw-r--r--devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h22
-rw-r--r--devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx10
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_avc-Makefile11
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx43
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h100
-rw-r--r--devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in11
-rw-r--r--devel/pwlib/files/patch-src-ptlib-unix-tlib-cxx11
-rw-r--r--devel/pwlib/files/patch-src-ptlib-unix-udll.cxx13
-rw-r--r--devel/pwlib/files/patch-src_ptclib_dtmf_cxx67
-rw-r--r--devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx12
-rw-r--r--devel/pwlib/files/patch-src_ptlib_unix_tlibthrd.cxx10
-rw-r--r--devel/pwlib/pkg-plist17
18 files changed, 188 insertions, 366 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 244643060495..2e9f5bd51105 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= pwlib
-PORTVERSION= 1.10.3
-PORTREVISION= 4
+PORTVERSION= 1.12.0
PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= http://www.voxgratia.org/releases/
-DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+DISTNAME= openh323/ptlib-v${PORTVERSION:S/./_/g}-src.
EXTRACT_SUFX= tar.gz
MAINTAINER= steve@energistic.com
@@ -19,7 +18,7 @@ COMMENT= A cross platform C++ library, used by OpenH323
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
-WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
+WRKSRC= ${WRKDIR}/ptlib_v${PORTVERSION:S/./_/g}
USE_BISON= build
USE_GMAKE= yes
@@ -32,6 +31,10 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 600000
+BROKEN= does not compile
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
@@ -73,6 +76,9 @@ CONFIGURE_ARGS+= --disable-sdl
CONFIGURE_ARGS+= --enable-plugins
.endif
+#explicity build OSS
+CONFIGURE_ARGS+= --enable-oss
+
#disable OpenLDAP support in PWLIB
.if defined(WITHOUT_LDAP)
CONFIGURE_ARGS+= --disable-openldap
diff --git a/devel/pwlib/distinfo b/devel/pwlib/distinfo
index ce1d49d943f3..5bdd339b7d65 100644
--- a/devel/pwlib/distinfo
+++ b/devel/pwlib/distinfo
@@ -1,3 +1,3 @@
-MD5 (pwlib-v1_10_3-src-tar.gz) = 082eb57b4f52e4d487208de18d83ccf8
-SHA256 (pwlib-v1_10_3-src-tar.gz) = ba775e0798a7a54cda0bf7ee7fcdbd2bebe14b329b6aba3908bd410080a0bd42
-SIZE (pwlib-v1_10_3-src-tar.gz) = 2079871
+MD5 (openh323/ptlib-v1_12_0-src.tar.gz) = 675dc9cbe3f34c9aed07ec8650fecfd5
+SHA256 (openh323/ptlib-v1_12_0-src.tar.gz) = e150f8460b64bac3c9a90703db81c26ab3e402d19e5cd7b9ebc9d976a8f0535f
+SIZE (openh323/ptlib-v1_12_0-src.tar.gz) = 4316808
diff --git a/devel/pwlib/files/patch-configureac b/devel/pwlib/files/patch-configureac
index 8b8afd87ef68..43900bd8f98e 100644
--- a/devel/pwlib/files/patch-configureac
+++ b/devel/pwlib/files/patch-configureac
@@ -1,35 +1,26 @@
---- configure.ac.orig Wed Feb 22 05:53:28 2006
-+++ configure.ac Tue Nov 27 16:58:54 2007
-@@ -136,7 +136,7 @@
+--- configure.ac.orig 2007-10-19 02:22:39.000000000 -0400
++++ configure.ac 2007-12-30 16:24:01.000000000 -0500
+@@ -145,7 +145,7 @@
x86 | i686 | i586 | i486 | i386 ) MACHTYPE=x86
;;
- x86_64) MACHTYPE=x86_64 ;
-+ x86_64|amd64) MACHTYPE=x86_64 ;
++ x86_64|amd64) MACHTYPE=x86_64 ;
P_64BIT=1 ;
LIB64=1 ;
;;
-@@ -145,7 +145,9 @@
- P_64BIT=1 ;
+@@ -162,7 +162,9 @@
+ LIB64=1 ;
;;
- sparc ) MACHTYPE=sparc ;
-+ sparc|sparc64 ) MACHTYPE=sparc ;
-+ P_64BIT=1 ;
-+ LIB64=1 ;
++ sparc|sparc64 ) MACHTYPE=sparc ;
++ P_64BIT=1 ;
++ LIB64=1 ;
;;
powerpc ) MACHTYPE=ppc ;
-@@ -278,7 +280,7 @@
-
- AC_MSG_CHECKING(if linker accepts -Wreorder)
- AC_LANG_CONFTEST([[int main(int ac,char **av) { return 0; }]])
--$STDCXX $CXXFLAGS -Wreorder conftest.cc > /dev/null 2>&1
-+$CXX $CXXFLAGS -Wreorder conftest.cc > /dev/null 2>&1
- if test $? = 0 ; then
- AC_MSG_RESULT(yes)
- STDCXXFLAGS="$STDCXXFLAGS -Wreorder"
-@@ -291,7 +293,7 @@
+@@ -348,7 +350,7 @@
# $CXX $CFLAGS -Woverloaded-virtual conftest.cc > /dev/null 2>&1
# if test $? = 0 ; then
# AC_MSG_RESULT(yes)
@@ -38,7 +29,7 @@
# else
# AC_MSG_RESULT(no)
# fi
-@@ -320,7 +322,7 @@
+@@ -377,7 +379,7 @@
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
@@ -47,7 +38,7 @@
fi
GCSECTIONS=0
-@@ -341,7 +343,7 @@
+@@ -398,7 +400,7 @@
$CXX $CFLAGS -ffunction-sections -c conftest.cc > /dev/null 2>&1
if test $? = 0 ; then
AC_MSG_RESULT(yes)
@@ -56,7 +47,7 @@
GCSECTIONS=1
else
AC_MSG_RESULT(no)
-@@ -357,7 +359,7 @@
+@@ -414,7 +416,7 @@
dnl $CXX $CFLAGS -fdata-sections -c conftest.cc > /dev/null 2>&1
dnl if test $? = 0 ; then
dnl AC_MSG_RESULT(yes)
@@ -65,7 +56,7 @@
dnl GCSECTIONS=1
dnl else
dnl AC_MSG_RESULT(no)
-@@ -370,7 +372,7 @@
+@@ -427,7 +429,7 @@
dnl $CXX $CFLAGS -fvtable-gc -c conftest.cc > /dev/null 2>&1
dnl if test $? = 0 ; then
dnl AC_MSG_RESULT(yes)
@@ -74,22 +65,25 @@
dnl GCSECTIONS=1
dnl else
dnl AC_MSG_RESULT(no)
-@@ -593,12 +595,12 @@
+@@ -662,7 +664,7 @@
P_HAS_ATOMIC_INT=0
P_NEEDS_GNU_CXX_NAMESPACE=0
AC_MSG_CHECKING(if atomic integer available)
-AC_TRY_COMPILE([#include <bits/atomicity.h>],
+AC_TRY_COMPILE([#include ${ATOMICITY_H}],
- [_Atomic_word val;], P_HAS_ATOMIC_INT=1)
- if test ${P_HAS_ATOMIC_INT} = 1 ; then
+ [_Atomic_word val;], P_HAS_ATOMIC_INT=1,
+ AC_TRY_COMPILE([#include <ext/atomicity.h>],
+ [_Atomic_word val;], P_HAS_ATOMIC_INT=2)
+@@ -671,7 +673,7 @@
AC_MSG_RESULT(yes)
AC_MSG_CHECKING(if __exchange_and_add is in __gnu_cxx namespace)
-- AC_TRY_COMPILE([#include <bits/atomicity.h>],
-+ AC_TRY_COMPILE([#include ${ATOMICITY_H}],
- [_Atomic_word val; __gnu_cxx::__exchange_and_add(&val, 1)], P_NEEDS_GNU_CXX_NAMESPACE=1)
- if test ${P_NEEDS_GNU_CXX_NAMESPACE} = 1 ; then
- AC_MSG_RESULT(yes)
-@@ -640,7 +642,7 @@
+ if test ${P_HAS_ATOMIC_INT} = 1 ; then
+- AC_TRY_COMPILE([#include <bits/atomicity.h>],
++ AC_TRY_COMPILE([#include ${ATOMICITY_H}],
+ [_Atomic_word val; __gnu_cxx::__exchange_and_add(&val, 1)],
+ P_NEEDS_GNU_CXX_NAMESPACE=1)
+ else
+@@ -721,7 +723,7 @@
AC_MSG_CHECKING(for upad128_t)
AC_TRY_COMPILE([#include <sys/types.h>],
[upad128_t upad; upad._q = 0.0;], has_upad128_t=y)
@@ -98,7 +92,7 @@
AC_MSG_RESULT(yes)
AC_DEFINE(P_HAS_UPAD128_T)
else
-@@ -665,7 +667,7 @@
+@@ -746,7 +748,7 @@
fi
fi
@@ -107,14 +101,14 @@
AC_TRY_COMPILE([#include <semaphore.h>],
[sem_t *s = sem_open("test", O_CREAT)],
-@@ -689,18 +691,18 @@
+@@ -770,18 +772,18 @@
dnl MSWIN_DISPLAY semaphore,Semaphore Support
dnl MSWIN_DEFINE semaphore,P_HAS_SEMAPHORES
-dnl Linux, Mac OS X use libpthread and -lpthread
-dnl FreeBSD uses the -pthread compiler option and uses libc_r
-+dnl FreeBSD >= 5.x, Linux, Mac OS X use libpthread and -lpthread
-+dnl FreeBSD < 5.x uses the -pthread compiler option and uses libc_r
++dnl FreeBSD>=5.x, Linux, Mac OS X use libpthread and -lpthread
++dnl FreeBSD <5.x uses the -pthread compiler option and uses libc_r
AC_CHECK_LIB(pthread, pthread_create, HAS_PTHREADS=yes, HAS_PTHREADS=no)
if test ${HAS_PTHREADS} = yes ; then
@@ -129,19 +123,10 @@
- STDCCFLAGS="$STDCCFLAGS -D_REENTRANT -pthread"
+ ENDLDLIBS="$ENDLDLIBS ${PTHREAD_LIBS}"
+ STDCCFLAGS="$STDCCFLAGS -D_REENTRANT ${PTHREAD_LIBS}"
- fi
- fi
-
-@@ -746,7 +748,7 @@
- if test ${P_HAS_RECURSIVE_MUTEX} = 1 ; then
- AC_MSG_RESULT(yes)
- else
-- if test ${OSTYPE} == Darwin ; then
-+ if test ${OSTYPE} = Darwin ; then
- AC_TRY_COMPILE([#include <pthread.h>],
- [pthread_mutexattr_t attr; pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);], P_HAS_RECURSIVE_MUTEX=1)
- if test ${P_HAS_RECURSIVE_MUTEX} = 1 ; then
-@@ -847,7 +849,7 @@
+ elif test ${OSTYPE} = FreeBSD ; then
+ HAS_PTHREADS=yes
+ ENDLDLIBS="$ENDLDLIBS -pthread"
+@@ -928,7 +930,7 @@
AC_SUBST(HAS_PLUGINS)
if test "x$LIB64" != "x" ; then
@@ -150,35 +135,7 @@
else
AC_DEFINE_UNQUOTED([P_DEFAULT_PLUGIN_DIR], ["${INSTALLPREFIX}/lib/pwlib"], [Default plugin directory])
fi
-@@ -1253,7 +1255,7 @@
- else
- AC_CHECK_HEADERS(expat.h, HAS_EXPAT=1)
- if test "${HAS_EXPAT:-unset}" != "unset" ; then
-- AC_CHECK_LIB(expat, XML_ParserCreate, HAS_EXPAT=1, HAS_EXPAT=)
-+ AC_SEARCH_LIBS(XML_ParserCreate, expat, HAS_EXPAT=1, HAS_EXPAT=)
- else
- AC_CHECK_FILE(/usr/local/include/expat.h, HAS_EXPAT=1)
- if test "${HAS_EXPAT:-unset}" != "unset" ; then
-@@ -1428,7 +1430,8 @@
- if test $HAS_IPV6 = no ; then
- AC_MSG_RESULT(no)
- else
-- AC_TRY_COMPILE([#include <sys/socket.h>
-+ AC_TRY_COMPILE([#include <stddef.h>
-+ #include <sys/socket.h>
- #include <netdb.h>],
- [getnameinfo(NULL, 0, NULL, 0, NULL, 0, 0);], HAS_IPV6=yes, HAS_IPV6=no)
- if test $HAS_IPV6 = no ; then
-@@ -1485,7 +1488,7 @@
- HAS_SDL=
- if test "$enable_sdl" = "no" ; then
- AC_MSG_NOTICE(SDL disabled)
-- AC_DEFINE(P_SDL, 0)
-+# AC_DEFINE(P_SDL, 0)
- else
- dnl SDL checks
- if test "${SDLLIB:-unset}" = "unset" ; then
-@@ -1495,17 +1498,17 @@
+@@ -1660,7 +1662,7 @@
dnl Linux check
AC_CHECK_HEADERS(SDL/SDL.h, HAS_SDL=1)
if test "${HAS_SDL:-unset}" != "unset" ; then
@@ -187,29 +144,7 @@
X11LIBDIR=/usr/X11R6/lib
fi
AC_CHECK_LIB(SDL, SDL_CreateYUVOverlay, HAS_SDL=1, HAS_SDL=, -L${X11LIBDIR} -lpthread -lX11 -lXext)
- fi
-
-- dnl freeBSD SDL check
-+ dnl FreeBSD SDL check
- if test "${HAS_SDL:-unset}" = "unset" ; then
-- AC_CHECK_FILE(/usr/local/include/SDL11/SDL.h, HAS_SDL=1)
-+ AC_CHECK_HEADER(SDL/SDL.h, HAS_SDL=1)
- if test "${HAS_SDL:-unset}" != "unset" ; then
-- SDLLIB=SDL-1.1
-+ SDLLIB=SDL
- fi
- fi
-
-@@ -1527,7 +1530,7 @@
- dnl ########################################################################
- dnl check for video capture support.
- dnl videodev.h on linux
--dnl machine/ioctl_meteor on FreeBSD
-+dnl machine/ioctl_meteor or dev/bktr/ioctl_meteor.h on FreeBSD
- dnl i386/ioctl_meteor on OpenBSD
- dnl dev/ic/bt8xx on NetBSD
-
-@@ -1553,9 +1556,10 @@
+@@ -1718,9 +1720,10 @@
HAS_VIDEO_CAPTURE=1
else
AC_CHECK_HEADER(linux/videodev.h, HAS_VIDEO_CAPTURE=1)
@@ -217,19 +152,19 @@
- dnl AC_CHECK_HEADER(i386/ioctl_meteor.h, HAS_VIDEO_CAPTURE=1)
- dnl AC_CHECK_HEADER(dev/ic/bt8xx.h, HAS_VIDEO_CAPTURE=1)
+ AC_CHECK_HEADER(machine/ioctl_meteor.h, HAS_VIDEO_CAPTURE=1)
-+ AC_CHECK_HEADER(dev/bktr/ioctl_meteor.h, HAS_VIDEO_CAPTURE=1)
+ AC_CHECK_HEADER(i386/ioctl_meteor.h, HAS_VIDEO_CAPTURE=1)
+ AC_CHECK_HEADER(dev/ic/bt8xx.h, HAS_VIDEO_CAPTURE=1)
++ AC_CHECK_HEADER(dev/bktr/ioctl_meteor.h, HAS_VIDEO_CAPTURE=1)
if test "${HAS_VIDEO_CAPTURE}z" = "z" ; then
AC_MSG_NOTICE(No Video Capture support)
AC_DEFINE([NO_VIDEO_CAPTURE], [], [No video capture])
-@@ -2046,6 +2050,9 @@
- AC_MSG_NOTICE(C++ exceptions enabled)
- STDCCFLAGS="$STDCCFLAGS -fno-exceptions"
+@@ -2335,6 +2338,9 @@
+ STDCCFLAGS="$STDCCFLAGS -fexceptions"
fi
-+
+
+STDCCFLAGS="$CPPFLAGS $STDCCFLAGS"
+STDCXXFLAGS="$CPPFLAGS $STDCXXFLAGS"
-
++
dnl ########################################################################
dnl final declarations
+
diff --git a/devel/pwlib/files/patch-include-ptclib-dtmf-h b/devel/pwlib/files/patch-include-ptclib-dtmf-h
new file mode 100644
index 000000000000..90e66e13875f
--- /dev/null
+++ b/devel/pwlib/files/patch-include-ptclib-dtmf-h
@@ -0,0 +1,10 @@
+--- include/ptclib/dtmf.h.old 2007-10-19 02:22:38.000000000 -0400
++++ include/ptclib/dtmf.h 2008-01-05 21:17:30.000000000 -0500
+@@ -69,6 +69,7 @@
+ public:
+ PDTMFDecoder();
+ PString Decode(const short * sampleData, PINDEX numSamples);
++ PString Decode(const void * buf, PINDEX bytes);
+
+ protected:
+ enum {
diff --git a/devel/pwlib/files/patch-plugins-configure b/devel/pwlib/files/patch-plugins-configure
index 6f30e76f900a..ffc7dc4704e3 100644
--- a/devel/pwlib/files/patch-plugins-configure
+++ b/devel/pwlib/files/patch-plugins-configure
@@ -1,26 +1,26 @@
---- plugins/configure.orig Thu Apr 6 10:16:09 2006
-+++ plugins/configure Thu Apr 6 09:56:04 2006
+--- plugins/configure.orig 2007-10-19 02:22:33.000000000 -0400
++++ plugins/configure 2007-12-30 16:51:33.000000000 -0500
@@ -309,7 +309,7 @@
# include <unistd.h>
#endif"
--ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_OSS HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
-+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_OSS HAS_ESD HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_ESD HAS_OSS HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
++ac_subst_vars='HAS_ESD SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_ESD HAS_OSS HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
ac_subst_files=''
# Initialize some variables set by options.
-@@ -852,6 +852,7 @@
- --disable-audio disable audio support
+@@ -853,6 +853,7 @@
--enable-alsa enable ALSA audio support
+ --enable-esd enable ESD audio support
--enable-oss enable OSS audio support
-+ --enable-esd enable ESD audio support
++ --enable-eds enable ESD audio support
--enable-sunaudio enable Sun audio support
--disable-video disable video device support in PWLIB
--enable-v4l enable V4L video support
-@@ -3444,6 +3459,172 @@
+@@ -3623,6 +3624,171 @@
+ fi
fi
-
+# Check whether --enable-esd or --disable-esd was given.
+if test "${enable_esd+set}" = set; then
+ enableval="$enable_esd"
@@ -186,15 +186,15 @@
+fi
+
+
-+
+
# Check whether --enable-sunaudio or --disable-sunaudio was given.
if test "${enable_sunaudio+set}" = set; then
- enableval="$enable_sunaudio"
-@@ -4239,6 +4239,146 @@
+@@ -4277,6 +4443,148 @@
BSDVIDEOHDR=1
fi
-+ if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
++
++if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
+ echo "$as_me:$LINENO: checking for dev/bktr/ioctl_meteor.h" >&5
+echo $ECHO_N "checking for dev/bktr/ioctl_meteor.h... $ECHO_C" >&6
+if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
@@ -334,12 +334,13 @@
+if test $ac_cv_header_dev_bktr_ioctl_meteor_h = yes; then
+ BSDVIDEOHDR=1
+fi
++
- if test "${ac_cv_header_dev_ic_bt8xx_h+set}" = set; then
- echo "$as_me:$LINENO: checking for dev/ic/bt8xx.h" >&5
-@@ -5872,6 +6065,7 @@
- s,@EGREP@,$EGREP,;t t
+ if test "${ac_cv_header_i386_ioctl_meteor_h+set}" = set; then
+ echo "$as_me:$LINENO: checking for i386/ioctl_meteor.h" >&5
+@@ -6060,6 +6368,7 @@
s,@HAS_ALSA@,$HAS_ALSA,;t t
+ s,@HAS_ESD@,$HAS_ESD,;t t
s,@HAS_OSS@,$HAS_OSS,;t t
+s,@HAS_ESD@,$HAS_ESD,;t t
s,@HAS_SUNAUDIO@,$HAS_SUNAUDIO,;t t
diff --git a/devel/pwlib/files/patch-plugins-sound_esd-Makefile b/devel/pwlib/files/patch-plugins-sound_esd-Makefile
deleted file mode 100644
index 41a36b0da932..000000000000
--- a/devel/pwlib/files/patch-plugins-sound_esd-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/sound_esd/Makefile.orig Thu Apr 6 16:47:13 2006
-+++ plugins/sound_esd/Makefile Thu Apr 6 16:50:52 2006
-@@ -4,7 +4,7 @@
-
- PLUGIN_NAME = esd
- PLUGIN_FAMILY = device/sound
--PLUGIN_LIBS =
-+PLUGIN_LIBS = $(LDFLAGS) -lesd
- PLUGIN_SOURCES = sound_esd.cxx
-
- include ../../make/plugins.mak
diff --git a/devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h b/devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h
deleted file mode 100644
index bc36e0202936..000000000000
--- a/devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- plugins/sound_esd/sound_esd.h.orig Thu Apr 6 16:47:28 2006
-+++ plugins/sound_esd/sound_esd.h Thu Apr 6 16:48:06 2006
-@@ -43,15 +43,15 @@
- unsigned _bitsPerSample);
- BOOL Setup();
- BOOL Close();
-- BOOL IsOpen() const;
-+// BOOL IsOpen() const;
- BOOL Write(const void * buf, PINDEX len);
- BOOL Read(void * buf, PINDEX len);
- BOOL SetFormat(unsigned numChannels,
- unsigned sampleRate,
- unsigned bitsPerSample);
-- unsigned GetChannels() const;
-- unsigned GetSampleRate() const;
-- unsigned GetSampleSize() const;
-+// unsigned GetChannels() const;
-+// unsigned GetSampleRate() const;
-+// unsigned GetSampleSize() const;
- BOOL SetBuffers(PINDEX size, PINDEX count);
- BOOL GetBuffers(PINDEX & size, PINDEX & count);
- BOOL PlaySound(const PSound & sound, BOOL wait);
diff --git a/devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx b/devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx
new file mode 100644
index 000000000000..6f18e5cc9f87
--- /dev/null
+++ b/devel/pwlib/files/patch-plugins-sound_oss-sound_oss_cxx
@@ -0,0 +1,10 @@
+--- plugins/sound_oss/sound_oss.cxx.orig 2007-10-19 02:22:33.000000000 -0400
++++ plugins/sound_oss/sound_oss.cxx 2007-12-30 20:46:38.000000000 -0500
+@@ -643,6 +643,7 @@
+ arg = val = (entry.numChannels == 2) ? 1 : 0;
+ if (ConvertOSError(::ioctl(os_handle, SNDCTL_DSP_STEREO, &arg)) || (arg != val)) {
+
++ resampleRate = entry.resampleRate;
+ mSampleRate = entry.sampleRate;
+ arg = val = entry.sampleRate;
+ if (ConvertOSError(::ioctl(os_handle, SNDCTL_DSP_SPEED, &arg))) {
diff --git a/devel/pwlib/files/patch-plugins-vidinput_avc-Makefile b/devel/pwlib/files/patch-plugins-vidinput_avc-Makefile
deleted file mode 100644
index 9dfbbb6e34bb..000000000000
--- a/devel/pwlib/files/patch-plugins-vidinput_avc-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/vidinput_avc/Makefile.orig Fri Nov 14 07:16:13 2003
-+++ plugins/vidinput_avc/Makefile Thu Apr 6 17:00:31 2006
-@@ -4,7 +4,7 @@
-
- PLUGIN_NAME = avc
- PLUGIN_FAMILY = device/videoinput
--PLUGIN_LIBS = -lraw1394 -ldv -lrom1394
-+PLUGIN_LIBS = $(LDFLAGS) -lraw1394 -ldv -lrom1394
- PLUGIN_SOURCES = vidinput_avc.cxx
-
- include ../../make/plugins.mak
diff --git a/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx b/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx
deleted file mode 100644
index 7207595c071b..000000000000
--- a/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.cxx
+++ /dev/null
@@ -1,43 +0,0 @@
---- plugins/vidinput_bsd/vidinput_bsd.cxx.orig Tue Aug 9 11:08:09 2005
-+++ plugins/vidinput_bsd/vidinput_bsd.cxx Wed Apr 5 21:35:08 2006
-@@ -122,12 +122,11 @@
- #pragma implementation "vidinput_bsd.h"
-
- #include "vidinput_bsd.h"
--#include <sys/mman.h>
-
- PCREATE_VIDINPUT_PLUGIN(BSDCAPTURE);
-
- ///////////////////////////////////////////////////////////////////////////////
--// PVideoInputDevice_BSDCAPTURE
-+// PVideoInputBSDCAPTURE
-
- PVideoInputDevice_BSDCAPTURE::PVideoInputDevice_BSDCAPTURE()
- {
-@@ -142,6 +141,7 @@
-
- BOOL PVideoInputDevice_BSDCAPTURE::Open(const PString & devName, BOOL startImmediate)
- {
-+ if (IsOpen())
- Close();
-
- deviceName = devName;
-@@ -235,10 +235,14 @@
- {
- PStringList list;
-
-- list.AppendString("/dev/bktr0");
-- list.AppendString("/dev/bktr1");
-- list.AppendString("/dev/meteor0");
-- list.AppendString("/dev/meteor1");
-+ if (PFile::Exists("/dev/bktr0"))
-+ list.AppendString("/dev/bktr0");
-+ if (PFile::Exists("/dev/bktr1"))
-+ list.AppendString("/dev/bktr1");
-+ if (PFile::Exists("/dev/meteor0"))
-+ list.AppendString("/dev/meteor0");
-+ if (PFile::Exists("/dev/meteor1"))
-+ list.AppendString("/dev/meteor1");
-
- return list;
- }
diff --git a/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h b/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h
deleted file mode 100644
index e3e6d99d5b32..000000000000
--- a/devel/pwlib/files/patch-plugins-vidinput_bsd-vidinput_bsd.h
+++ /dev/null
@@ -1,100 +0,0 @@
---- plugins/vidinput_bsd/vidinput_bsd.h.orig Tue Aug 9 05:08:09 2005
-+++ plugins/vidinput_bsd/vidinput_bsd.h Sun May 14 13:42:28 2006
-@@ -1,15 +1,29 @@
-+#ifndef _PVIDEOIOBSDCAPTURE
-
--//#include <sys/mman.h>
--//#include <sys/time.h>
-+#define _PVIDEOIOBSDCAPTURE
-+
-+#ifdef __GNUC__
-+#pragma interface
-+#endif
-
- #include <ptlib.h>
- #include <ptlib/videoio.h>
- #include <ptlib/vconvert.h>
-
- #if defined(P_FREEBSD)
-+#include <sys/param.h>
-+#if __FreeBSD_version <= 500000
-+#include <sys/types.h>
-+#endif
-+# if __FreeBSD_version >= 502100
-+#include <dev/bktr/ioctl_meteor.h>
-+# else
- #include <machine/ioctl_meteor.h>
-+# endif
- #endif
-
-+#include <sys/mman.h>
-+
- #if defined(P_OPENBSD) || defined(P_NETBSD)
- #if P_OPENBSD >= 200105
- #include <dev/ic/bt8xx.h>
-@@ -20,19 +34,24 @@
- #endif
- #endif
-
--class PVideoInputDevice_BSDCAPTURE: public PVideoInputDevice
-+#if !P_USE_INLINES
-+#include <ptlib/contain.inl>
-+#endif
-+
-+
-+class PVideoInputDevice_BSDCAPTURE : public PVideoInputDevice
- {
-
-+ PCLASSINFO(PVideoInputDevice_BSDCAPTURE, PVideoInputDevice);
-+
- public:
- PVideoInputDevice_BSDCAPTURE();
- ~PVideoInputDevice_BSDCAPTURE();
-
-- static PStringList GetInputDeviceNames();
--
-- PStringList GetDeviceNames() const
-- { return GetInputDeviceNames(); }
--
-- BOOL Open(const PString &deviceName, BOOL startImmediate);
-+ BOOL Open(
-+ const PString &deviceName,
-+ BOOL startImmediate = TRUE
-+ );
-
- BOOL IsOpen();
-
-@@ -43,11 +62,24 @@
-
- BOOL IsCapturing();
-
-+ static PStringList GetInputDeviceNames();
-+
-+ PStringList GetDeviceNames() const
-+ { return GetInputDeviceNames(); }
-+
- PINDEX GetMaxFrameBytes();
-
-- BOOL GetFrame(PBYTEArray & frame);
-- BOOL GetFrameData(BYTE*, PINDEX*);
-- BOOL GetFrameDataNoDelay(BYTE*, PINDEX*);
-+// BOOL GetFrame(
-+// PBYTEArray & frame
-+// );
-+ BOOL GetFrameData(
-+ BYTE * buffer,
-+ PINDEX * bytesReturned = NULL
-+ );
-+ BOOL GetFrameDataNoDelay(
-+ BYTE * buffer,
-+ PINDEX * bytesReturned = NULL
-+ );
-
- BOOL GetFrameSizeLimits(unsigned int&, unsigned int&,
- unsigned int&, unsigned int&);
-@@ -99,3 +131,5 @@
- int mmap_size;
-
- };
-+
-+#endif
diff --git a/devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in b/devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in
deleted file mode 100644
index f367f2855c6b..000000000000
--- a/devel/pwlib/files/patch-plugins-vidinput_dc-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/vidinput_dc/Makefile.in.orig Thu Apr 6 17:01:27 2006
-+++ plugins/vidinput_dc/Makefile.in Thu Apr 6 17:01:38 2006
-@@ -4,7 +4,7 @@
-
- PLUGIN_NAME = dc
- PLUGIN_FAMILY = device/videoinput
--PLUGIN_LIBS = -lraw1394 -ldv -ldc1394_control
-+PLUGIN_LIBS = $(LDFLAGS) -lraw1394 -ldv -ldc1394_control
- PLUGIN_SOURCES = video4dc1394.cxx
-
- CFLAGS = @DC_CFLAGS@
diff --git a/devel/pwlib/files/patch-src-ptlib-unix-tlib-cxx b/devel/pwlib/files/patch-src-ptlib-unix-tlib-cxx
new file mode 100644
index 000000000000..1593a1c8b6e2
--- /dev/null
+++ b/devel/pwlib/files/patch-src-ptlib-unix-tlib-cxx
@@ -0,0 +1,11 @@
+--- src/ptlib/unix/tlib.cxx 2007-10-19 02:22:32.000000000 -0400
++++ src/ptlib/unix/tlib.cxx 2008-01-06 21:15:54.000000000 -0500
+@@ -642,7 +642,7 @@
+ {
+ if (PProcessInstance != NULL) {
+ PWaitAndSignal m(PProcessInstance->threadMutex);
+- PThread & thread = PProcessInstance->activeThreads[(unsigned)id];
++ PThread & thread = PProcessInstance->activeThreads[(uintptr_t)id];
+ return thread.GetThreadName();
+ }
+ return psprintf("%08x", id);
diff --git a/devel/pwlib/files/patch-src-ptlib-unix-udll.cxx b/devel/pwlib/files/patch-src-ptlib-unix-udll.cxx
deleted file mode 100644
index 8cfadebbfe9f..000000000000
--- a/devel/pwlib/files/patch-src-ptlib-unix-udll.cxx
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/ptlib/unix/udll.cxx.orig Wed Nov 30 13:47:42 2005
-+++ src/ptlib/unix/udll.cxx Wed Apr 5 22:36:51 2006
-@@ -382,6 +382,10 @@
- dllHandle = dlopen((char *)(const char *)name, RTLD_NOW);
- #else
-+ const char *dummyerr = dlerror();
- dllHandle = dlopen((const char *)name, RTLD_NOW);
-+ const char *err = dlerror();
-+ if (err != NULL)
-+ cerr << err << '\n';
- #endif
-
- return IsLoaded();
diff --git a/devel/pwlib/files/patch-src_ptclib_dtmf_cxx b/devel/pwlib/files/patch-src_ptclib_dtmf_cxx
new file mode 100644
index 000000000000..828ee564e1d6
--- /dev/null
+++ b/devel/pwlib/files/patch-src_ptclib_dtmf_cxx
@@ -0,0 +1,67 @@
+--- src/ptclib/dtmf.cxx.old 2007-10-19 02:22:33.000000000 -0400
++++ src/ptclib/dtmf.cxx 2008-01-05 21:17:37.000000000 -0500
+@@ -121,6 +121,64 @@
+ }
+
+
++PString PDTMFDecoder::Decode(const void *buf, PINDEX bytes)
++{
++ int x;
++ int s, kk;
++ int c, d, f, n;
++ short *buffer = (short *)buf;
++
++ PINDEX numSamples = bytes >> 1;
++
++ PString keyString;
++
++ PINDEX pos;
++ for (pos = 0; pos < numSamples; pos++) {
++
++ /* Read (and scale) the next 16 bit sample */
++ x = ((int)(*buffer++)) / (32768/FSC);
++
++ /* Input amplitude */
++ if (x > 0)
++ ia += (x - ia) / 128;
++ else
++ ia += (-x - ia) / 128;
++
++ /* For each tone */
++ s = 0;
++ for(kk = 0; kk < 8; kk++) {
++
++ /* Turn the crank */
++ c = (P2 * (x - k[kk])) / FSC;
++ d = x + c;
++ f = (p1[kk] * (d - h[kk])) / FSC;
++ n = x - k[kk] - c;
++ k[kk] = h[kk] + f;
++ h[kk] = f + d;
++
++ /* Detect and Average */
++ if (n > 0)
++ y[kk] += (n - y[kk]) / 64;
++ else
++ y[kk] += (-n - y[kk]) / 64;
++
++ /* Threshold */
++ if (y[kk] > FSC/10 && y[kk] > ia)
++ s |= 1 << kk;
++ }
++
++ /* Hysteresis and noise supressor */
++ if (s != so) {
++ nn = 0;
++ so = s;
++ } else if (nn++ == 520 && s < 256 && key[s] != '?') {
++ PTRACE(3,"DTMF\tDetected '" << key[s] << "' in PCM-16 stream");
++ keyString += key[s];
++ }
++ }
++ return keyString;
++}
++
+ PString PDTMFDecoder::Decode(const short * sampleData, PINDEX numSamples)
+ {
+ int x;
diff --git a/devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx b/devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx
deleted file mode 100644
index 113cf9728c88..000000000000
--- a/devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/ptlib/common/jidctflt.cxx.orig Wed Apr 5 07:08:00 2006
-+++ src/ptlib/common/jidctflt.cxx Wed Apr 5 07:08:08 2006
-@@ -80,7 +80,8 @@
-
- #define DEQUANTIZE(coef,quantval) (((FAST_FLOAT) (coef)) * (quantval))
-
--#if defined(__GNUC__) && (defined(__i686__) || defined(__x86_64__))
-+/* asm doesn't compile properly... avoid using */
-+#if 0
-
- static inline unsigned char descale_and_clamp(int x, int shift)
- {
diff --git a/devel/pwlib/files/patch-src_ptlib_unix_tlibthrd.cxx b/devel/pwlib/files/patch-src_ptlib_unix_tlibthrd.cxx
index 16c8461e7440..5ff364393487 100644
--- a/devel/pwlib/files/patch-src_ptlib_unix_tlibthrd.cxx
+++ b/devel/pwlib/files/patch-src_ptlib_unix_tlibthrd.cxx
@@ -5,7 +5,7 @@
PWaitAndSignal m(threadMutex);
- if (!activeThreads.Contains((unsigned)id))
-+ if (!activeThreads.Contains((unsigned long)id))
++ if (!activeThreads.Contains((uintptr_t)id))
return FALSE;
return pthread_kill(id, sig) == 0;
@@ -14,7 +14,7 @@
((PProcess *)this)->activeThreads.DisallowDeleteObjects();
- ((PProcess *)this)->activeThreads.SetAt((unsigned)PX_threadId, this);
-+ ((PProcess *)this)->activeThreads.SetAt((unsigned long)PX_threadId, this);
++ ((PProcess *)this)->activeThreads.SetAt((uintptr_t)PX_threadId, this);
PX_firstTimeStart = FALSE;
@@ -23,7 +23,7 @@
// put the thread into the thread list
- process.activeThreads.SetAt((unsigned)PX_threadId, this);
-+ process.activeThreads.SetAt((unsigned long)PX_threadId, this);
++ process.activeThreads.SetAt((uintptr_t)PX_threadId, this);
if (process.activeThreads.GetSize() > highWaterMark)
newHighWaterMark = highWaterMark = process.activeThreads.GetSize();
@@ -32,7 +32,7 @@
PProcess & process = PProcess::Current();
process.threadMutex.Wait();
- PThread * thread = process.activeThreads.GetAt((unsigned)pthread_self());
-+ PThread * thread = process.activeThreads.GetAt((unsigned long)pthread_self());
++ PThread * thread = process.activeThreads.GetAt((uintptr_t)pthread_self());
process.threadMutex.Signal();
return thread;
}
@@ -41,7 +41,7 @@
// remove this thread from the active thread list
- process.activeThreads.SetAt((unsigned)id, NULL);
-+ process.activeThreads.SetAt((unsigned long)id, NULL);
++ process.activeThreads.SetAt((uintptr_t)id, NULL);
// delete the thread if required, note this is done this way to avoid
// a race condition, the thread ID cannot be zeroed before the if!
diff --git a/devel/pwlib/pkg-plist b/devel/pwlib/pkg-plist
index 74bf980ee791..212dacc0bfc7 100644
--- a/devel/pwlib/pkg-plist
+++ b/devel/pwlib/pkg-plist
@@ -1,5 +1,14 @@
bin/ptlib-config
include/ptbuildopts.h
+include/ptclib/guid.h
+include/ptclib/podbc.h
+include/ptclib/pvfiledev.h
+include/ptclib/pwavfiledev.h
+include/ptclib/snmp.h
+include/ptclib/paec.h
+include/ptclib/psockbun.h
+include/ptclib/pvidfile.h
+include/ptclib/rfc1155.h
include/ptclib/asnber.h
include/ptclib/asner.h
include/ptclib/asnper.h
@@ -58,6 +67,7 @@ include/ptlib/config.h
include/ptlib/contain.h
include/ptlib/contain.inl
include/ptlib/critsec.h
+include/ptlib/devplugin.h
include/ptlib/dict.h
include/ptlib/dynalink.h
include/ptlib/ethsock.h
@@ -133,6 +143,7 @@ include/ptlib/unix/ptlib/resampler.h
include/ptlib/unix/ptlib/semaphor.h
include/ptlib/unix/ptlib/serchan.h
include/ptlib/unix/ptlib/sfile.h
+include/ptlib/unix/ptlib/shmvideo.h
include/ptlib/unix/ptlib/socket.h
include/ptlib/unix/ptlib/sound.h
include/ptlib/unix/ptlib/svcproc.h
@@ -166,18 +177,12 @@ lib/pwlib/devices/sound/oss_pwplugin.so
@dirrm lib/pwlib/devices
@dirrmtry lib/pwlib
%%DATADIR%%/make/common.mak
-%%DATADIR%%/make/defaultgui.mak
-%%DATADIR%%/make/gui.mak
%%DATADIR%%/make/lib.mak
-%%DATADIR%%/make/motif.mak
%%DATADIR%%/make/plugins.mak
%%DATADIR%%/make/ptbuildopts.mak
%%DATADIR%%/make/ptlib-config
%%DATADIR%%/make/ptlib.mak
-%%DATADIR%%/make/pwlib.mak
-%%DATADIR%%/make/qt.mak
%%DATADIR%%/make/unix.mak
-%%DATADIR%%/make/xlib.mak
%%DATADIR%%/version.h
@dirrm %%DATADIR%%/make
@dirrm %%DATADIR%%