aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-10 21:29:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-10 21:29:51 +0000
commit4c44860299f2b768b886621ae340c62bf4411c54 (patch)
tree8ed4f0653da18b87532462bcc92e5bbcdde0fc27 /devel/pwlib
parent0c3b612ad1eeacee1fd1ffbfbc358fd8198abbd0 (diff)
downloadports-4c44860299f2b768b886621ae340c62bf4411c54.tar.gz
ports-4c44860299f2b768b886621ae340c62bf4411c54.zip
Notes
Diffstat (limited to 'devel/pwlib')
-rw-r--r--devel/pwlib/Makefile3
-rw-r--r--devel/pwlib/distinfo4
-rw-r--r--devel/pwlib/files/patch-make-common.mak19
-rw-r--r--devel/pwlib/files/patch-src-ptclib-ansper.cxx (renamed from devel/pwlib/files/patch-src::ptclib::asner.cxx)14
-rw-r--r--devel/pwlib/files/patch-unix26
5 files changed, 41 insertions, 25 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 4310b56aad73..378dbaced7ee 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pwlib
-PORTVERSION= 1.5.0
-PORTREVISION= 5
+PORTVERSION= 1.5.2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.openh323.org/bin/ \
diff --git a/devel/pwlib/distinfo b/devel/pwlib/distinfo
index 4161caba80d6..b8697d9ca844 100644
--- a/devel/pwlib/distinfo
+++ b/devel/pwlib/distinfo
@@ -1,2 +1,2 @@
-MD5 (pwlib_1.5.0.tar.gz) = e6bcdd121a85687c040f4871f24b7352
-SIZE (pwlib_1.5.0.tar.gz) = 1074311
+MD5 (pwlib_1.5.2.tar.gz) = 0fa33ba1b32b254abe0b731a52c0f2f9
+SIZE (pwlib_1.5.2.tar.gz) = 1085203
diff --git a/devel/pwlib/files/patch-make-common.mak b/devel/pwlib/files/patch-make-common.mak
new file mode 100644
index 000000000000..44f8b75a64d4
--- /dev/null
+++ b/devel/pwlib/files/patch-make-common.mak
@@ -0,0 +1,19 @@
+*** make/common.mak.orig Tue Jul 29 11:25:23 2003
+--- make/common.mak Wed Jun 8 16:50:19 2005
+***************
+*** 262,268 ****
+ endif
+
+ ifneq ($(P_SHAREDLIB),1)
+! LDFLAGS += -static
+ endif
+
+ # clean whitespace out of source file list
+--- 262,268 ----
+ endif
+
+ ifneq ($(P_SHAREDLIB),1)
+! #LDFLAGS += -static
+ endif
+
+ # clean whitespace out of source file list
diff --git a/devel/pwlib/files/patch-src::ptclib::asner.cxx b/devel/pwlib/files/patch-src-ptclib-ansper.cxx
index 4776c3cab7f4..27f09e7b8870 100644
--- a/devel/pwlib/files/patch-src::ptclib::asner.cxx
+++ b/devel/pwlib/files/patch-src-ptclib-ansper.cxx
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- src/ptclib/asner.cxx 2004/06/03 14:44:43 1.1
-+++ src/ptclib/asner.cxx 2004/06/03 14:50:35
-@@ -4926,6 +4926,11 @@
+--- src/ptclib/asnper.cxx Fri Aug 1 02:11:38 2003
++++ src/ptclib/asnper.cxx Fri Jun 3 14:32:55 2005
+@@ -1224,6 +1224,11 @@
return -1;
value += lower;
@@ -15,7 +12,7 @@ $FreeBSD$
return 0;
}
-@@ -4970,7 +4975,13 @@
+@@ -1268,7 +1273,14 @@
unsigned base;
if (!MultiBitDecode(CountBits(upper - lower + 1), base))
return -1;
@@ -27,10 +24,11 @@ $FreeBSD$
+ len = upper;
+
+ return len;
++
}
if (upper < 65536) // 10.9.3.3
-@@ -4981,13 +4992,20 @@
+@@ -1279,13 +1291,20 @@
if (IsAtEnd())
return -1;
diff --git a/devel/pwlib/files/patch-unix b/devel/pwlib/files/patch-unix
index 205bd870e479..945ad223fb83 100644
--- a/devel/pwlib/files/patch-unix
+++ b/devel/pwlib/files/patch-unix
@@ -1,7 +1,7 @@
-*** make/unix.mak.orig Thu Aug 28 08:39:18 2003
---- make/unix.mak Thu Aug 28 08:42:30 2003
-*************** endif # linux
-*** 338,348 ****
+*** make/unix.mak.orig Thu Jul 24 22:01:42 2003
+--- make/unix.mak Fri Jun 3 15:13:47 2005
+***************
+*** 358,368 ****
ifeq ($(OSTYPE),FreeBSD)
@@ -13,7 +13,7 @@
ifndef OSRELEASE
OSRELEASE := $(shell sysctl -n kern.osreldate)
---- 338,348 ----
+--- 358,368 ----
ifeq ($(OSTYPE),FreeBSD)
@@ -25,8 +25,8 @@
ifndef OSRELEASE
OSRELEASE := $(shell sysctl -n kern.osreldate)
-*************** SHELL := /bin/sh
-*** 871,881 ****
+***************
+*** 891,901 ****
# Directories
@@ -38,7 +38,7 @@
ifndef UNIX_SRC_DIR
UNIX_SRC_DIR = $(PWLIBDIR)/src/ptlib/unix
---- 871,881 ----
+--- 891,901 ----
# Directories
@@ -50,20 +50,20 @@
ifndef UNIX_SRC_DIR
UNIX_SRC_DIR = $(PWLIBDIR)/src/ptlib/unix
-*************** LDFLAGS += $(DEBLDFLAGS)
-*** 912,918 ****
+***************
+*** 932,938 ****
else
ifneq ($(OSTYPE),Darwin)
-! OPTCCFLAGS += -O3 -DNDEBUG
+! OPTCCFLAGS += -Os -DNDEBUG
else
OPTCCFLAGS += -O2 -DNDEBUG
endif
---- 912,919 ----
+--- 932,939 ----
else
ifneq ($(OSTYPE),Darwin)
-! # OPTCCFLAGS += -O3 -DNDEBUG
+! # OPTCCFLAGS += -Os -DNDEBUG
! OPTCCFLAGS += -DNDEBUG
else
OPTCCFLAGS += -O2 -DNDEBUG