aboutsummaryrefslogtreecommitdiff
path: root/devel/py-Jinja/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-02-16 10:05:44 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-02-16 10:05:44 +0000
commitda5cceaf3561f68403bab0bb8cad37e33e6035e8 (patch)
treed01a70e0a35f0175a160212ed468bac168898c2c /devel/py-Jinja/Makefile
parentb37ddea6a7e573cc8b9d4e7a955346f1b26cdffe (diff)
Notes
Diffstat (limited to 'devel/py-Jinja/Makefile')
-rw-r--r--devel/py-Jinja/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/py-Jinja/Makefile b/devel/py-Jinja/Makefile
new file mode 100644
index 000000000000..7d7cab7e6e20
--- /dev/null
+++ b/devel/py-Jinja/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jinja
+# Date created: 2007-02-14
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Jinja
+PORTVERSION= 0.9
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/J/${PORTNAME}/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= A fast, and easy to use stand-alone template engine
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} \
+ PYJINJA_EGG=${PYJINJA_EGG}
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+PYJINJA_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>