aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ToscaWidgets/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-04 23:15:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-04 23:15:59 +0000
commit63a8158f14352e305e07b324bf4a821dfbe04887 (patch)
treecc1083025a654d4e9f3a16b5a4f07fdecd8e6d18 /devel/py-ToscaWidgets/Makefile
parent60fed8013c3d8e75e791bfec97f9f7abd3cae7aa (diff)
downloadports-63a8158f14352e305e07b324bf4a821dfbe04887.tar.gz
ports-63a8158f14352e305e07b324bf4a821dfbe04887.zip
Notes
Diffstat (limited to 'devel/py-ToscaWidgets/Makefile')
-rw-r--r--devel/py-ToscaWidgets/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/py-ToscaWidgets/Makefile b/devel/py-ToscaWidgets/Makefile
new file mode 100644
index 000000000000..e06c02c4feea
--- /dev/null
+++ b/devel/py-ToscaWidgets/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-ToscaWidgets
+# Date created: 1st July, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= ToscaWidgets
+PORTVERSION= 0.9.7.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A python framework for building reusable web components
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}webob>=0:${PORTSDIR}/www/py-webob \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:${PORTSDIR}/devel/py-simplejson
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>