aboutsummaryrefslogtreecommitdiff
path: root/devel/py-argparse/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-05 22:35:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-05 22:35:33 +0000
commit146e3539c6e44e530dd63ad75406275105cbe0b4 (patch)
tree2b25c63cbeef0f3905b55611daff4610bc5d8f40 /devel/py-argparse/Makefile
parent64214e1ab1f5a0b0c1e952ab9535f72f5f4411ca (diff)
downloadports-146e3539c6e44e530dd63ad75406275105cbe0b4.tar.gz
ports-146e3539c6e44e530dd63ad75406275105cbe0b4.zip
Notes
Diffstat (limited to 'devel/py-argparse/Makefile')
-rw-r--r--devel/py-argparse/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/py-argparse/Makefile b/devel/py-argparse/Makefile
new file mode 100644
index 000000000000..7ce216ff1fc5
--- /dev/null
+++ b/devel/py-argparse/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-argparse
+# Date created: Jan. 05, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= argparse
+PORTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/a/argparse/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= An optparse-inspired command-line parsing library
+
+USE_ZIP= yes
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/argparse.py \
+ %%PYTHON_SITELIBDIR%%/argparse.pyc \
+ %%PYTHON_SITELIBDIR%%/argparse.pyo
+
+.include <bsd.port.mk>