aboutsummaryrefslogtreecommitdiff
path: root/devel/py-argparse
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-05 22:35:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-05 22:35:33 +0000
commit146e3539c6e44e530dd63ad75406275105cbe0b4 (patch)
tree2b25c63cbeef0f3905b55611daff4610bc5d8f40 /devel/py-argparse
parent64214e1ab1f5a0b0c1e952ab9535f72f5f4411ca (diff)
downloadports-146e3539c6e44e530dd63ad75406275105cbe0b4.tar.gz
ports-146e3539c6e44e530dd63ad75406275105cbe0b4.zip
Notes
Diffstat (limited to 'devel/py-argparse')
-rw-r--r--devel/py-argparse/Makefile26
-rw-r--r--devel/py-argparse/distinfo3
-rw-r--r--devel/py-argparse/pkg-descr7
3 files changed, 36 insertions, 0 deletions
diff --git a/devel/py-argparse/Makefile b/devel/py-argparse/Makefile
new file mode 100644
index 000000000000..7ce216ff1fc5
--- /dev/null
+++ b/devel/py-argparse/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-argparse
+# Date created: Jan. 05, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= argparse
+PORTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/a/argparse/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= An optparse-inspired command-line parsing library
+
+USE_ZIP= yes
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/argparse.py \
+ %%PYTHON_SITELIBDIR%%/argparse.pyc \
+ %%PYTHON_SITELIBDIR%%/argparse.pyo
+
+.include <bsd.port.mk>
diff --git a/devel/py-argparse/distinfo b/devel/py-argparse/distinfo
new file mode 100644
index 000000000000..da5d5ef8bb87
--- /dev/null
+++ b/devel/py-argparse/distinfo
@@ -0,0 +1,3 @@
+MD5 (argparse-0.4.0.zip) = 9240b1183f2c08a1eb5b48e0adae689b
+SHA256 (argparse-0.4.0.zip) = ced2c1a18794fbd6232780f050e77f86a1e1a6ab28e1fce1aacc97b2b18b0618
+SIZE (argparse-0.4.0.zip) = 15031
diff --git a/devel/py-argparse/pkg-descr b/devel/py-argparse/pkg-descr
new file mode 100644
index 000000000000..e3695583b712
--- /dev/null
+++ b/devel/py-argparse/pkg-descr
@@ -0,0 +1,7 @@
+Argparse takes the best of the optparse command-line parsing module and brings
+it new life. Argparse adds positional as well as optional arguments, the
+ability to create parsers for sub-commands, more informative help and usage
+messages, and much more. At the same time, it retains the ease and flexibility
+of use that made optparse so popular.
+
+WWW: http://argparse.python-hosting.com/