aboutsummaryrefslogtreecommitdiff
path: root/devel/py-configobj/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-18 23:50:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-18 23:50:50 +0000
commit1ba663693e12115aaa502c7d20c0a88777efe5a5 (patch)
tree6739c97bf2145fba21f113e1da818f4a461f6afb /devel/py-configobj/Makefile
parent58dc95b9cc7cf05e4b41dc4cb14a766e695ca5e4 (diff)
downloadports-1ba663693e12115aaa502c7d20c0a88777efe5a5.tar.gz
ports-1ba663693e12115aaa502c7d20c0a88777efe5a5.zip
Notes
Diffstat (limited to 'devel/py-configobj/Makefile')
-rw-r--r--devel/py-configobj/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/py-configobj/Makefile b/devel/py-configobj/Makefile
new file mode 100644
index 000000000000..7b2a4a9768f8
--- /dev/null
+++ b/devel/py-configobj/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-configobj
+# Date created: 2006-10-20
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= configobj
+PORTVERSION= 4.3.2
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHONPKGNAMEPREFIX}
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= Simple but powerful config file reader and writer
+
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PORTDOCS= *
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -r ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>