aboutsummaryrefslogtreecommitdiff
path: root/devel/py-dal
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2008-10-21 20:43:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2008-10-21 20:43:05 +0000
commit4bdc0a2961be24dd5b1f9778dd0891d5b2441cdc (patch)
tree259bc10ff60a82e39ec8059117a5f1f404bf51d1 /devel/py-dal
parente7f72d052d0cc30cb97b88b2996ac45afd52552c (diff)
downloadports-4bdc0a2961be24dd5b1f9778dd0891d5b2441cdc.tar.gz
ports-4bdc0a2961be24dd5b1f9778dd0891d5b2441cdc.zip
Notes
Diffstat (limited to 'devel/py-dal')
-rw-r--r--devel/py-dal/Makefile20
-rw-r--r--devel/py-dal/distinfo3
-rw-r--r--devel/py-dal/pkg-descr9
-rw-r--r--devel/py-dal/pkg-plist1
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/py-dal/Makefile b/devel/py-dal/Makefile
new file mode 100644
index 000000000000..b652b7e5ea38
--- /dev/null
+++ b/devel/py-dal/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-breve
+# Date created: 30 July 2008
+# Whom: Andriy Pylypenko <bamby@sippysoft.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dal
+PORTVERSION= 20081003
+CATEGORIES= devel python
+MASTER_SITES= http://devel.sippysoft.com:8080/~bamby/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bamby@sippysoft.com
+COMMENT= A database abstraction layer for Python
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/devel/py-dal/distinfo b/devel/py-dal/distinfo
new file mode 100644
index 000000000000..cb2c1ec370d8
--- /dev/null
+++ b/devel/py-dal/distinfo
@@ -0,0 +1,3 @@
+MD5 (dal-20081003.tar.gz) = 18327ceb4ba64c619c2e8ee91833872f
+SHA256 (dal-20081003.tar.gz) = 5ca0153bb98bfed2334ddbffa91c1a1296e6ac00ccb0ac6cb0870aa9a32d3994
+SIZE (dal-20081003.tar.gz) = 24373
diff --git a/devel/py-dal/pkg-descr b/devel/py-dal/pkg-descr
new file mode 100644
index 000000000000..feaf4b07b7bb
--- /dev/null
+++ b/devel/py-dal/pkg-descr
@@ -0,0 +1,9 @@
+PyDal is a database abstraction layer for Python. It provides a DBAPI 2.0
+wrapper for DBAPI 2.0 drivers. Sounds strange, but even drivers that fully
+conform to the DBAPI can differ enough to make building database independent
+applications difficult. Two major abstractions handled by PyDal are
+paramstyles and datetime objects. PyDal makes it possible to use the same
+paramstyle and datetime types with any module that conforms to DBAPI 2.0.
+In addition, paramstyles and datetime types are configurable.
+
+WWW: http://pydal.sourceforge.net/
diff --git a/devel/py-dal/pkg-plist b/devel/py-dal/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/devel/py-dal/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%