aboutsummaryrefslogtreecommitdiff
path: root/devel/py-decoratortools
diff options
context:
space:
mode:
authorDryice Dong Liu <dryice@FreeBSD.org>2008-01-28 09:23:35 +0000
committerDryice Dong Liu <dryice@FreeBSD.org>2008-01-28 09:23:35 +0000
commit08fc9f7784137cec7faaf5fd174e1739fbac2149 (patch)
treef71e5146410ad29ec2007ec062b14c8856e5c3c9 /devel/py-decoratortools
parente9da7bab57627f608dbd0da4dcc920e1b491a525 (diff)
downloadports-08fc9f7784137cec7faaf5fd174e1739fbac2149.tar.gz
ports-08fc9f7784137cec7faaf5fd174e1739fbac2149.zip
Notes
Diffstat (limited to 'devel/py-decoratortools')
-rw-r--r--devel/py-decoratortools/Makefile25
-rw-r--r--devel/py-decoratortools/distinfo3
-rw-r--r--devel/py-decoratortools/pkg-descr10
3 files changed, 38 insertions, 0 deletions
diff --git a/devel/py-decoratortools/Makefile b/devel/py-decoratortools/Makefile
new file mode 100644
index 000000000000..a334a9f4c0a6
--- /dev/null
+++ b/devel/py-decoratortools/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-DecoratorTools
+# Date created: 20-jan-2008
+# Whom: alexander smishlajev
+#
+# $FreeBSD$
+#
+
+PORTNAME= DecoratorTools
+PORTVERSION= 1.7
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/D/DecoratorTools
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Class, function, and metaclass decorators
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= easy_install
+
+USE_ZIP= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/devel/py-decoratortools/distinfo b/devel/py-decoratortools/distinfo
new file mode 100644
index 000000000000..e3528122527c
--- /dev/null
+++ b/devel/py-decoratortools/distinfo
@@ -0,0 +1,3 @@
+MD5 (DecoratorTools-1.7.zip) = 84df0a86aabec6a7d802439ffaa17585
+SHA256 (DecoratorTools-1.7.zip) = 55283e6acc4e5f66cb6e104f98d08f93b1bd29823d17d7e2f852541738a53a11
+SIZE (DecoratorTools-1.7.zip) = 27481
diff --git a/devel/py-decoratortools/pkg-descr b/devel/py-decoratortools/pkg-descr
new file mode 100644
index 000000000000..52c418a42f8d
--- /dev/null
+++ b/devel/py-decoratortools/pkg-descr
@@ -0,0 +1,10 @@
+Want to use decorators, but still need to support Python 2.3?
+Wish you could have class decorators, decorate arbitrary assignments,
+or match decorated function signatures to their original functions?
+Want to get metaclass features without creating metaclasses?
+How about synchronized methods?
+
+"DecoratorTools" gets you all of this and more.
+
+Author: Phillip J. Eby
+WWW: http://cheeseshop.python.org/pypi/DecoratorTools