aboutsummaryrefslogtreecommitdiff
path: root/devel/py-distributed/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-03-01 06:48:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-03-01 06:48:03 +0000
commit5909043ca459d88b452698927bd00d50bd5659af (patch)
tree3b4288d9f42b3e0dc7c19fe9102f0c04e5b74efa /devel/py-distributed/Makefile
parent4425b7bd1a9f6c11e40d91453ddc91aff0c77f2c (diff)
Notes
Diffstat (limited to 'devel/py-distributed/Makefile')
-rw-r--r--devel/py-distributed/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/devel/py-distributed/Makefile b/devel/py-distributed/Makefile
index f2f17d56a485..abf7fe652bde 100644
--- a/devel/py-distributed/Makefile
+++ b/devel/py-distributed/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= distributed
-PORTVERSION= 2.10.0
+PORTVERSION= 2.11.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,13 +16,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=6.6:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cloudpickle>=0.2.2:devel/py-cloudpickle@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dask>=2.9.0:devel/py-dask@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}msgpack>=0:devel/py-msgpack@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}msgpack>=0.6.0:devel/py-msgpack@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}psutil>=5.0:sysutils/py-psutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sortedcontainers>=2.0.2:devel/py-sortedcontainers@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tblib>=0:devel/py-tblib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tblib>=1.6.0:devel/py-tblib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}toolz>=0.7.4:devel/py-toolz@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tornado>=5:www/py-tornado@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zict>=0.1.3:devel/py-zict@${PY_FLAVOR}
USES= python:3.6+
@@ -30,4 +29,12 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=5:www/py-tornado@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado6>=6.0.3:www/py-tornado6@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>