aboutsummaryrefslogtreecommitdiff
path: root/devel/py-extremes
diff options
context:
space:
mode:
authorDryice Dong Liu <dryice@FreeBSD.org>2008-01-28 09:19:17 +0000
committerDryice Dong Liu <dryice@FreeBSD.org>2008-01-28 09:19:17 +0000
commite9da7bab57627f608dbd0da4dcc920e1b491a525 (patch)
treea6b735cd5fc19a7ab91aabc1b08fbcd1f8fae5ca /devel/py-extremes
parent4b0e9129ec6b830c858885b83b0ff16e1aa84036 (diff)
downloadports-e9da7bab57627f608dbd0da4dcc920e1b491a525.tar.gz
ports-e9da7bab57627f608dbd0da4dcc920e1b491a525.zip
Notes
Diffstat (limited to 'devel/py-extremes')
-rw-r--r--devel/py-extremes/Makefile25
-rw-r--r--devel/py-extremes/distinfo3
-rw-r--r--devel/py-extremes/files/patch-setup.py11
-rw-r--r--devel/py-extremes/pkg-descr5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/py-extremes/Makefile b/devel/py-extremes/Makefile
new file mode 100644
index 000000000000..b0af4fccb030
--- /dev/null
+++ b/devel/py-extremes/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-Extremes
+# Date created: 22-jan-2008
+# Whom: alexander smishlajev
+#
+# $FreeBSD$
+#
+
+PORTNAME= Extremes
+PORTVERSION= 1.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/E/Extremes
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Production-quality 'Min' and 'Max' objects (adapted from PEP 326)
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= easy_install
+
+USE_ZIP= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/devel/py-extremes/distinfo b/devel/py-extremes/distinfo
new file mode 100644
index 000000000000..883b5eadb109
--- /dev/null
+++ b/devel/py-extremes/distinfo
@@ -0,0 +1,3 @@
+MD5 (Extremes-1.1.zip) = 34fc2c114b09e2cc331482d6cc4e4399
+SHA256 (Extremes-1.1.zip) = 5fb1b1b237cb166ea29419a148ce7ab70e604dfe8c78fbec9899439c75be996f
+SIZE (Extremes-1.1.zip) = 6134
diff --git a/devel/py-extremes/files/patch-setup.py b/devel/py-extremes/files/patch-setup.py
new file mode 100644
index 000000000000..3b52e1471503
--- /dev/null
+++ b/devel/py-extremes/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Wed Nov 21 14:25:46 2007
++++ setup.py Tue Jan 22 11:28:34 2008
+@@ -1,8 +1,6 @@
+ #!/usr/bin/env python
+ """Distutils setup file"""
+
+-import ez_setup
+-ez_setup.use_setuptools()
+ from setuptools import setup
+
+ # Metadata
diff --git a/devel/py-extremes/pkg-descr b/devel/py-extremes/pkg-descr
new file mode 100644
index 000000000000..e559c82a2fb6
--- /dev/null
+++ b/devel/py-extremes/pkg-descr
@@ -0,0 +1,5 @@
+The peak.util.extremes module provides a production-quality implementation
+of the Min and Max objects from PEP 326.
+
+Author: Phillip J. Eby
+WWW: http://pypi.python.org/pypi/Extremes/