aboutsummaryrefslogtreecommitdiff
path: root/devel/py-game/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-12-18 17:02:09 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-12-18 17:02:09 +0000
commitcf8f9e48af5d876fe19f45ae0646e846a5d6f023 (patch)
tree9313b0c853b8a10607143a9c68ac70641e32e301 /devel/py-game/Makefile
parenta2957738903966e767dc87ed076e051509d07145 (diff)
downloadports-cf8f9e48af5d876fe19f45ae0646e846a5d6f023.tar.gz
ports-cf8f9e48af5d876fe19f45ae0646e846a5d6f023.zip
Notes
Diffstat (limited to 'devel/py-game/Makefile')
-rw-r--r--devel/py-game/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
new file mode 100644
index 000000000000..45e2c8cd7e74
--- /dev/null
+++ b/devel/py-game/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-game
+# Date created: 14 December 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= py-game
+PORTVERSION= 0.4
+CATEGORIES= devel python
+MASTER_SITES= http://pygame.seul.org/ftp/
+DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+LIB_DEPENDS= SDL_ttf.2:${PORTSDIR}/graphics/sdl_ttf \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ smpeg.1:${PORTSDIR}/graphics/smpeg
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD}
+MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+do-configure:
+ ${SETUP_CMD} config.py
+
+do-build:
+ ${SETUP_CMD} setup.py build
+
+do-install:
+ ${SETUP_CMD} setup.py install
+
+.include <bsd.port.mk>