aboutsummaryrefslogtreecommitdiff
path: root/devel/py-game
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:12:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:12:58 +0000
commit5faefa6350cd172add279e339bd86a650313beb3 (patch)
tree67630f04aea3b9bda5b75203dcc28ce176a630d4 /devel/py-game
parent1e2b30a0544e506996a9bcca922a97277d3e9746 (diff)
- Fix permissions of the installed files so they are readable to non-root users
PR: ports/130169 Reported by: Rainer Hurling <rhurlin@gwdg.de> Approved by: Marcus von Appen <mva@sysfault.org> (maintainer)
Notes
Notes: svn path=/head/; revision=225287
Diffstat (limited to 'devel/py-game')
-rw-r--r--devel/py-game/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index 4c4ea814a84b..9f1446df3ef2 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -7,6 +7,7 @@
PORTNAME= game
PORTVERSION= 1.8.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://pygame.seul.org/ftp/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -29,6 +30,10 @@ SDLNOX11= sdl-nox11-[0-9]*
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+post-patch:
+ @${FIND} ${WRKSRC} -type d | xargs ${CHMOD} a+rx
+ @${FIND} ${WRKSRC} -type f | xargs ${CHMOD} a+r
+
pre-configure:
@invalid=`${PKG_INFO} -I ${SDLNOX11:C/.+/'&'/} 2>/dev/null | ${AWK} '{print $$1}`
@if [ ! -z "$$invalid" ]; then \