aboutsummaryrefslogtreecommitdiff
path: root/devel/py-game
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-09-20 11:21:59 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-09-20 11:21:59 +0000
commit0d2725682b8325a08b11592d11062997bb9dc7f2 (patch)
tree46ab0c86563bfc2fbab1ecc5f9dadffb47afe737 /devel/py-game
parent750f1f56ed3264341b911b1182fc2f3f4dd609c2 (diff)
downloadports-0d2725682b8325a08b11592d11062997bb9dc7f2.tar.gz
ports-0d2725682b8325a08b11592d11062997bb9dc7f2.zip
Notes
Diffstat (limited to 'devel/py-game')
-rw-r--r--devel/py-game/Makefile1
-rw-r--r--devel/py-game/files/patch-config_unix.py27
2 files changed, 1 insertions, 27 deletions
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index 444b655c80e3..811a2191de93 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -7,6 +7,7 @@
PORTNAME= game
PORTVERSION= 1.7.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://pygame.seul.org/ftp/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-game/files/patch-config_unix.py b/devel/py-game/files/patch-config_unix.py
index fb467e28e6d8..2bf13082c5fd 100644
--- a/devel/py-game/files/patch-config_unix.py
+++ b/devel/py-game/files/patch-config_unix.py
@@ -1,14 +1,5 @@
--- config_unix.py.orig Wed Aug 10 04:45:11 2005
+++ config_unix.py Wed Sep 14 09:12:44 2005
-@@ -4,7 +4,7 @@
- from glob import glob
- from distutils.sysconfig import get_python_inc
-
--configcommand = os.environ.get('SDL_CONFIG', 'sdl-config',)
-+configcommand = os.environ.get('SDL_CONFIG', 'sdl11-config',)
- configcommand = configcommand + ' --version --cflags --libs'
- localbase = os.environ.get('LOCALBASE', '')
-
@@ -52,6 +52,9 @@
self.cflags += f + ' '
elif f[:3] == '-Wl':
@@ -19,21 +10,3 @@
except:
print 'WARNING: "%s" failed!' % command
self.found = 0
-@@ -137,7 +140,7 @@
- def main():
- print '\nHunting dependencies...'
- DEPS = [
-- DependencyProg('SDL', 'SDL_CONFIG', 'sdl-config', '1.2', 'sdl'),
-+ DependencyProg('SDL', 'SDL_CONFIG', 'sdl11-config', '1.2', 'sdl'),
- Dependency('FONT', 'SDL_ttf.h', 'libSDL_ttf.so', 'SDL_ttf'),
- Dependency('IMAGE', 'SDL_image.h', 'libSDL_image.so', 'SDL_image'),
- Dependency('MIXER', 'SDL_mixer.h', 'libSDL_mixer.so', 'SDL_mixer'),
-@@ -146,7 +149,7 @@
- ]
-
- if not DEPS[0].found:
-- print 'Unable to run "sdl-config". Please make sure a development version of SDL is installed.'
-+ print 'Unable to run "sdl11-config". Please make sure a development version of SDL is installed.'
- raise SystemExit
-
- if localbase: