aboutsummaryrefslogtreecommitdiff
path: root/devel/py-game
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-28 10:35:21 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-28 10:35:21 +0000
commitf1a239553c99a91143bb899a0f983a1398727e68 (patch)
tree1273fe7f8c36aa8def7e8b2f659e9ee677f12602 /devel/py-game
parentd5a64b9ac3ef33ee942842daceba0d00e34bfcfd (diff)
downloadports-f1a239553c99a91143bb899a0f983a1398727e68.tar.gz
ports-f1a239553c99a91143bb899a0f983a1398727e68.zip
Notes
Diffstat (limited to 'devel/py-game')
-rw-r--r--devel/py-game/Makefile2
-rw-r--r--devel/py-game/distinfo2
-rw-r--r--devel/py-game/files/patch-config_unix.py18
-rw-r--r--devel/py-game/files/patch-src::mixer.c23
-rw-r--r--devel/py-game/files/patch-src::music.c23
-rw-r--r--devel/py-game/pkg-plist3
6 files changed, 14 insertions, 57 deletions
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index 86de92643043..88ef2263f923 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= py-game
-PORTVERSION= 1.4
+PORTVERSION= 1.4.9
CATEGORIES= devel python
MASTER_SITES= http://pygame.seul.org/ftp/
DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
diff --git a/devel/py-game/distinfo b/devel/py-game/distinfo
index 09baee9ee2ae..c12debaf48c4 100644
--- a/devel/py-game/distinfo
+++ b/devel/py-game/distinfo
@@ -1 +1 @@
-MD5 (pygame-1.4.tar.gz) = f418f24ba425fc92306a4f8c6904b430
+MD5 (pygame-1.4.9.tar.gz) = e3d8dd07a25f3d94a61d3f7627c38241
diff --git a/devel/py-game/files/patch-config_unix.py b/devel/py-game/files/patch-config_unix.py
index 79f55695b0a4..47cb93978ceb 100644
--- a/devel/py-game/files/patch-config_unix.py
+++ b/devel/py-game/files/patch-config_unix.py
@@ -1,22 +1,24 @@
$FreeBSD$
---- config_unix.py.orig Sat Nov 3 19:27:56 2001
-+++ config_unix.py Wed Dec 19 14:49:24 2001
-@@ -43,7 +43,7 @@
+--- config_unix.py.orig Sat Mar 23 10:23:12 2002
++++ config_unix.py Tue May 28 12:58:39 2002
+@@ -113,7 +113,7 @@
sdl_lib_name = 'SDL'
if sys.platform.find('bsd') != -1:
- sdl_lib_name = 'SDL-1.2'
+ sdl_lib_name = 'SDL-1.1'
- DEPS = [
- Dependency('SDL', 'SDL.h', 'lib'+sdl_lib_name+'.so', sdl_lib_name),
-@@ -74,7 +74,7 @@
- print 'Hunting dependencies...'
- if localbase:
+ def main():
+@@ -132,8 +132,8 @@
+ raise SystemExit
+
+
+- if localbase: #unneeded?
- incdirs = [localbase + '/include/SDL']
++ if localbase: #unneeded? nah, needed on FreeBSD!
+ incdirs = [localbase + '/include/SDL11', localbase + '/include/smpeg']
libdirs = [localbase + '/lib']
else:
diff --git a/devel/py-game/files/patch-src::mixer.c b/devel/py-game/files/patch-src::mixer.c
deleted file mode 100644
index 6e3eb3305cad..000000000000
--- a/devel/py-game/files/patch-src::mixer.c
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- src/mixer.c 2002/05/09 21:53:08 1.1
-+++ src/mixer.c 2002/05/09 21:55:19
-@@ -926,7 +926,7 @@
- /*DOC*/ "Temporarily stops playback on all the mixer channels.\n"
- /*DOC*/ ;
-
--static PyObject* pause(PyObject* self, PyObject* args)
-+static PyObject* all_pause(PyObject* self, PyObject* args)
- {
- if(!PyArg_ParseTuple(args, ""))
- return NULL;
-@@ -1029,7 +1029,7 @@
- { "find_channel", find_channel, 1, doc_find_channel },
- { "fadeout", fadeout, 1, doc_fadeout },
- { "stop", stop, 1, doc_stop },
-- { "pause", pause, 1, doc_pause },
-+ { "pause", all_pause, 1, doc_pause },
- { "unpause", unpause, 1, doc_unpause },
- /* { "lookup_frequency", lookup_frequency, 1, doc_lookup_frequency },*/
-
diff --git a/devel/py-game/files/patch-src::music.c b/devel/py-game/files/patch-src::music.c
deleted file mode 100644
index a4ff93a13d12..000000000000
--- a/devel/py-game/files/patch-src::music.c
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- src/music.c 2002/05/09 21:56:01 1.1
-+++ src/music.c 2002/05/09 21:56:51
-@@ -148,7 +148,7 @@
- /*DOC*/ "Temporarily stops the current music.\n"
- /*DOC*/ ;
-
--static PyObject* pause(PyObject* self, PyObject* args)
-+static PyObject* music_pause(PyObject* self, PyObject* args)
- {
- if(!PyArg_ParseTuple(args, ""))
- return NULL;
-@@ -365,7 +365,7 @@
- { "get_busy", get_busy, 1, doc_get_busy },
- { "fadeout", fadeout, 1, doc_fadeout },
- { "stop", stop, 1, doc_stop },
-- { "pause", pause, 1, doc_pause },
-+ { "pause", music_pause, 1, doc_pause },
- { "unpause", unpause, 1, doc_unpause },
- { "rewind", mus_rewind, 1, doc_rewind },
- { "set_volume", set_volume, 1, doc_set_volume },
diff --git a/devel/py-game/pkg-plist b/devel/py-game/pkg-plist
index 0ad9489210c9..6f9427abaa56 100644
--- a/devel/py-game/pkg-plist
+++ b/devel/py-game/pkg-plist
@@ -35,6 +35,7 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/pygame_icon.icns
lib/%%PYTHON_VERSION%%/site-packages/pygame/pygame_icon.tiff
lib/%%PYTHON_VERSION%%/site-packages/pygame/rect.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/rwobject.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/sndarray.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/sprite.py
lib/%%PYTHON_VERSION%%/site-packages/pygame/sprite.pyc
lib/%%PYTHON_VERSION%%/site-packages/pygame/sprite.pyo
@@ -77,11 +78,11 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/version.pyo
%%PORTDOCS%%share/doc/py-game/ref/pygame_mixer_music.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_mouse.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_movie.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_sndarray.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_sprite.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_surfarray.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_time.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_transform.html
-%%PORTDOCS%%share/doc/py-game/ref/pygame_version.html
%%PORTDOCS%%share/doc/py-game/tut/ChimpLineByLine.html
%%PORTDOCS%%share/doc/py-game/tut/DisplayModes.html
%%PORTDOCS%%share/doc/py-game/tut/Executable.html