aboutsummaryrefslogtreecommitdiff
path: root/devel/py-gamin
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-04-02 09:10:35 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-04-02 09:10:35 +0000
commitc16bb210e83eb0cf77ad32cc1e20d068efab1ec7 (patch)
treec5ff7d496e1f739e1116f491b660586ff23f44e0 /devel/py-gamin
parent968aed520658a9eb2cccce2cb40a796c57a6ef6c (diff)
downloadports-c16bb210e83eb0cf77ad32cc1e20d068efab1ec7.tar.gz
ports-c16bb210e83eb0cf77ad32cc1e20d068efab1ec7.zip
Notes
Diffstat (limited to 'devel/py-gamin')
-rw-r--r--devel/py-gamin/Makefile34
-rw-r--r--devel/py-gamin/pkg-descr3
-rw-r--r--devel/py-gamin/pkg-plist4
3 files changed, 41 insertions, 0 deletions
diff --git a/devel/py-gamin/Makefile b/devel/py-gamin/Makefile
new file mode 100644
index 000000000000..e4ffc770554a
--- /dev/null
+++ b/devel/py-gamin/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-gamin
+# Date Created: 24 March 2005
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface to the Gamin file monitoring system
+
+LIB_DEPENDS= gamin-1.0:${PORTSDIR}/devel/gamin
+
+MASTERDIR= ${.CURDIR}/../gamin
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+GAMIN_SLAVE= yes
+
+USE_GNOME= gnomehack gnometarget
+USE_PYTHON= yes
+CONFIGURE_ARGS= --with-python=${LOCALBASE} \
+ --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-gamin/pkg-descr b/devel/py-gamin/pkg-descr
new file mode 100644
index 000000000000..e99ea2fd1ff0
--- /dev/null
+++ b/devel/py-gamin/pkg-descr
@@ -0,0 +1,3 @@
+Python interface to the Gaim file and directory monitoring system.
+
+WWW: http://www.gnome.org/~veillard/gamin/python.html
diff --git a/devel/py-gamin/pkg-plist b/devel/py-gamin/pkg-plist
new file mode 100644
index 000000000000..e46d4da5621b
--- /dev/null
+++ b/devel/py-gamin/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%PYTHON_VERSION%%/site-packages/gamin.py
+lib/%%PYTHON_VERSION%%/site-packages/gamin.pyc
+lib/%%PYTHON_VERSION%%/site-packages/gamin.pyo
+lib/%%PYTHON_VERSION%%/site-packages/_gamin.so