aboutsummaryrefslogtreecommitdiff
path: root/devel/py-gdata/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-28 07:45:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-28 07:45:20 +0000
commit230be3b3af50fb3a962983822fdc0247122975d9 (patch)
tree05312a8612588f2dba83a991be19cf94513ab2a2 /devel/py-gdata/Makefile
parent831a63b73c0e57eb3a88ad9cfa1b7265ef82e91b (diff)
downloadports-230be3b3af50fb3a962983822fdc0247122975d9.tar.gz
ports-230be3b3af50fb3a962983822fdc0247122975d9.zip
Notes
Diffstat (limited to 'devel/py-gdata/Makefile')
-rw-r--r--devel/py-gdata/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/py-gdata/Makefile b/devel/py-gdata/Makefile
new file mode 100644
index 000000000000..284c66b604b1
--- /dev/null
+++ b/devel/py-gdata/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-gdata
+# Date created: Mar. 28, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdata
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= http://gdata-python-client.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= gdata.py.${PORTVERSION}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= GData Python Client Library
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/gdata-python-client
+
+EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+
+do-patch:
+ ${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|g' ${FILESDIR}/setup.py \
+ > ${WRKSRC}/setup.py
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/samples/ ${EXAMPLESDIR}
+
+.include <bsd.port.mk>