aboutsummaryrefslogtreecommitdiff
path: root/devel/py-gflags
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-01-11 16:15:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-01-11 16:15:47 +0000
commit2554fb4ec6e8cf7ffe4aac80d9258307e6638305 (patch)
treee0596eaf7b9db2c9a41d928bd061a8af596ab8bf /devel/py-gflags
parentbad9f1bcb29bdad81f318250e32e41c1d6ea4dc8 (diff)
Notes
Diffstat (limited to 'devel/py-gflags')
-rw-r--r--devel/py-gflags/Makefile28
-rw-r--r--devel/py-gflags/distinfo2
-rw-r--r--devel/py-gflags/pkg-descr7
-rw-r--r--devel/py-gflags/pkg-plist2
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/py-gflags/Makefile b/devel/py-gflags/Makefile
new file mode 100644
index 000000000000..1f970d969415
--- /dev/null
+++ b/devel/py-gflags/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-gflags
+# Date created: 2011-01-10
+# Whom: Julien Laffaye <kimelto@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gflags
+PORTVERSION= 1.4
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-gflags-${PORTVERSION}
+
+MAINTAINER= kimelto@gmail.com
+COMMENT= Commandline flags module for Python
+
+PROJECTHOST= python-gflags
+LICENSE= BSD
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= python_gflags
+
+post-install:
+ ${TOUCH} ${PYEASYINSTALL_SITELIBDIR}/gflags
+
+.include <bsd.port.mk>
diff --git a/devel/py-gflags/distinfo b/devel/py-gflags/distinfo
new file mode 100644
index 000000000000..80e43e9f43da
--- /dev/null
+++ b/devel/py-gflags/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-gflags-1.4.tar.gz) = 55f6a7f1bde4df987e2253111058ec8e73c791c1588cc95da5bd0379f1745d19
+SIZE (python-gflags-1.4.tar.gz) = 53836
diff --git a/devel/py-gflags/pkg-descr b/devel/py-gflags/pkg-descr
new file mode 100644
index 000000000000..5625ab65fa98
--- /dev/null
+++ b/devel/py-gflags/pkg-descr
@@ -0,0 +1,7 @@
+The gflags package contains a library that implements commandline flags
+processing. As such it's a replacement for getopt(). It has increased
+flexibility, including built-in support for Python types, and the ability to
+define flags in the source file in which they're used. (This last is its major
+difference from OptParse.)
+
+WWW: http://code.google.com/p/python-gflags/
diff --git a/devel/py-gflags/pkg-plist b/devel/py-gflags/pkg-plist
new file mode 100644
index 000000000000..8c8f32064f24
--- /dev/null
+++ b/devel/py-gflags/pkg-plist
@@ -0,0 +1,2 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PYTHON_SITELIBDIR%%/gflags