aboutsummaryrefslogtreecommitdiff
path: root/devel/py-hypothesis/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:46:37 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:46:37 +0000
commit5de147f82f4dbef0d7ffeda7337760d8ae5825db (patch)
tree75deaeb438c4661e05c68ee7c0ba8d757f7308f5 /devel/py-hypothesis/Makefile
parent86ce13e106e71e7db42bdecdfbc75d5a1312b126 (diff)
Notes
Diffstat (limited to 'devel/py-hypothesis/Makefile')
-rw-r--r--devel/py-hypothesis/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/py-hypothesis/Makefile b/devel/py-hypothesis/Makefile
new file mode 100644
index 000000000000..f2596130826d
--- /dev/null
+++ b/devel/py-hypothesis/Makefile
@@ -0,0 +1,25 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= hypothesis
+PORTVERSION= 1.18.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Library for property based testing
+
+LICENSE= MPL
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
+
+.include <bsd.port.mk>