aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ice/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-14 22:28:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-14 22:28:54 +0000
commitf0000681746c861b50020b459d0d0d2cfcf0be8a (patch)
treedd2fbbcf910a8c52a3002fd51e90860107f237a9 /devel/py-ice/Makefile
parent2e6153f64fc8c34f093fe8996451422c88ec97bc (diff)
downloadports-f0000681746c861b50020b459d0d0d2cfcf0be8a.tar.gz
ports-f0000681746c861b50020b459d0d0d2cfcf0be8a.zip
Notes
Diffstat (limited to 'devel/py-ice/Makefile')
-rw-r--r--devel/py-ice/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/devel/py-ice/Makefile b/devel/py-ice/Makefile
index bea9ccc6a936..1b29bae7ac8f 100644
--- a/devel/py-ice/Makefile
+++ b/devel/py-ice/Makefile
@@ -6,21 +6,25 @@
#
PORTNAME= Ice
-PORTVERSION= 3.2.1
+PORTVERSION= 3.3.0
CATEGORIES= devel python
-MASTER_SITES= http://www.zeroc.com/download/Ice/3.2/
+MASTER_SITES= http://www.zeroc.com/download/Ice/3.3/ \
+ http://www.dirk.sh/dirk/Ice/
PKGNAMEPREFIX= py-
-DISTNAME= IcePy-${PORTVERSION}
+DISTNAME= Ice-${PORTVERSION}
MAINTAINER= dirk.ye@gmail.com
COMMENT= An Ice (Internet Communications Engine) language mapping for Python
+BUILD_DEPENDS= mcpp:${PORTSDIR}/devel/mcpp
LIB_DEPENDS= Ice.${LIB_VRS}:${PORTSDIR}/devel/ice
USE_GMAKE= yes
USE_PYTHON= yes
+BUILD_WRKSRC= ${WRKSRC}/py
+INSTALL_WRKSRC= ${WRKSRC}/py
-LIB_VRS= ${PORTVERSION:S|.||g:C|1$||}
+LIB_VRS= ${PORTVERSION:S|.||g:C|0$||}
PLIST_SUB= LIB_VERSION="${PORTVERSION}" LIB_VRS="${LIB_VRS}"
CFLAGS+= -ftemplate-depth-128 -fPIC -DPIC -Wall -D_REENTRANT ${PTHREAD_CFLAGS}
@@ -31,21 +35,24 @@ CFLAGS+= -DNDEBUG
.endif
.include <bsd.port.pre.mk>
-
.if ${ARCH} == "ia64"
-BROKEN= does not compile
+BROKEN= does not compile on ia64
.endif
.if ((${ARCH} != i386) && (${ARCH} != powerpc))
MAKE_ENV= LP64=yes
.endif
+.if defined(NOPORTDOCS)
+MAKE_ENV+= NOPORTDOCS=yes
+.endif
+
post-patch:
${REINPLACE_CMD} 's|%%INSTALL_PROGRAM%%|${INSTALL_PROGRAM}|g; \
s|%%INSTALL_DATA%%|${INSTALL_DATA}|g; \
s|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g; \
s|%%PREFIX%%|${PREFIX}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/config/Make.rules
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/py/config/Make.rules
post-install:
${ECHO} "Ice" > ${PYTHON_SITELIBDIR}/Ice.pth