aboutsummaryrefslogtreecommitdiff
path: root/devel/py-icu
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2008-09-26 06:05:06 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2008-09-26 06:05:06 +0000
commit0ccc20cb585c0163ae10c865fe56cd38341f43c9 (patch)
tree9546fea6a3228a11cde85cc3f2cb8631f489c2e6 /devel/py-icu
parent068a8081c55f626678f48dcb719d72bf77530d0b (diff)
downloadports-0ccc20cb585c0163ae10c865fe56cd38341f43c9.tar.gz
ports-0ccc20cb585c0163ae10c865fe56cd38341f43c9.zip
Notes
Diffstat (limited to 'devel/py-icu')
-rw-r--r--devel/py-icu/Makefile32
-rw-r--r--devel/py-icu/distinfo3
-rw-r--r--devel/py-icu/pkg-descr4
-rw-r--r--devel/py-icu/pkg-plist1
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/py-icu/Makefile b/devel/py-icu/Makefile
new file mode 100644
index 000000000000..3148598b22c0
--- /dev/null
+++ b/devel/py-icu/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-icu
+# Date created: 26 Sep 2008
+# Whom: bland@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= icu
+PORTVERSION= 0.8.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/P/PyICU
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyICU-${PORTVERSION}
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= Python extension wrapping IBM's ICU C++ API
+
+LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= PyICU
+PYEASYINSTALL_ARCHDEP= yes
+
+MAKE_ENV+= \
+ PYICU_INCLUDES="${PREFIX}/include" \
+ PYICU_CFLAGS="-w" \
+ PYICU_LFLAGS="-L${PREFIX}/lib" \
+ PYICU_LIBRARIES="icui18n:icuuc:icudata"
+
+.include <bsd.port.mk>
diff --git a/devel/py-icu/distinfo b/devel/py-icu/distinfo
new file mode 100644
index 000000000000..0a7cb8fe063d
--- /dev/null
+++ b/devel/py-icu/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyICU-0.8.1.tar.gz) = 789092993f84ccd6ba21d7346d6e093d
+SHA256 (PyICU-0.8.1.tar.gz) = 8edf1901e998d198d861b95a8ba9d12d7d9d2ca82c82984f6c94b1b009c48008
+SIZE (PyICU-0.8.1.tar.gz) = 66819
diff --git a/devel/py-icu/pkg-descr b/devel/py-icu/pkg-descr
new file mode 100644
index 000000000000..8151156e5730
--- /dev/null
+++ b/devel/py-icu/pkg-descr
@@ -0,0 +1,4 @@
+PyICU is a python extension wrapping IBM's ICU C++ API.
+PyICU is supported on Mac OS X, Linux (32- and 64-bit) and Windows.
+
+WWW: http://pyicu.osafoundation.org/
diff --git a/devel/py-icu/pkg-plist b/devel/py-icu/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/devel/py-icu/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%