aboutsummaryrefslogtreecommitdiff
path: root/devel/py-instant/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-05 19:35:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-05 19:35:11 +0000
commit9e61e1314a7c6090bb696521becde3432f4bef97 (patch)
tree75444be6fbf8f7d32e2c3726b89182d46f9dd9e9 /devel/py-instant/Makefile
parent224101216c5876ca8e254a5a82f24c95ca279b01 (diff)
downloadports-9e61e1314a7c6090bb696521becde3432f4bef97.tar.gz
ports-9e61e1314a7c6090bb696521becde3432f4bef97.zip
Notes
Diffstat (limited to 'devel/py-instant/Makefile')
-rw-r--r--devel/py-instant/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/py-instant/Makefile b/devel/py-instant/Makefile
new file mode 100644
index 000000000000..ea82f4c111cc
--- /dev/null
+++ b/devel/py-instant/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-instant
+# Date created: Jan. 04, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= instant
+PORTVERSION= 0.9
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyinstant
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Instant-${PORTVERSION}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Python module for instant inlining of C and C++ code in Python
+
+RUN_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/Instant.py \
+ %%PYTHON_SITELIBDIR%%/Instant.pyc \
+ %%PYTHON_SITELIBDIR%%/Instant.pyo
+
+.include <bsd.port.mk>