aboutsummaryrefslogtreecommitdiff
path: root/devel/py-jsonschema3/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:23:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:41:21 +0000
commit83d7ba7947f30ddf8620423173545759777f97b6 (patch)
treeaacb29b4f44e1cbc69881823bd930f3ba4111d9d /devel/py-jsonschema3/Makefile
parent05cede0a892bfe22adb4a92adaf8b5535a67cdc2 (diff)
downloadports-83d7ba7947f30ddf8620423173545759777f97b6.tar.gz
ports-83d7ba7947f30ddf8620423173545759777f97b6.zip
Diffstat (limited to 'devel/py-jsonschema3/Makefile')
-rw-r--r--devel/py-jsonschema3/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/py-jsonschema3/Makefile b/devel/py-jsonschema3/Makefile
new file mode 100644
index 000000000000..8d92df1d7772
--- /dev/null
+++ b/devel/py-jsonschema3/Makefile
@@ -0,0 +1,34 @@
+# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
+
+PORTNAME= jsonschema
+PORTVERSION= 3.2.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 3
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= JSON Schema validation for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=17.4.0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyrsistent>=0.14.0:devel/py-pyrsistent@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^3\.
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>