aboutsummaryrefslogtreecommitdiff
path: root/devel/py-kqueue/Makefile
diff options
context:
space:
mode:
authorDoug White <dwhite@FreeBSD.org>2000-05-24 04:34:16 +0000
committerDoug White <dwhite@FreeBSD.org>2000-05-24 04:34:16 +0000
commitc970b381edbfc9ea49cf6ef4d65725d40d85cc01 (patch)
treefea04fb667159b485986215612c93c1c0a998f40 /devel/py-kqueue/Makefile
parent7f8cdb6f0056fedb27bdd67aa374a8f938f79f36 (diff)
downloadports-c970b381edbfc9ea49cf6ef4d65725d40d85cc01.tar.gz
ports-c970b381edbfc9ea49cf6ef4d65725d40d85cc01.zip
Notes
Diffstat (limited to 'devel/py-kqueue/Makefile')
-rw-r--r--devel/py-kqueue/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/py-kqueue/Makefile b/devel/py-kqueue/Makefile
new file mode 100644
index 000000000000..b28b668983cb
--- /dev/null
+++ b/devel/py-kqueue/Makefile
@@ -0,0 +1,37 @@
+# Ports collection Makefile for: PyKQueue
+# Date created: 05/23/2000
+# Whom: dwhite@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= kqueue
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= http://people.freebsd.org/~dwhite/PyKQueue/
+PKGNAMEPREFIX= py-
+DISTNAME= PyKQueue-${PORTVERSION}
+
+MAINTAINER= dwhite@FreeBSD.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+# NO_WRKSUBDIR= yes
+# MAKEFILE= makefile
+
+do-configure:
+ @(cd ${WRKSRC} && \
+ make -f Makefile.pre.in boot)
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/python1.5/site-packages
+ ${INSTALL_DATA} ${WRKSRC}/kqsyscallmodule.so \
+ ${PREFIX}/lib/python1.5/site-packages/
+ ${INSTALL_DATA} ${WRKSRC}/KQueue.py \
+ ${PREFIX}/lib/python1.5/site-packages/
+# .if !defined(NOPORTDOCS)
+# ${INSTALL_DATA} ${WRKSRC}/kjbuckets.html ${PREFIX}/share/doc/
+# .endif
+
+.include <bsd.port.mk>