aboutsummaryrefslogtreecommitdiff
path: root/devel/py-mx-experimental/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-03 17:25:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-03 17:25:21 +0000
commit10011c8137da283da34b0a43f7a26e54adc47980 (patch)
tree3460330519c8ae71f0f2d4866c6a10326671d713 /devel/py-mx-experimental/Makefile
parentb5b94c15041238fd656d97f51c56359387571272 (diff)
downloadports-10011c8137da283da34b0a43f7a26e54adc47980.tar.gz
ports-10011c8137da283da34b0a43f7a26e54adc47980.zip
Notes
Diffstat (limited to 'devel/py-mx-experimental/Makefile')
-rw-r--r--devel/py-mx-experimental/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/py-mx-experimental/Makefile b/devel/py-mx-experimental/Makefile
new file mode 100644
index 000000000000..9d11f9f7c7c4
--- /dev/null
+++ b/devel/py-mx-experimental/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: py-mx-experimental
+# Date created: Nov 3, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mx-experimental
+PORTVERSION= 0.6.0
+CATEGORIES= devel python
+MASTER_SITES= http://www.lemburg.com/files/python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= egenix-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/BeeBase/BeeBase.py:${PORTSDIR}/lang/py-mx-base
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>