aboutsummaryrefslogtreecommitdiff
path: root/devel/py-notify
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-12-12 19:38:47 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-12-12 19:38:47 +0000
commit759132bafc98c16173af1fde8cb547fc9675a74c (patch)
tree8090192b644c6c01369450dc8ca5282eaa08510e /devel/py-notify
parent1c2dc1743a7de7268cdfb3733509c181f224f266 (diff)
downloadports-759132bafc98c16173af1fde8cb547fc9675a74c.tar.gz
ports-759132bafc98c16173af1fde8cb547fc9675a74c.zip
Notes
Diffstat (limited to 'devel/py-notify')
-rw-r--r--devel/py-notify/Makefile37
-rw-r--r--devel/py-notify/distinfo3
-rw-r--r--devel/py-notify/pkg-descr3
-rw-r--r--devel/py-notify/pkg-plist13
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/py-notify/Makefile b/devel/py-notify/Makefile
new file mode 100644
index 000000000000..f8fd16730e4d
--- /dev/null
+++ b/devel/py-notify/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-notify
+# Date created: 03 December 2006
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= notify
+PORTVERSION= 0.1.1
+DISTVERSIONPREFIX=python-
+CATEGORIES= devel python
+MASTER_SITES= http://www.galago-project.org/files/releases/source/notify-python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A python bindings for libnotify
+
+LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+
+USE_XLIB= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget pygtk2
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+
+DOCS= AUTHORS COPYING ChangeLog NEWS
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-notify/distinfo b/devel/py-notify/distinfo
new file mode 100644
index 000000000000..047989c8cdf7
--- /dev/null
+++ b/devel/py-notify/distinfo
@@ -0,0 +1,3 @@
+MD5 (notify-python-0.1.1.tar.bz2) = d247cf79b46cef7495deb0a76334f81d
+SHA256 (notify-python-0.1.1.tar.bz2) = 7d3bbb7c3d8f56c922cc31d02ef9057a4f06998cc2fd4f3119a576fcf8d504ce
+SIZE (notify-python-0.1.1.tar.bz2) = 214514
diff --git a/devel/py-notify/pkg-descr b/devel/py-notify/pkg-descr
new file mode 100644
index 000000000000..80df410aa3c2
--- /dev/null
+++ b/devel/py-notify/pkg-descr
@@ -0,0 +1,3 @@
+A python bindings for libnotify.
+
+WWW: http://www.galago-project.org/
diff --git a/devel/py-notify/pkg-plist b/devel/py-notify/pkg-plist
new file mode 100644
index 000000000000..d0a3d024018d
--- /dev/null
+++ b/devel/py-notify/pkg-plist
@@ -0,0 +1,13 @@
+%%PYTHON_SITELIBDIR%%/gtk-2.0/pynotify/__init__.py
+%%PYTHON_SITELIBDIR%%/gtk-2.0/pynotify/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gtk-2.0/pynotify/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gtk-2.0/pynotify/_pynotify.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/pynotify/_pynotify.so
+libdata/pkgconfig/notify-python.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+share/pygtk/2.0/defs/pynotify.defs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/pynotify