aboutsummaryrefslogtreecommitdiff
path: root/devel/py-omniorb
diff options
context:
space:
mode:
authorAlexander Kabaev <kan@FreeBSD.org>2002-11-28 03:20:05 +0000
committerAlexander Kabaev <kan@FreeBSD.org>2002-11-28 03:20:05 +0000
commitc8c2e3a281179c65c2ffca91814e06fa18ce40f3 (patch)
tree58f4260714d025121d983320ef99b05d7927d1e5 /devel/py-omniorb
parentfb99651fb8b8d2d81cd83e1f234caca554155681 (diff)
downloadports-c8c2e3a281179c65c2ffca91814e06fa18ce40f3.tar.gz
ports-c8c2e3a281179c65c2ffca91814e06fa18ce40f3.zip
Notes
Diffstat (limited to 'devel/py-omniorb')
-rw-r--r--devel/py-omniorb/Makefile61
-rw-r--r--devel/py-omniorb/distinfo2
-rw-r--r--devel/py-omniorb/pkg-comment2
-rw-r--r--devel/py-omniorb/pkg-descr33
-rw-r--r--devel/py-omniorb/pkg-plist42
5 files changed, 89 insertions, 51 deletions
diff --git a/devel/py-omniorb/Makefile b/devel/py-omniorb/Makefile
index cf3c882206cc..01a2fad90ea7 100644
--- a/devel/py-omniorb/Makefile
+++ b/devel/py-omniorb/Makefile
@@ -6,61 +6,56 @@
#
PORTNAME= omniorb
-PORTVERSION= 1.5
+PORTVERSION= 2.0
CATEGORIES= devel python
-MASTER_SITES= http://belnet.dl.sourceforge.net/sourceforge/omniorb/ \
- http://telia.dl.sourceforge.net/sourceforge/omniorb/ \
- http://unc.dl.sourceforge.net/sourceforge/omniorb/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= omniORBpy_${PORTVERSION:S/./_/g}
+DISTNAME= omniORBpy-${PORTVERSION}
MAINTAINER= ak03@gte.com
-LIB_DEPENDS= omniORB3.0:${PORTSDIR}/devel/omniORB
+LIB_DEPENDS= omniORB4.0:${PORTSDIR}/devel/omniORB
RUN_DEPENDS= omniidl:${PORTSDIR}/devel/omniORB
-# A pre-built omniORB3 source tree is required to build omniORBpy;
+# parts of omniORB4 source tree is required to build omniORBpy;
# see also the "post-extract" target below.
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/omniORB:build
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/omniORB:patch
+
+CONFIGURE_WRKSRC= ${WRKSRC}/build
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+OMNIORB_WRKSRC!= cd $(.CURDIR)/../omniORB && ${MAKE} -V WRKSRC
USE_PYTHON= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
-ALL_TARGET= export
-INSTALLS_SHLIB= yes
-WRKSRC!= cd ${.CURDIR}/../omniORB && ${MAKE} -V WRKSRC
-BUILD_WRKSRC= ${WRKSRC}/src/lib/omniORBpy
-MAKE_ENV+= CDEBUGFLAGS="${CFLAGS}" CXXDEBUGFLAGS="${CXXFLAGS}" \
- BSD_INSTALL="${INSTALL}" PYTHON_CMD="${PYTHON_CMD}" \
- MKDIR="${MKDIR}"
-ONLY_FOR_ARCHS= i386
-CONFIG_TARGET= x86_freebsd_4.0
-CPIO= cpio --quiet -pdum -R
+
+CONFIGURE_SCRIPT= ../configure
+CONFIGURE_ENV+= CC=${CC} CFLAGS="${CFLAGS}" CXX=${CXX} CXXFLAGS="${CXXFLAGS}" \
+ CPP=${CPP} PYTHON=${PYTHON_CMD}
+CONFIGURE_ARGS= --with-openssl=/usr --with-omniorb=$(LOCALBASE)
+
+CPIO= cpio --quiet -pdum
MODULEDIRS= CosNaming CosNaming__POA omniORB
DOCDIR= ${PREFIX}/share/doc/omniORBpy
EGDIR= ${PREFIX}/share/examples/omniORBpy
post-extract:
- @ ${MV} -f ${WRKDIR}/omniORBpy ${WRKSRC}/src/lib/
+ @ ${MKDIR} ${CONFIGURE_WRKSRC}
+ @ cd ${OMNIORB_WRKSRC} && find idl | ${CPIO} ${WRKSRC}
-do-install:
- @ ${INSTALL_DATA} ${WRKSRC}/lib/python/omniidl_be/python.py* \
- ${PYTHON_SITELIBDIR}/omniidl_be
- @ ${INSTALL_DATA} ${WRKSRC}/lib/python/Naming_idl.py* \
- ${PYTHON_SITELIBDIR}
- @ cd ${WRKSRC}/lib/python && find ${MODULEDIRS} \
- | ${CPIO} ${BINOWN}:${BINGRP} ${PYTHON_SITELIBDIR}
- @ cd ${WRKSRC}/lib/${CONFIG_TARGET} && find _omnipymodule.so* \
- | ${CPIO} ${BINOWN}:${BINGRP} ${PYTHON_SITELIBDIR}
+pre-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCDIR}/html
@ ${MKDIR} ${DOCDIR}/tex
- @ ${INSTALL_DATA} ${BUILD_WRKSRC}/doc/omniORBpy.* ${DOCDIR}
- @ ${INSTALL_DATA} ${BUILD_WRKSRC}/doc/omniORBpy/* ${DOCDIR}/html
- @ ${INSTALL_DATA} ${BUILD_WRKSRC}/doc/tex/* ${DOCDIR}/tex
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/omniORBpy.* ${DOCDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/omniORBpy/* ${DOCDIR}/html
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/tex/* ${DOCDIR}/tex
@ ${MKDIR} ${EGDIR}
- @ cd ${BUILD_WRKSRC}/examples && find . \
- | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EGDIR}
+ @ cd ${WRKSRC}/examples && find . \
+ | ${CPIO} -R ${SHAREOWN}:${SHAREGRP} ${EGDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/py-omniorb/distinfo b/devel/py-omniorb/distinfo
index ae5547d77716..352bcb705d04 100644
--- a/devel/py-omniorb/distinfo
+++ b/devel/py-omniorb/distinfo
@@ -1 +1 @@
-MD5 (omniORBpy_1_5.tar.gz) = 83ca601d289aaa3e32ede0775e71e546
+MD5 (omniORBpy-2.0.tar.gz) = ebe2ac26322feee11a4ab3ddb055992f
diff --git a/devel/py-omniorb/pkg-comment b/devel/py-omniorb/pkg-comment
index ef33507f8f81..dcb2a0862701 100644
--- a/devel/py-omniorb/pkg-comment
+++ b/devel/py-omniorb/pkg-comment
@@ -1 +1 @@
-Python bindings for omniORB, a CORBA 2.0 ORB
+Python bindings for omniORB4, a CORBA 2.6 ORB
diff --git a/devel/py-omniorb/pkg-descr b/devel/py-omniorb/pkg-descr
index c1385a71269b..e2404d658091 100644
--- a/devel/py-omniorb/pkg-descr
+++ b/devel/py-omniorb/pkg-descr
@@ -1,18 +1,23 @@
omniORBpy is an object request broker (ORB) for Python which implements
-specification 2.3 of the Common Object Request Broker Arhitecture (CORBA).
+specification 2.6 of the Common Object Request Broker Arhitecture (CORBA).
omniORBpy is implemented as a Python extension module (written in C++) to
-provide bindings for omniORB3, a high performance C++ ORB.
+provide bindings for omniORB4, a high performance C++ ORB.
-Some features of omniORB3:
-- Support for the Portable Object Adapter (POA)
-- Support for the Interoperable Naming Service (INS)
-- The Internet Inter-ORB Protocol (IIOP 1.0) is used as the native protocol.
-- The omniORB3 runtime is fully multithreaded. It uses native platform thread
- support encapsulated with a small class library, omnithread, to abstract
- away from differences in native thread APIs.
-- TypeCode and type Any are supported.
-- DynAny is supported (CORBA 2.2)
-- The Dynamic Invocation and Dynamic Skeleton interfaces are supported
-- A COS Naming Service, omniNames, is provided.
+Some features of omniORB4:
+- Support for GIOP and IIOP 1.0, 1.1 and 1.2.
+- Fully multithreaded runtime.
+- TypeCode and type Any.
+- CORBA 2.6 DynAny interfaces.
+- Dynamic Invocation and Dynamic Skeleton interfaces.
+- Complete Naming Service, omniNames.
+- Support for wchar, wstring and code set negotiation.
+- Full long long, long double, fixed point support.
+- PortableServer::Current.
+- Unix domain socket transport.
+- Bidirectional GIOP.
+- Interoperable Secure Socket Layer transport.
+- Flexible thread management.
+- Interceptors.
+- Fully interoperable with other CORBA ORBs.
-WWW: http://www.uk.research.att.com/omniORB/omniORBpy/
+WWW: http://omniorb.sourceforge.net
diff --git a/devel/py-omniorb/pkg-plist b/devel/py-omniorb/pkg-plist
index 01e35fc5f489..d65e6fddea9f 100644
--- a/devel/py-omniorb/pkg-plist
+++ b/devel/py-omniorb/pkg-plist
@@ -24,10 +24,20 @@
%%PORTDOCS%%share/examples/omniORBpy/echo/example_echo_nsclt.py
%%PORTDOCS%%share/examples/omniORBpy/echo/example_echo_nssrv.py
%%PORTDOCS%%share/examples/omniORBpy/echo/example_echo_srv.py
+%%PORTDOCS%%share/examples/omniORBpy/embed/GNUmakefile
+%%PORTDOCS%%share/examples/omniORBpy/embed/GNUmakefile.in
+%%PORTDOCS%%share/examples/omniORBpy/embed/dir.mk
+%%PORTDOCS%%share/examples/omniORBpy/embed/echo.idl
+%%PORTDOCS%%share/examples/omniORBpy/embed/embed.cc
+%%PORTDOCS%%share/examples/omniORBpy/embed/embed.py
+%%PORTDOCS%%share/examples/omniORBpy/fortune/fortune.idl
+%%PORTDOCS%%share/examples/omniORBpy/fortune/fortune_server.py
%%PORTDOCS%%share/examples/omniORBpy/poa/README
%%PORTDOCS%%share/examples/omniORBpy/poa/echo.idl
+%%PORTDOCS%%share/examples/omniORBpy/poa/mainthread.py
%%PORTDOCS%%share/examples/omniORBpy/poa/servantactivator.py
%%PORTDOCS%%share/examples/omniORBpy/poa/servantlocator.py
+%%PORTDOCS%%share/examples/omniORBpy/poa/singlethread.py
%%PORTDOCS%%share/examples/omniORBpy/random/README
%%PORTDOCS%%share/examples/omniORBpy/random/random.idl
%%PORTDOCS%%share/examples/omniORBpy/random/random_clt.py
@@ -37,20 +47,38 @@
%%PORTDOCS%%share/examples/omniORBpy/tests/pserver.py
%%PORTDOCS%%share/examples/omniORBpy/tests/tclient.py
%%PORTDOCS%%share/examples/omniORBpy/tests/tserver.py
+%%PORTDOCS%%share/examples/omniORBpy/tictactoe/README
+%%PORTDOCS%%share/examples/omniORBpy/tictactoe/gameClient.py
+%%PORTDOCS%%share/examples/omniORBpy/tictactoe/gameServer.py
+%%PORTDOCS%%share/examples/omniORBpy/tictactoe/tictactoe.idl
%%PORTDOCS%%share/examples/omniORBpy/weather/README
%%PORTDOCS%%share/examples/omniORBpy/weather/gauge.py
%%PORTDOCS%%share/examples/omniORBpy/weather/weather.py
%%PORTDOCS%%share/examples/omniORBpy/weather/weatherInfo.idl
%%PORTDOCS%%share/examples/omniORBpy/weather/wserver.py
+include/omniORB4/pydistdate.hh
+include/omniORBpy.h
+lib/%%PYTHON_VERSION%%/site-packages/CORBA.py
+lib/%%PYTHON_VERSION%%/site-packages/CORBA.pyc
lib/%%PYTHON_VERSION%%/site-packages/CosNaming/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/CosNaming/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/CosNaming__POA/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/CosNaming__POA/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/Naming_idl.py
lib/%%PYTHON_VERSION%%/site-packages/Naming_idl.pyc
+lib/%%PYTHON_VERSION%%/site-packages/PortableServer.py
+lib/%%PYTHON_VERSION%%/site-packages/PortableServer.pyc
+lib/%%PYTHON_VERSION%%/site-packages/PortableServer__POA.py
+lib/%%PYTHON_VERSION%%/site-packages/PortableServer__POA.pyc
+lib/%%PYTHON_VERSION%%/site-packages/_omnicodesetsmodule.so
+lib/%%PYTHON_VERSION%%/site-packages/_omnicodesetsmodule.so.2
+lib/%%PYTHON_VERSION%%/site-packages/_omnicodesetsmodule.so.2.0
lib/%%PYTHON_VERSION%%/site-packages/_omnipymodule.so
-lib/%%PYTHON_VERSION%%/site-packages/_omnipymodule.so.0
-lib/%%PYTHON_VERSION%%/site-packages/_omnipymodule.so.0.5
+lib/%%PYTHON_VERSION%%/site-packages/_omnipymodule.so.2
+lib/%%PYTHON_VERSION%%/site-packages/_omnipymodule.so.2.0
+lib/%%PYTHON_VERSION%%/site-packages/_omnisslTPmodule.so
+lib/%%PYTHON_VERSION%%/site-packages/_omnisslTPmodule.so.2
+lib/%%PYTHON_VERSION%%/site-packages/_omnisslTPmodule.so.2.0
lib/%%PYTHON_VERSION%%/site-packages/omniORB/CORBA.py
lib/%%PYTHON_VERSION%%/site-packages/omniORB/CORBA.pyc
lib/%%PYTHON_VERSION%%/site-packages/omniORB/PortableServer.py
@@ -61,8 +89,14 @@ lib/%%PYTHON_VERSION%%/site-packages/omniORB/URI.py
lib/%%PYTHON_VERSION%%/site-packages/omniORB/URI.pyc
lib/%%PYTHON_VERSION%%/site-packages/omniORB/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/omniORB/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/omniORB/any.py
+lib/%%PYTHON_VERSION%%/site-packages/omniORB/any.pyc
+lib/%%PYTHON_VERSION%%/site-packages/omniORB/codesets.py
+lib/%%PYTHON_VERSION%%/site-packages/omniORB/codesets.pyc
lib/%%PYTHON_VERSION%%/site-packages/omniORB/ir_idl.py
lib/%%PYTHON_VERSION%%/site-packages/omniORB/ir_idl.pyc
+lib/%%PYTHON_VERSION%%/site-packages/omniORB/sslTP.py
+lib/%%PYTHON_VERSION%%/site-packages/omniORB/sslTP.pyc
lib/%%PYTHON_VERSION%%/site-packages/omniORB/tcInternal.py
lib/%%PYTHON_VERSION%%/site-packages/omniORB/tcInternal.pyc
lib/%%PYTHON_VERSION%%/site-packages/omniidl_be/python.py
@@ -71,12 +105,16 @@ lib/%%PYTHON_VERSION%%/site-packages/omniidl_be/python.pyc
@dirrm lib/%%PYTHON_VERSION%%/site-packages/CosNaming__POA
@dirrm lib/%%PYTHON_VERSION%%/site-packages/CosNaming
%%PORTDOCS%%@dirrm share/examples/omniORBpy/weather
+%%PORTDOCS%%@dirrm share/examples/omniORBpy/tictactoe
%%PORTDOCS%%@dirrm share/examples/omniORBpy/tests
%%PORTDOCS%%@dirrm share/examples/omniORBpy/random
%%PORTDOCS%%@dirrm share/examples/omniORBpy/poa
+%%PORTDOCS%%@dirrm share/examples/omniORBpy/fortune
+%%PORTDOCS%%@dirrm share/examples/omniORBpy/embed
%%PORTDOCS%%@dirrm share/examples/omniORBpy/echo
%%PORTDOCS%%@dirrm share/examples/omniORBpy
%%PORTDOCS%%@dirrm share/doc/omniORBpy/tex
%%PORTDOCS%%@dirrm share/doc/omniORBpy/html
%%PORTDOCS%%@dirrm share/doc/omniORBpy
@unexec rmdir %D/lib/%%PYTHON_VERSION%%/site-packages/omniidl_be 2>/dev/null || true
+@unexec rmdir %D/include/omniORB4 2>/dev/null || true