aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-07-25 21:21:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-07-25 21:21:48 +0000
commit361c3ea3f99db94573f67e3fba7e9d9c95f32237 (patch)
treec1d86bc75623839e5459ec420b91f50a8f27e56f /devel/py-pefile
parent3548a49064d56f96aa159550f5386abb6e0a6f05 (diff)
Notes
Diffstat (limited to 'devel/py-pefile')
-rw-r--r--devel/py-pefile/Makefile26
-rw-r--r--devel/py-pefile/distinfo3
-rw-r--r--devel/py-pefile/pkg-descr5
-rw-r--r--devel/py-pefile/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/py-pefile/Makefile b/devel/py-pefile/Makefile
new file mode 100644
index 000000000000..fba7b3a075c7
--- /dev/null
+++ b/devel/py-pefile/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pefile
+# Date created: 16 July 2006
+# Whom: antoine.brodin@laposte.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= pefile
+PORTVERSION= 1.1
+CATEGORIES= devel python
+MASTER_SITES= http://dkbza.org/pefile/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine.brodin@laposte.net
+COMMENT= A python module to read and work with PE files
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-pefile/distinfo b/devel/py-pefile/distinfo
new file mode 100644
index 000000000000..d320ff6ceb1e
--- /dev/null
+++ b/devel/py-pefile/distinfo
@@ -0,0 +1,3 @@
+MD5 (pefile-1.1.tar.gz) = 6788c7555dfe4b6cd956bc8f03928e8f
+SHA256 (pefile-1.1.tar.gz) = a51b87ade802e8b06352ca5b1154281dbda9340da848d1e071ea06c5d9371c9b
+SIZE (pefile-1.1.tar.gz) = 19077
diff --git a/devel/py-pefile/pkg-descr b/devel/py-pefile/pkg-descr
new file mode 100644
index 000000000000..5c7b1fd9a6fd
--- /dev/null
+++ b/devel/py-pefile/pkg-descr
@@ -0,0 +1,5 @@
+pefile is a Python module to read and work with PE files. Most of the
+information in the PE Header is accessible, as well as all the sections,
+section's information and data.
+
+WWW: http://dkbza.org/pefile.html
diff --git a/devel/py-pefile/pkg-plist b/devel/py-pefile/pkg-plist
new file mode 100644
index 000000000000..710cb236f8c1
--- /dev/null
+++ b/devel/py-pefile/pkg-plist
@@ -0,0 +1,5 @@
+%%PYTHON_SITELIBDIR%%/pefile.py
+%%PYTHON_SITELIBDIR%%/pefile.pyc
+%%PYTHON_SITELIBDIR%%/pefile.pyo
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%