aboutsummaryrefslogtreecommitdiff
path: root/devel/py-protobuf
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2009-05-27 07:07:22 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2009-05-27 07:07:22 +0000
commit8cda4e21477958c26d6972a2cb3372a7b9ead3bd (patch)
treeca7f0eed9944ec084f9acfa238ad9414c0dd142b /devel/py-protobuf
parent5681ba78b4fba9b3a3384ba2c0fe8169025bf947 (diff)
downloadports-8cda4e21477958c26d6972a2cb3372a7b9ead3bd.tar.gz
ports-8cda4e21477958c26d6972a2cb3372a7b9ead3bd.zip
Notes
Diffstat (limited to 'devel/py-protobuf')
-rw-r--r--devel/py-protobuf/Makefile25
-rw-r--r--devel/py-protobuf/distinfo3
-rw-r--r--devel/py-protobuf/pkg-descr5
-rw-r--r--devel/py-protobuf/pkg-plist1
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/py-protobuf/Makefile b/devel/py-protobuf/Makefile
new file mode 100644
index 000000000000..7f044e9abfc9
--- /dev/null
+++ b/devel/py-protobuf/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-protobuf
+# Date created: May 27 2009
+# Whom: vanilla@
+#
+# $FreeBSD$
+#
+
+PORTNAME= protobuf
+PORTVERSION= 2.1.0
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Google protobuf Python Client Library
+
+BUILD_DEPENDS= protoc:${PORTSDIR}/devel/protobuf
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/python
+PROJECTHOST= protobuf
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/devel/py-protobuf/distinfo b/devel/py-protobuf/distinfo
new file mode 100644
index 000000000000..78e3ae2886cc
--- /dev/null
+++ b/devel/py-protobuf/distinfo
@@ -0,0 +1,3 @@
+MD5 (protobuf-2.1.0.tar.bz2) = 7aedd257d8723c128cc1529c4675f858
+SHA256 (protobuf-2.1.0.tar.bz2) = 55ead035337b248bb63243d2c6deeb42e5e88789109d14b5ae0beda6548928e1
+SIZE (protobuf-2.1.0.tar.bz2) = 1286218
diff --git a/devel/py-protobuf/pkg-descr b/devel/py-protobuf/pkg-descr
new file mode 100644
index 000000000000..2fc5c87aef30
--- /dev/null
+++ b/devel/py-protobuf/pkg-descr
@@ -0,0 +1,5 @@
+Protocol Buffers are a way of encoding structured data in an efficien
+yet extensible format. Google uses Protocol Buffers for almost all of
+its internal RPC protocols and file formats.
+
+WWW: http://code.google.com/p/protobuf/
diff --git a/devel/py-protobuf/pkg-plist b/devel/py-protobuf/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/devel/py-protobuf/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%