aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ptrace/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2010-10-08 13:21:00 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2010-10-08 13:21:00 +0000
commit702f663e184ff37ca3acea13fab63e728e2785f3 (patch)
tree7dd92c4d0399e53ab86c2671dafa550b938affb4 /devel/py-ptrace/Makefile
parent59af2613aa1febea5410c7621eb862dd4b5e53bf (diff)
downloadports-702f663e184ff37ca3acea13fab63e728e2785f3.tar.gz
ports-702f663e184ff37ca3acea13fab63e728e2785f3.zip
Notes
Diffstat (limited to 'devel/py-ptrace/Makefile')
-rw-r--r--devel/py-ptrace/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/py-ptrace/Makefile b/devel/py-ptrace/Makefile
index 1d310ac0bc1f..be6694fba7c3 100644
--- a/devel/py-ptrace/Makefile
+++ b/devel/py-ptrace/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ptrace
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,13 +16,17 @@ DISTNAME= python-ptrace-${PORTVERSION}
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= Python binding of ptrace
-RUN_DEPENDS= ${PYCTYPES} \
- ${LOCALBASE}/lib/libdistorm64.so:${PORTSDIR}/devel/distorm
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/distorm.so:${PORTSDIR}/devel/py-distorm
-USE_PYTHON= 2.5+
+USE_PYTHON= 2.5-2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= python_ptrace
+LICENSE= GPLv2
ONLY_FOR_ARCHS= i386
+post-patch:
+ ${REINPLACE_CMD} -e 's|libdistorm64.so|${PYTHON_SITELIBDIR}/distorm.so|' \
+ ${WRKSRC}/ptrace/pydistorm.py
+
.include <bsd.port.mk>