aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ptrace/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-06-15 11:47:44 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-06-15 11:47:44 +0000
commite06dc8998c83eb57db071e1c287dc862e0ce8e34 (patch)
treed6d60f3eb0590c5875a2ef01e2ec8b87f3dd4413 /devel/py-ptrace/Makefile
parentef1e3f841ada2bd7c725f87f30010189d1ab327a (diff)
downloadports-e06dc8998c83eb57db071e1c287dc862e0ce8e34.tar.gz
ports-e06dc8998c83eb57db071e1c287dc862e0ce8e34.zip
Notes
Diffstat (limited to 'devel/py-ptrace/Makefile')
-rw-r--r--devel/py-ptrace/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/py-ptrace/Makefile b/devel/py-ptrace/Makefile
new file mode 100644
index 000000000000..27a52e791e40
--- /dev/null
+++ b/devel/py-ptrace/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-ptrace
+# Date created: 2008-06-15
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptrace
+PORTVERSION= 0.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Python binding of ptrace
+
+RUN_DEPENDS= ${PYCTYPES} \
+ ${LOCALBASE}/lib/libdistorm64.so:${PORTSDIR}/devel/distorm
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.mk>