aboutsummaryrefslogtreecommitdiff
path: root/devel/py-px
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2002-07-19 02:34:48 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2002-07-19 02:34:48 +0000
commit4eda703f5c0c28835b4aa4720c075ff1d0d76333 (patch)
treeeaa7a13305e7fff61282836d6d2c17b7438e33e9 /devel/py-px
parent1e807601e1c305e820f8dcbb6ce0d033684f45fd (diff)
downloadports-4eda703f5c0c28835b4aa4720c075ff1d0d76333.tar.gz
ports-4eda703f5c0c28835b4aa4720c075ff1d0d76333.zip
Notes
Diffstat (limited to 'devel/py-px')
-rw-r--r--devel/py-px/Makefile20
-rw-r--r--devel/py-px/distinfo1
-rw-r--r--devel/py-px/pkg-comment1
-rw-r--r--devel/py-px/pkg-descr10
-rw-r--r--devel/py-px/pkg-plist4
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/py-px/Makefile b/devel/py-px/Makefile
new file mode 100644
index 000000000000..32d081f973ee
--- /dev/null
+++ b/devel/py-px/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-px
+# Date created: 19 July 2002
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+
+PORTNAME= px
+PORTVERSION= 0.6.8
+CATEGORIES= devel python
+MASTER_SITES= http://starship.python.net/~tmick/downloads/px/${PORTVERSION}/linux/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= python
+
+MAINTAINER= perky@FreeBSD.org
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-px/distinfo b/devel/py-px/distinfo
new file mode 100644
index 000000000000..1b455980ff57
--- /dev/null
+++ b/devel/py-px/distinfo
@@ -0,0 +1 @@
+MD5 (python/px-0.6.8.tar.gz) = 83ac34aba20ca4a4499bdf279523a755
diff --git a/devel/py-px/pkg-comment b/devel/py-px/pkg-comment
new file mode 100644
index 000000000000..dd5abbd428db
--- /dev/null
+++ b/devel/py-px/pkg-comment
@@ -0,0 +1 @@
+Perforce p4 wrapper and Python Perforce interface
diff --git a/devel/py-px/pkg-descr b/devel/py-px/pkg-descr
new file mode 100644
index 000000000000..a5907ddbf615
--- /dev/null
+++ b/devel/py-px/pkg-descr
@@ -0,0 +1,10 @@
+px is a wrapper around p4. It provides all the functionality of p4
+(defering work to it) plus it extends some standard p4 commands and
+adds a few new ones. If you are a Perforce user you might find these
+extensions useful.
+
+px uses p4lib.py, a Python interface to the Perforce client application.
+If you are a Python programmer and script Perforce you might find this
+module helpful. Currently, most common commands are supported.
+
+WWW: http://starship.python.net/~tmick/
diff --git a/devel/py-px/pkg-plist b/devel/py-px/pkg-plist
new file mode 100644
index 000000000000..b15aa642c354
--- /dev/null
+++ b/devel/py-px/pkg-plist
@@ -0,0 +1,4 @@
+bin/px
+%%PYTHON_SITELIBDIR%%/p4lib.py
+%%PYTHON_SITELIBDIR%%/p4lib.pyc
+%%PYTHON_SITELIBDIR%%/p4lib.pyo