aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pydasm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-04 17:42:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-04 17:42:48 +0000
commitd43f306ff49376569ad05277528f676aa7366691 (patch)
treeb080e8bd78d88836264b3b8cfb5b3e5e4b704182 /devel/py-pydasm
parent1a233b6392d3ce93d7e1443c7b8e0d6773c3db23 (diff)
downloadports-d43f306ff49376569ad05277528f676aa7366691.tar.gz
ports-d43f306ff49376569ad05277528f676aa7366691.zip
Notes
Diffstat (limited to 'devel/py-pydasm')
-rw-r--r--devel/py-pydasm/Makefile38
-rw-r--r--devel/py-pydasm/distinfo3
-rw-r--r--devel/py-pydasm/pkg-descr4
-rw-r--r--devel/py-pydasm/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/py-pydasm/Makefile b/devel/py-pydasm/Makefile
new file mode 100644
index 000000000000..f2414fcf0bd3
--- /dev/null
+++ b/devel/py-pydasm/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: pydasm
+# Date created: 23 March 2006
+# Whom: antoine.brodin@laposte.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= pydasm
+PORTVERSION= 1.4
+CATEGORIES= devel python
+MASTER_SITES= http://www.klake.org/~jt/misc/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= libdasm-${PORTVERSION}
+
+MAINTAINER= antoine.brodin@laposte.net
+COMMENT= A python interface to libdasm
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.if !defined(WITHOUT_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+post-install:
+.if !defined(WITHOUT_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/das.py ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-pydasm/distinfo b/devel/py-pydasm/distinfo
new file mode 100644
index 000000000000..7554bd4cb7d9
--- /dev/null
+++ b/devel/py-pydasm/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdasm-1.4.tar.gz) = bc13927d718edf8db7e5e3a7631b03dc
+SHA256 (libdasm-1.4.tar.gz) = 182603e7581e34c013c82811b0dcd4f7fc49f0e493d5e7ea1935a42408565d1f
+SIZE (libdasm-1.4.tar.gz) = 69303
diff --git a/devel/py-pydasm/pkg-descr b/devel/py-pydasm/pkg-descr
new file mode 100644
index 000000000000..1a12acc6fcda
--- /dev/null
+++ b/devel/py-pydasm/pkg-descr
@@ -0,0 +1,4 @@
+pydasm is a python interface to libdasm, the best x86 disassembling
+library out there.
+
+WWW: http://dkbza.org/pydasm.html
diff --git a/devel/py-pydasm/pkg-plist b/devel/py-pydasm/pkg-plist
new file mode 100644
index 000000000000..2fd7ba91261a
--- /dev/null
+++ b/devel/py-pydasm/pkg-plist
@@ -0,0 +1,5 @@
+%%PYTHON_SITELIBDIR%%/pydasm.so
+%%EXAMPLES%%%%EXAMPLESDIR%%/das.py
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%