aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pyral/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2017-08-17 16:31:48 +0000
committerMark Felder <feld@FreeBSD.org>2017-08-17 16:31:48 +0000
commita70393762bf5e6f5402e02e68c8374fdda54c427 (patch)
treea1730422870fd3fcde9b20af6f1a572b8d9e664b /devel/py-pyral/Makefile
parentc470100ba1842d9ee4ae0cd7d83d88918c7c0232 (diff)
downloadports-a70393762bf5e6f5402e02e68c8374fdda54c427.tar.gz
ports-a70393762bf5e6f5402e02e68c8374fdda54c427.zip
Notes
Diffstat (limited to 'devel/py-pyral/Makefile')
-rw-r--r--devel/py-pyral/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/py-pyral/Makefile b/devel/py-pyral/Makefile
new file mode 100644
index 000000000000..0fb781f9f820
--- /dev/null
+++ b/devel/py-pyral/Makefile
@@ -0,0 +1,22 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyral
+PORTVERSION= 1.3.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Rally REST Tookit for Python
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.12.5:www/py-requests
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>