aboutsummaryrefslogtreecommitdiff
path: root/devel/py-python-gitlab/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-10-15 14:16:36 +0000
committerSteve Wills <swills@FreeBSD.org>2019-10-15 14:16:36 +0000
commitddc15777b679ba58e093b8f7a6eebbbd8325ddeb (patch)
tree336473263a7c8f6667cbba4ff75ad498be2a7ca3 /devel/py-python-gitlab/Makefile
parent7c1dc01a2f8b462471c5abb96bb350f36e283264 (diff)
downloadports-ddc15777b679ba58e093b8f7a6eebbbd8325ddeb.tar.gz
ports-ddc15777b679ba58e093b8f7a6eebbbd8325ddeb.zip
Notes
Diffstat (limited to 'devel/py-python-gitlab/Makefile')
-rw-r--r--devel/py-python-gitlab/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/devel/py-python-gitlab/Makefile b/devel/py-python-gitlab/Makefile
index 0dcf70f2dfb5..e7f6d99d4d93 100644
--- a/devel/py-python-gitlab/Makefile
+++ b/devel/py-python-gitlab/Makefile
@@ -1,10 +1,14 @@
# $FreeBSD$
PORTNAME= python-gitlab
-PORTVERSION= 1.11.0
+PORTVERSION= 1.12.1
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= CHEESESHOP \
+ https://raw.githubusercontent.com/${PORTNAME}/${PORTNAME}/v${PORTVERSION}/gitlab/tests/data/:tests
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ todo.json:tests
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dereks@lifeofadishwasher.com
COMMENT= Interact with GitLab API
@@ -31,6 +35,14 @@ USE_PYTHON= distutils autoplist concurrent
SUB_FILES= pkg-message
+# todo.json is missing in the pypi dist file
+# https://github.com/python-gitlab/python-gitlab/issues/907
+# Once included EXTRACT_ONLY, DISTFILES, Extra MASTER_SITES, and the below post-extract
+# can be removed
+post-extract:
+ @${MKDIR} ${WRKSRC}/gitlab/tests/data
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/todo.json ${WRKSRC}/gitlab/tests/data/
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}/etc|g' ${WRKSRC}/gitlab/config.py