aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pyutil
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-05 07:12:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-05 07:12:31 +0000
commitc55574321c44ccda29f5ab410e2d5200f6094039 (patch)
tree74b051cfe1588cfe204cb5dfc36bd4a0bfe6b21d /devel/py-pyutil
parent07224b4a4cc5f25b1af1f9c91f483044479a8894 (diff)
downloadports-c55574321c44ccda29f5ab410e2d5200f6094039.tar.gz
ports-c55574321c44ccda29f5ab410e2d5200f6094039.zip
Notes
Diffstat (limited to 'devel/py-pyutil')
-rw-r--r--devel/py-pyutil/Makefile41
-rw-r--r--devel/py-pyutil/distinfo3
-rw-r--r--devel/py-pyutil/pkg-descr10
-rw-r--r--devel/py-pyutil/pkg-plist2
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/py-pyutil/Makefile b/devel/py-pyutil/Makefile
new file mode 100644
index 000000000000..1cab7f0c5aa6
--- /dev/null
+++ b/devel/py-pyutil/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-pyutil
+# Date created: 2007-5-31
+# Whom: Chao Shin <quakelee@cn.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyutil
+PORTVERSION= 1.1.0
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/p/pyutil
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= quakelee@cn.FreeBSD.org
+COMMENT= A collection of mature utilities for Python programmers
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+
+USE_PYTHON= 2.4
+USE_PYDISTUTILS= yes
+
+PYUTIL_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}-${OPSYS:L}-${OSRELEASE}-${ARCH}.egg
+
+PLIST_SUB+= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PYUTIL_EGG=${PYUTIL_EGG} \
+ PYUTIL_EGG_VER="${PORTNAME}==${PORTVERSION}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^from\ ez\_setup|#from\ ez\_setup|' \
+ -e 's|^use_setuptools|#use_setuptools|' ${WRKSRC}/${PYSETUP}
+
+.include <bsd.port.pre.mk>
+
+OSRELEASE!= ${DESTDIR}/usr/bin/uname -r
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-pyutil/distinfo b/devel/py-pyutil/distinfo
new file mode 100644
index 000000000000..8d4164526002
--- /dev/null
+++ b/devel/py-pyutil/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyutil-1.1.0.tar.gz) = df2219badcc7ae8ef4dfb6c81a7fc462
+SHA256 (pyutil-1.1.0.tar.gz) = 88a1b30f2895ca3181fcd5e0a839a06f420c1922b7bde9b35cb380fc26a5f73b
+SIZE (pyutil-1.1.0.tar.gz) = 47593
diff --git a/devel/py-pyutil/pkg-descr b/devel/py-pyutil/pkg-descr
new file mode 100644
index 000000000000..ae8fb50bf025
--- /dev/null
+++ b/devel/py-pyutil/pkg-descr
@@ -0,0 +1,10 @@
+These are a few data structures, classes and functions
+which we've needed over many years of Python
+programming and which seem to be of general use to
+other Python programmers. Many of the modules that
+have existed in pyutil over the years have subsequently
+been obsoleted by new features added to the Python
+language or its standard library, thus showing that
+we're not alone in wanting tools like these.
+
+WWW: http://zooko.com/repos/pyutil/
diff --git a/devel/py-pyutil/pkg-plist b/devel/py-pyutil/pkg-plist
new file mode 100644
index 000000000000..35cd05ee1ae2
--- /dev/null
+++ b/devel/py-pyutil/pkg-plist
@@ -0,0 +1,2 @@
+@unexec %%EASY_INSTALL_CMD%% -q -m -S %D/%%PYTHON_SITELIBDIR%% %%PYUTIL_EGG_VER%%
+%%PYTHON_SITELIBDIR%%/%%PYUTIL_EGG%%